please HELP! new member here.. pcie samsung 950 pro boot issue.

so i bought a samsung 950 pro 512gb and a pcie adapter card to use as a fast storage drive.
my current system is a rampage gene iv (x79) with windows 7 x64 installed on a raid 0 array (on intel controller) of 2x samsung 830 ssd’s i also have 2x WD 2TB drives in raid1 mirror on the same controller for storage. 3930k OC, titan x gpu and 32 gb ram.

problem:
i plug in the pcie drive, switch on, and my bios reset itself. then i had to load an old bios save and reapply all my settings… very annoying.
reboot, aand: "please insert valid boot media"

checked and the bios had assigned the (clearly recognised) new pcie drive as the priimary boot option.
fixed that, disabling it in the list and setting my raid 0 boot drive as first option.
reboot: “please insert valid boot media”
check, right drive is chosen, retry , same problem.
remove pcie ssd, boots fine.

ive done a lot of researching about this, but most posts refer to booting FROM a pcie SSD… i dont even want to do that. just want my machine to continue booting as normal, with an extra drive to use for stuff.

ive heard people suggest setting onboard controllers to ide mode… obviously not an option for the intel controller as i need the raid arrays.
i tried disabling the asmedia controller entirely (and setting it to ide - its unused) didnt help.
i read that disabling CSM (?) might help (a related sounding issue) . but if i disable CSM and reboot, it just dumps me immediately back in bios.
i installed windows7 non-uefi (it wouldnt get through the install otherwise and i was advised to) so i guess thats why disabling CSM doesnt work?

please somebody help, id rather not send this lovely drive back to amazon… particularly as i may well have ripped the box in half getting it out. DOH.

EDIT by Fernando: Unneeded multiple blank lines removed (to save space)

@robinlawrie :
Welcome at Win-RAID Forum!

It was not a good idea to purchase a Samsung 950 Pro SSD and to use it as "fast storage drive" with a system, which
a) is running Win7 as OS (no native NVMe support) and
b) uses the LEGACY mode MBR partition table and no GUIMODE Partition Table (GPT).
You cannot expect, that this combination will work.

Regards
Dieter (alias Fernando)

thanks for the reply, but i did do research before purchasing… i saw that x79 systems work fine with nvme drives as long as you only wish to use them for storage rather than boot.
a) nvme support is possible in windows 7 (there are a lot of people using nvme drives with windows7, you just need a driver installed)
b) my 3tb raid1 drives use GPT so im not sure what your point is? do i need my raid0 system array to be a GPT partition also?

since you obviously know about this stuff, something a bit more constructive than "you shouldnt have bought it and it cant work" would be nice, since other people with very similar setups have these drives working…
would reformatting my machine in uefi mode help? converting all drives to GPT?

@robinlawrie :
For me the usage of an extremely performant SSD like the Samsung 950 Pro only makes sense, when it is used as bootable system drive (drive C:).

The installation of the OS in UEFI mode is absolutely required, if you want to use the Samsung 950 Pro SSD.

ah but you see my requirements are specific. i am doing extremely complex fluid simulations, and i need somewhere to store the cache files. consider that these can be upwards of 3GB a frame, and the final cache file (single file) is anywhere between 300 and 500GB, i need all the speed i can get! if it were even possible, 10x the performance of this drive would still not be enough for realtime playback.

i think my raid 0 ssd 830’s are quite fast enough for booting :slight_smile:

im also running into the ram limits on my system, and with 32GB installed, i have no spare slots to upgrade, and 16gb ddr3 dimms are not available. so im also hoping that using such a fast drive for the windows pagefile will help me a little, although i read that pagefile is not greatly sped up by using these drives.

so… to be clear, my issue is specifically that i need to be in uefi mode? or are there likely other issues? as mentioned, ive seen many people online with x79 systems and windows 7 who have these drives functioning fine, so its not like i was an idiot for purchasing… nowhere have i found online the statement that uefi is needed, or i might have reconsidered.

thanks, Robin.

Yes, according to my knowledge there is no LEGACY mode NVMe Option ROM module available. An NVMe Controller will only be detected, if the system is running in UEFI mode.

thanks for the advice… however, that is strange, as the bios clearly detects the drive, it even sets it as the preferred boot device. or maybe that is not what you mean.

anyway im due an "upgrade" to windows 10, so i will download the iso and do a clean install in uefi mode… hopefully that will resolve my issues.

do you know of any incompatibilities with systems running the intel controller in raid mode, and a pcie ssd in the same system? this is my other concern.

@robinlawrie :
Before you are starting a clean install of the OS in UEFI mode, I recommend to unplug all storage drives except the target drive for the OS and the USB Flash Drive containing the bootable OS image.
Once the OS is up and running, you can reconnect all the other drives.

OK, i was hoping to leave the raid 1 storage array connected (its set as gpt) so i do not need to rebuild it… it took 12 hrs to initialise, and that was when it was empty.

its been ages since i reinstalled my pc… and ive never done it with windows 10… do i still need to copy raid drivers to the usb key and press a key (dont remember which) when installing? bear in mind my boot drive is a raid0 array.

actually now i think about it, i seem to remember having to install windows on a single ssd then migrate it to a raid 0 setup after… or maybe that was another machine, or another drive. bah… i dont remember.

ive been putting off reinstalling as ive got about 100 interellated softwares and plugins installed and working perfectly, and windows tweaked in a million different ways.

Provided, that you are runnig your Intel SATA Controller in RST mode, the Win10 in-box Intel RAID driver 13.2.0.1022 will detect your RAID0 array automaticly.

No, you should be able to install the OS directly onto the RAID array. I have done it very often.

hm, i got myself all ready to do my windows 10 installation, then realised that drivers are potentially unavailable for my old infiniband network cards… latest driver appears to be for windows 7.
so im going to have to stick with windows 7 as i cannot risk having no network.
dammit all this just to get a drive to work.

im now using Rufus to create a gpt bootable usb key with a windows 7 iso.
since ive got you here, any pointers for the instalation? ill need to find the raid drivers and put those on the usb key too i guess. and disable fast boot and secure boot? csm off?
do i need to recreate the raid array for the boot disk in the bios? with gpt? or do i do it when i create the partition to install in during windows installation?
i remeber the reason i didnt use uefi last time was windows would lock up at the splash screen during installation… what do i do to avoid this?

sorry for a load of questions, but you seem very knowledgeable about raid in particular, so ive gotta ask :slight_smile:

thanks!

I agree 3 times.

Probably not!

ok an update… i had a crap night with my 950 pro last night!

i created a gpt usb boot disk for windows 7
i decided to do a test run, so i umplugged all my raid drives, and plugged in an old corsair ssd i had lying around… i also used diskpart to make sure it was a gpt drive.
treid to install windows from the usb key with csm disabled.
windows got stuck on the “starting windows” logo screen as it did before ( the reason i installed as legacy bios in the first place!) i had read that installing from a gpt usb key and making sure it was set to boot as uefi would resolve this… not so.

so i tried again with csm enabled.
this time i managed to install windows on the gpt corsair ssd ( this is all with the pcie ssd plugged in)
at this stage i was able to boot into my new windows install.
installing the samsung 950 pro driver, i was finally able to see the pcie drive in windows (note this is in csm enabled mode!)
i ran some benchmarks.

atto (my normal bench tool) gave very wierd results… started well at smaller block sizes, 70 meg read and write for 0.5k blocks, going up to almost 1GB at 8kb block size… but then things went crazy… at larger block sizes the performance became almost random, with 512kb actually giving a result of 0 read and 800mb write. all other block sizes were much lower than expected and really random, read speeds ranging from 20MB/sec to 600.
i tried crystal diskmark, samsung magician and a host of others. most gave the expected great results, with samsung magician showing 2600MB read (!) and 1600MB write.
one other one i tested gave the same wierd results as ATTO.
i was happy to assume that it was just an old benchmark not working properly, especially since when i set up a ramdisk and copied a 10GB file, it copied in a couple of seconds at a speed of 2500+ mb/sec
however i then tried to unrar a system driver of 220 meg to the drive… this consisted of say 400 small files. normally id expect this to take 10-15 seconds on a lesser drive.
on the samsung drive it went at 20KB/sec and estimated 40 minutes to complete!!!
needless to say i decided this wasnt going to be acceptable.

i also tried rebooting and turning CSM off… it refused to boot windows, getting stuck at the “starting windows” logo as it did when installing.
i was about to give up, and i had another idea.
i formatted the samsung drive as MBR, and downloaded an unpacked windows driver for it, and copied it to my usb key.
i then rebooted, and tried to install windows on the samsung drive.
when it asked for extra drivers, i chose the ones on the usb key, and it worked! it told me i needed to delete the partition and create a gpt one. i did that, and windows installed fine! although it was a bit slower than i expected. - bear in mind this is running in legacy bios mode (since i could not install in uefi)

i finally got into windows, booting from an nvme drive, running on legacy bios, on an x79 motherboard. everyone says this should not be possible.
HOWEVER, i still got the wierd benchmark results, and worst of all, it refused to recognise my raid arrays when i reattached them… they simply did not show up in windows. this includes one that is made from GPT disks.

at this point i gave up, unplugged the drive, and went back to my old install. im very glad i didnt wipe those disks to do an install… id have been crying today.

so.
1: it is possible to use an nvme drive under legacy bios on an x79 board… even to boot from one.
2: performance is awful and unpredicatble.
3: i still dont know how to install windows 7 with CSM disabled.

i have filled out a return request with AMAZON. hopefully they wont mind the destroyed packaging.

one final question. im either going to get the samsung sm951 ahci version, or a normal sata ssd.
do you know if the ahci m2 drive is fine with older systems and legacy bios? ive heard suggestions that booting from it is problematic too!!

what a right mess.

EDIT: Unneeded blank lines removed (to save space)

@robinlawrie :
It really is a pity, that you obviously didn’t get the results you expected.
Thanks for your interesting report.

I am not sure, that this is a correct description of your results.
1. Have you tried to get Win7 installed in UEFI mode onto the Samsung 950 Pro? Note: Even with enabled CSM it is possible to get an OS installed in UEFI mode (with a separate EFI system partition).
2. You obviously were not able to get the OS installed onto the Samsung 950 Pro by using the “LEGACY” mode Master Boot Record (MBR). The modern GUIMODE Partition Table obviously has been required for your system (contrary to the Forum member and X79 Chipset user retiredfields, who reported >here< about having succeeded to get the Samsung 950 Pro SSD bootable as system drive on an MBR system).

Please have a look into >this< thread.