Plextor M5P 128GB keeps getting disconnected

I have another issue with my Plextor M5P 128GB SSD, w/c is set up AHCI as my boot drive (Win 7 - 64bit).

I notice that every time I shutdown my PC and turn it on later (minutes later, or the next day), the M5P disappears from the listed SATA devices in the BIOS, hence I can’t boot into Windows. I’ve tried changing ports from SATA0 to others, but it doesn’t solve the issue. So far, the only way I get it back is after I reset the CMOS. Anyone encounters this issue? Tried UEFI and Legacy boot options too, to no avail.

That seems to be either a hardware or a BIOS issue.
You should ask your mainboard manufacturer for an updated BIOS. Since Gigibyte has released yesterday a lot of new Z87 BIOS versions, there may be already an update available.

Thanks. I actually am already in the latest BIOS F7.

Thanks. I actually am already in the latest BIOS F7.

I have seen some disconnect problems fixed with the drive firmware, are you running 1.05 firmware. Personally I would secure erase the drive and try a fresh install.

What drivers are you using, Micro, chipset AHCI, or RST, try using the Micro driver and don’t update the driver.

Try a different Sata 3 cable.

I am in F1.05, ever since the start, right after I installed Win7 x64.

Tried different SATA 3 cables and Intel SATA ports already.

I’m sorry, what is the Micro driver?

Ever since the start, until now (with the above versions), it still happens intermittently (i.e. yesterday and the other day, when I boot in the morning, the problem doesn’t happen. I shutdown my PC at night. This morning though, it happened again. Performed a cycle of “ON/OFF/wait 1 minute/ON” for around 6 times, then it found the drive again and booted to Win7.

Until now I have no idea, which part of your system may have caused your issue.
Maybe a user with a Gigabyte Z87 chipset mainboard knows the answer.