Problem bad bios flash gigabyte sabre 17


i have a problem with a gigabyte saber 17 9462NGW.
I wanted to update the bios and after restarting the computer does not turn on anymore.
there is the led bulb blinking.
I reflashed with a soic 8 pliers and the file of this forum "gigabyte saber 17 k8 version f5" but it does not change anything.
On the official gigabyte site there is f10 update, i test but always the same problem.
thank you

I need bios for Sabre 17 P47K-V8-C35W10-FR Please

Please someone help me?


when i flash with neoprogrammer and my ch341a. everything seems to work.
I read the bios chip, I erase it, I program it then I check it and everything is ok.
However, the computer does not start.
is there anything missing for the bios to be correct please?

Flash the bios and read it back in a separate process and save it with a different name. Compare the results, flashed file and afterwards dumped should be 100% identical

I assume you did save a backup of your bricked bios. Post this backup of the bricked bios and the bios/ file you flashed.

Here’s the bios I used to flash.
On the other hand I have reflashed several times since I bricked it.
I made a backup of the bricked bios but it may not be reliable.

N8xEJEK(16M).rar (5.03 MB)

this is my backup after bricked

savebios.rar (985 Bytes)

Your backup is 16 MByte of “FF”, meaning that you probably didn’t have good enough contact to the chip, did choose the wrong chip, used the wrong program, whatever. Funny how many people make a dump/ backup without even checking if it’s valid- or if there’s at least some content!

As written before.

You might skip the ‘flashing again’ part, just read the content of the chip and compare it to what it should be.

there is an actual backup

newsave.rar (5.35 MB)

Well, that’s a Gigabyte F10 bios you got recommended at badcaps. If this is really read from the chip, then it’s properly flashed, and if this is the right bios for your machine, it should work. If the PC anyway doesn’t start then the reason isn’t the content of the firmware chip.

I don’t understand why the computer won’t start. before the bad flash of the bios everything worked

on the box it is marked sword 17-k8

nothing is missing in the bios for the file to be correct and the computer to boot?

N8xEJEK(16M)10.rar (5.35 MB)

someone told me that maybe the ME is corrupted

It might be something similar to my issue, which lfb6 solved! It might be different on your board, but in some instances you have a separate chip containing the Intel Management Engine (The ME). You should try to identify it and save a copy of it, then test it with ME Analyzer .

@McTeddy Here it’s different, the mentoined stock bios is a complete valid image with ME/FD, and it’s one single 16 MB chip. So if this firmware is properly flashed just as eric35 states and doesn’t boot anyway, then it’s not the firmware itself. And the ME of a stock bios (if not an update image) is normally supposed to be ‘clean’.

In addition it’s totally unclear what happenend here and since there’s no valid backup there isn’t even the possibility to look into the bricked bios to find out. See also

I wanted to update the bios but I made the wrong version. (I took the saber 17 version) he made me create a usb key on which I booted. I selected my key from a list and I launched the flash. I did not see if he went to the end. but it turned off and when I wanted to restart. no more reaction apart from the flashing led bulb.

I buy the f5 dump bios . I don’t know if I have the right to send it here

The request in badcaps was ‘to give a link’. It never was requested here.

I must have made a mistake