[Problem] Bricked Acer Nitro 5 AN515-52 N17C1 BIOS

After updating the bios, the screen is black and the fans are working for a few seconds, but the external screen does not work

I disconnected the device battery and bios battery for 30 minutes.
Still the same problem

please help me

Edit by Fernando: Thread title customized

Find out if there’s a specific recovery procedure for your machine. If there’s no such procedure of if it doesn’t work: buy a CH341a programmer, make a (better 2 or 3) valid dump(s) of the bios, compare to stock bios old and new version (UEFIToolNE, Hex editor) to find where the update stopped/ bricked the bios.

@ahmadobied898 :
Without any additional information it is difficult to help you.
Why did you try to flash an “updated” BIOS? Has it been an original or a modded BIOS? If the latter, why haven’t you asked for help before you flashed it? How did you flash the BIOS?
Please attach or post a link to the BIOS, which bricked your notebook.

P.S.: I have deleted the other thread, which had been started by you already in August about the same topic.

I sold the device and it told me that it had updated the BIOS and I think that it did not work with it because the BIOS was updated about a year ago.

this link



@ahmadobied898 :

If you have sold the device, you are not affected by the BIOS problem.

I buy and sell if the problem can be solved, I don’t mind buying it at a low price if there is a solution