[Problem] Bricked ASUS ROG Strix G531GT BIOS

3 weeks ago i’ve tried to upgrade the bios (from 307 to 308) by copying the downloaded file to USB and flashed with EZ Flash. But the upgrade process crashed at 0%. I’ve bough a CH341A recently and try AsProgrammer, CH341A programmer, NeoProgrammer but the only thing i get is the full of FF in any attempt of reading the chip. My BIOS chip is MX25L12873F. I’ve extracted body of the downloaded bios capsule from Asus website and flashed it using CH341A, but no luck. Can anyone help me to get biosreg or something that help me to recover my laptop from death. Many thanks.

Edit by Fernando: Thread title customized

Most of the time bad seating of the clamp, search the forum for the chip type and recommendations, seems that it’s not that hard to read.

To put it mildly it’s not a good idea to expect to be able to flash the chip properly if you can’t read it- the probability that everything is overwritten with FF / deleted by the flashing process is rather low since the update does contain a “hidden” ME region, but no FD. In addition it’s an even less good idea to flash something that you don’t understand the structure of into a chip- especially if you don’t have a backup of the former content.

The ASUS firmware is a bios region with an UEFI volume attached containing the flash program and additional stuff, not a complete Intel firmware image. Even if you were able to flash it correctly it’d been a 100% sure brick!


That’s the most simple simple structure of an Intel firmware (non- TXE 3-4):


Pray that you didn’t write to the chip- if the EC firmware got updated from the area it’s normally localized in bios region that can’t be fixed by your programmer. If that didn’t happen but you did overwrite parts of the firmware outside bios region you’ll need a firmware dump of another system. In addition machine specific data like serial, UUID, MAC, windows license may be gone.

Read the chip again until you get reproducable results- meaning that you read the chip 3 times, save the results to 3 different files and these 3 files are a 100% identical! Attach the result or post a link to it.

Too bad that i flashed 2 times. Old content is completely gone. I don’t know what to do now. Maybe i have to wait for someone to share the biosreg.

And you still don’t understand: You have a bios region, it’s the other parts you need.

And you still don’t understand: You have a bios region, it’s the other parts you need.

Wait, that means even if i flashed with programmer i can still get some data that is not in the .rom that i extracted from capsule?

Did you check what’s the content of your SPI chip? You couldn’t read it, what makes you think that you could flash it? Did you read the contents of the chip after flashing?

- If you get the Asus update file it’s bad news

- If you get FF then it’s probably bad contact again (and there’s a chance that you didn’t flash anything)

- If you get something else now- let’s have a look into it.

I will take a look at it tomorrow and show what i’ve got.

I have a running BIOS from other machine. I flashed it and my laptop booted and can go through BIOS Setup with F2. But it seems that it doesn’t reconize my SSD 860 EVO 2.5 inches anymore. And all of the Serial, MAC ID are gone now.

308_running.rar (8.29 MB)

As written, that is expected. These are normally recoverable from a bricked bios, but since these aeras of the bios region are overwritten now, they’re gone for good.

So are there any way to add them again to the bios. And are there any solution to fix the 2.5 inches detection?

You’ll have to find another bios dump to check where the data are stored and how they are structured. If they’re written clear text without any checksum you may put something in again. (I never saw this work on newer machines). Or you find someone on Asus support who will do that (never heard of it) of you find the original manufacturers programs to put in these data.

Regarding SSD- there may be different hardware versions of these notebooks, PCIe lanes and SATA ports can be differently configured. These information is stored in FD and can be changed with ME tools /FIT. But there will be countless possibilties, so again you’ll have to find a bios dump with your configuration stored in FD/ME.
I assume you did clear the CMOS?
Firmware you posted is a 100% stock bios, so reason for not recognizing the harddisk is not in bios region.
Otherwise it may be a hardware problem when disassembling/ assembling.

I’m out of this now- Good luck!

There is a friend on the internet want to help me with adding those info. But he doesnt know what to be dump to check where are those info stored and structured nor dont has a programmer. What need to be dump in Windows from a well working machine to get those info?

My friend sent me a biosreg which he backed up in Windows from a guide on this forum. Can anyone please help me.

G531GT.biosreg.zip (6.83 MB)

I have the exactly same problem, did you find a solution?