[Problem] Cannot get GOP working on MSI RX 580


I recently got an MSI RX 580 Armor 8G OC and it doesn’t want to work if I turn CSM off (blank screen until OS boots and drivers kick in). My motherboard is an ASRock z390 Phantom Gaming-ITX.

I already tried updating the GOP firmware using the tool at AMD and Nvidia GOP update (No requests, DIY), but it changed nothing.

I’ll attach here my original (and GOP-updated) ROMs:

(couldn’t upload for some reason, so I put them on on Google Drive)

@da_petcu21 - This is probably best asked in the GOP thread you linked, that’s where more users that can help might see it and reply. I can move it there after your next reply if you want?
Did you enable Secure boot in BIOS and set Launch Video OpROM Policy option in CSM menu (below disable CSM option) to UEFI instead of Legacy (Default)? The video option rom setting would need to be changed to UEFI if you disable CSM

No need. I managed to make it work by updating to a newer version of the BIOS from the TechPowerUp database (couldn’t find an update anywhere else).

Secure Boot is disabled (and I need it disabled). I have no other options in the CSM menu if I disable CSM. But anyway, it works now. Thanks!