Problem copying large files with Intel Rapid Storage Technology (iRST)

In the testing stage after having completed a new Haswell build the other day. My build is in my signature.

I have an issue when copying large files (i.e. 4GB or more) with iRST (v12.7.1.1000) from/to the Seagate 2TB HDD. For example, when copying/backing up multiple large files (like total of 10GB at a time).

At the start of copying, file transmission is quite fast (average of 150MB/s) but then it slows down after a while, even down to Kb/s rates (the copy process appears to have hanged and the window shows ‘Not Responding’), forcing me to stop the transfer. When observing iRST, I also noticed that prior to starting the copy process, it would show the Seagate drive having SATA Transmission=6Gb/s for that drive, but when the slow down happens, I recheck iRST and it then shows the transmission rate as 1.5Gb/s. Obviously this happens only when copying large files because copying smaller files are relatively faster and I guess by the time it starts to slow down, the copy has already finished.

Note that when I tried uninstalling iRST, the problem disappears. Unfortunately, I liked iRST because the transmission rates seem to be somewhat faster, especially w/ my boot C:\ Plextor drive. Has anyone observed this and/or know what’s causing the hangup with the Seagate 2TB w/ iRST installed? I already tried reverting to the previous iRST v12.6.x but had the same issue.

@ sherpa25:
Welcome at Win-RAID Forum!

I can confirm your experience while trying to copy very large files from or to my 2 TB Seagate Barracuda Green (ST2000DL003). Difference to your configuration: My Seagate HDD is connected with one of the ASMedia SATA3 ports and using the MS AHCI driver.
What do you mean, when you write "IRST"? Do you have installed the complete Drivers & Software Set or just the Intel RST AHCI driver?


Hi, thanks Fernando.

Are you saying that this also does happen to you, when copying files, they slow down and hang up eventually? However, you said you are using the msahci drivers. I don’t encounter it with msahci drivers, w/c are installed if I remove iRST I’m encountering the problem only with iRST installed, w/c puts iastor drivers.

For your question, what I meant was when Intel RST (v12.7.1.1000) drivers are installed in my system, copying large files tends to slow down shortly and then hangs the copy process. If I uninstall/remove iRST from my system, and try again to copy bulk/multiple large files again, it seems fine.

However, when iRST was still installed, it seemed faster for my SSD. Could it be just a problem with my Seagate HDD? How is it in your system? Thanks.

Hi there,

found something here about your drive (you two have the same model??):
//I’ve already seen that some 6Gbps SATA controller and 3Gbps disk misnegotiated on 1.5Gbps until controller was strictly limited to 3Gbps.//

or here:…ATA1/m-p/125102
last sentence here!
//The ST2000DL003 also has a four item “installation summary” on its sticker. The wording is nearly identical to the ST31000340AS except that it’s missing the sentence “If the drive is not detected, check the 1.5GB jumper” and there’s a blank area where Seagate used to have the image of the jumper block. The drive has a jumper block with no jumpers installed. The manual claims this drive can auto-negotiate to 1.5 Gb/s. //

So probably you have a faulty controller? Do you have any “other” controller on your board? JMICRON or something? The ports are usually colored in another color than your main ports. Try to connect the HDD there and try again.

Which firmware is on your HDD? I googled around and heard / read about a firmware bug, which could render the drive useless. It does not get detected in BIOS then … Probably your errors are warnings like “HEY, DO STH. OR I WILL QUIT FOREVER!” …



SHERP: Try an disable, sata aggressive link power management in your BIOS. Leave SMART on.

P.S. If your using the ACHI driver from RST, then try

Every system is different, the best thing is to test the SSD on the default MS ACHI driver, then a RST, see which one gives you better performance where you want it, either read or write.