[PROBLEM] How to open/modify/flash an Intel mainboard BIOS?

Still no trim after reflashing the mod’ed BIOS.

Is there a way to read the ROM to confirm that proper value is in certain address/offset?

It would have been easier to verify the successful flash of the modded BIOS, if the Intel RAID ROM version would have been changed.

No, but it may be a good idea to clear the CMOS and to redo all BIOS settings.

clear the CMOS didn’t help.

I have flashed the same version of the BIOS before using the mod’ed version that you have given me, so the RAID ROM version would have been the same. Is there a way to switch the RAID ROM to another version and then back to this version just to confirm the desired RAID ROM is indeed being used?

I double confirmed that I have flashed your mod’ed BIOS properly: I flashed previous version 42 and booted up fine, then I flashed your mod’ed BIOS again which is based on version 43, booted up fine and BIOS version shown as 43, so that’s no doubt that the mod’ed BIOS is being flashed, but still no trim.

Yes, that is strange, because the TRIM modded Intel RAID ROM v11.2.0.1527 worked for all other users.
And you are sure, that your SSDs do support TRIM?

yes, the SSD supports Trim, I just moved from a gigabyte p67 mobo, and Trim worked there in raid0 via a mod’ed BIOS.

Thanks for the quick reply.
Another idea would be to insert another version of the TRIM in RAID0 modded Intel RAID ROMs into your BIOS and to try that version. This way we can be sure, that the mainboard really has taken and using the modded BIOS.

Sure, I was wondering if you could put another version other than .1527 for me to try. For now, I have confirmed that 1527 is being used via CTRL-I during boot.

Ok, I will do it for you and replace the original Intel RAID ROM v11.2.01527 by the TRIM modded v12.9.0.2006.

@ seeking123:

Maybe I have detected the reason why you haven’t yet gotten TRIM in RAID0 support with the BIOS I had modded for you yesterday:

After having done a deeper look into the modded Intel BIOS by checking the GUID of all included modules, I found out, that the GUID E8441378-54D5-4D9D-B238-82343E6BA581 was listed twice at different locations. One of them was modded, the other not.
As a consequence I have done the TRIM in RAID0 modification with the other Intel RAID ROM module and saved the freshy modded BIOS.
At the end I extracted both modules and compared them with an hex editor. Both are modded and absolutely identical now.

Please flash the attached re-modded BIOS containing the TRIM modded Intel RAID ROM v11.2.0.1527 and report, if TRIM is working now.

Good luck!

EDIT: The attachment has been removed by me.

This mod is no good, as soon as the updater start reading the new BIOS it initiate system reset. Something obviously wrong, or perhaps going to a different version of RAID ROM you mentioned earlier next?

It is obviously a checksum problem, which prevents a successful flashing procedure. So a change of the Intel RAID ROM version may not really help.
I will try to solve the problem this evening or tomorrow and let you know the result of my work.

alright, sounds good. thanks!

@ seeking123:

Attached you will find the 3rd and last test version. If it should not work, I will give up.
Intel made it very difficult for users, who want to modify their BIOS (Option ROM modules are doubled and not within the CSMCORE file etc.).

Good luck!

EDIT: The attachment has been removed by me.

Still no luck, just like last time, system reset during flash.

Many thanks for your time on trying this out. Whenever you have the time, if you could build a TRIM modded v12.9.0.2006 for me one more time that would be great, wanted to see if that change anything. Thanks again for your help!

It is a pity!
Thank you for having tested it nevertheless. These are the experiences, which we need to get a better knowledge about how to circumvent the BIOS modding restrictions of the mainboard manufacturers.

You are welcome.
As soon as I have a new idea about how to get a TRIM modded Intel BIOS properly flashed, I will let you know it.

@ seeking123:

Meanwhile I have asked our BIOS modding expert CodeRush for a solution regarding the modification of Intel mainboard UEFI BIOSes named *.BIO.
He answered, that it is nearly impossible to get such BIOS modded, because Intel has implemented a lot of security features into their BIOSes to prevent such action.
The only chance to get an Intel UEFI BIOS modified is to do the following (not valid for Intel 8- and 9-Series chipet mainboards):

  1. Make a full DUMP of the BIOS chip by using an extern SPI Programmer.
  2. Modify the DUMP by using the UBU tool or doing it manually.
  3. Restore the modded DUMP into the BIOS chip.

Since I neither have the needed hardware (extern SPI Programmer) nor any experience with this sort of BIOS modding, I cannot help you to modify your Intel mainboard BIOS this way.

Nevertheless I have created a 4th test version of the TRIM in RAID0 modded BIOS for your mainboard. This time I just have used Andy’s Phoenixtool. The result is attached.
Please give me a feedback, if you have tried to flash it.

Good luck again!

BIOS-MOD4.rar (3.89 MB)

Just tried it, same issue - system reset… :frowning:

Thanks for another attempt.

It sounded like this BIOS can’t be mod’ed unless it is being taken to an external EPROM tool?

Yes, that seems to be the only possible solution.
Thanks anyway for having tested all my experimental modifications. Now we definitively know, that CodeRush was right with his statement.

supposed i can use the spi tool to read the bios, can you tell me which row/column (address) to change? thanks.