[Problem] How to re-enable USB Support in BIOS of a 2in1-Tablet


I have a big problema with my laptop\tablet, by mistake i disabled usb support… now i have no way to boot or change some setting in bios (no way to reset, short circuit or cmos reset) …i can only use windows 10 already previously installed…
I made a backup of the bios with AFUWINGUI, and i tried to enable USB support with the program AMIBCP5 but give me the advice : save secure rom as unsigned. and with AFUWINGUI does not allow me to flashing the bios giving me this error:18- Error: Secure Flash Rom Verify fail .

Someone can help me? there is a possible soltion? my goals are Reset the bios to default settings or enable the usbsupport in my backup rom.
i can send the backup rom if needed
Sorry for my bad english…

Thanks to all.
Matteo T.

Edit by Fernando: Thread title shortened and customized

It would be helpful if users provided, primary, tech specs… dont you think so?
And yes tools around like AMIBCP are useful when used correctly and in the right models, so no surprise what you get as this is not a simple click and done operations
I also like “shorts circuits” specially on other users systems…not mine


Otherwise these settings are stored in a part f the firmware called NVRAM and normally don’t get overwritten when updateing/ flashing bios. Might be that also serial and other machine specific data are stored there. Normally it’s not possible to edit single values, so one would have to reset all the settings… If it’s possible to flash that back without a programmer depends on the device. As written before post specs and bios backup.

@fpstasso92 : Welcome to the Win-RAID Forum!
As MeatWar and lfb6 have already written, the BIOS Modding Experts can only help after having gotten some information about the affected device (e.g. manufacturer and exact model name) and about the specific BIOS (attached or linked as .ZIP/.RAR file).
Good luck!
Dieter (alias Fernando)

Hello MeatWar, thanks for the reply.

The system is a IRULU W21 Tablet 2 in 1, with Atom Z3735F , Bios Aptio 5 Firmware ID: 3BAIR008 core version: 05.06 and project version 00.08. (IRULU is death and i can’t find a clear bios to flash… i searched everywhere)
The bios chip is: winbond 25q64fw1G

this is the link for download the bios backup: https:// megafile.cc/6A60/afuwin.rom

If you need other specs or info ask me.

thank you all really

Besides messing with bios and as you stated that still have current OS on the machine working, have you tried this:

[quote=MeatWar|p157164]Besides messing with bios and as you stated that still have current OS on the machine working, have you tried this:

Thanks, the system windows 10 work and i can reset the system…i have a clean windows 10 inside…my problem is that i can’t use the bios or bot something with USB because i disabled for error the support USB in Bios.
I would like to restore the bios for be enable to install other OS or what i want


There’s indeed a NVRAM key that’s called USBsupport, once in StdDefaults, and in one NVRAM volume, slightly different, several positions. In addition seems the second NVRAM volume got a little corrupted, several valid entries not linked to a guid?

One could edit your bios region backup, and try to flash it back using /N /SP, but use of keys may differ very depending on version of afuwingui, and this might have a relevant probability of brick. In addition it’d fell better to have a complete backup of the firmware, not just bios region.

Do you have a link to the manufacturer/ a stock firmware?
Can you find out your ME version?

IRULU company went bankrupt …there is no website to visit for download a clean bios/driver :frowning:
Where i can find the ME version?
AFUWINGUI v5.15.00.0064 32bit
Thanks for help

Edit by Fernando: Unneeded corrupted fully quoted post replaced by directly addressing to the author (to save space)

@fpstasso92 There’s no need for a (corrupted) fullquote every time, one can address other users bi @user
ME version: HwInfo will display, Sisoft Sandra, I think?

Btw is this legacy boot or UEFI? At least for UEFI firmware there’s a possibility to reboot into firmware settings from Windows:

[EDIT] Possibly TXE1? Download TXE System Tools v1 r4 - (2019-05-04) from this page.
Unpack it, open a command prompt as admin and change directory to …\Intel TXE System Tools v1 r4\Flash Programming Tool\WIN64 (or 32) (where you unpacked the tools).
Run fpt(w(64)) -i
If this doesn’t give you an error message post the output.
Then try to run fpt -d spi.bin
If this doesn’t give you an error you should now have a backup/dump of your complete firmware (spi.bin).

@fpstasso92 There’s no need for a (corrupted) fullquote every time, one can address other users bi @user

@lfb6 sorry for that
yes i can open the bios setup, the problem is that i can’t move inside it and i can’t do nothing because i need the usb support for the keyboard.
This is the HWinfo log : https:// megafile.cc/WRmE/log-hwinfo.log

Thanks. Bios isn’t touch enabled?
See the edit in the last post, I edited while you posted…

The attached file has the default settings in ‘USBsupport’, in second NVRAM removed invalid entries. You might flash it with AFUWIN /N /SP bios_un.rom
There’s no warranty that these really were the relevant usb settings, that this will work, that this will not brick your tablet. As written try to get a valid backup of the complete firmware before you try to flash anything so that you might recover from a brick with a programmer.

bios_un.zip (2.07 MB)

@lfb6 I tried, i unpack on C
i opened the cmd with administrator and i go in the folder for 32 bit version.
next i digit: start fptw -i
it opened another cmd window and closed it immediately automatically with no errors
i make the spi.bin : https:// megafile.cc/WRrd/spi.bin

PS. No touch screen function on bios

In Afuwin i don’t have the command /N
i linked 2 capture with AFUWIN options
https:// megafile.cc/6APD/immagine-2022-01-09-202111.png
https:// megafile.cc/AygA/immagine-2022-01-09-202135.png

ok i flashed the bios with the command:
it works perfect, thank you!!! give me paypal i pay you a beer!!
Thanks very mutch

@fpstasso92 Good to hear that it worked! Thanks for the beer, but I don’t have a ‘beer- account’ and that was really little work. If you really want to do something, use the paypal buttons for the forum on the first page

Take good care of the spi- file and the ‘fixed’ bios, just in case. (But keep in mind that spi.bin was done with USB disabled, so you have either to combine the first 4 MB of spi.bin with ‘bios-un.rom’ or just create a new full dump of the firmware with usb enabled the same way you already did.