[PROBLEM] HP Probook 6560b wrong ME firmware

Hi guys,

I’m new on this forum and would like to ask some help. Now im a proud owner of a Thinkpad W520, but before i could sell the 6560b i have to repair them, because there is a problem with the bios. Actually there is only one realizable issue: when i shut down the pc then turn on, i dont have net connection. I always get an error 10 on my Intel(R) 82579V Gigabit Network device. BUT! if i disable and re-enable i have net and error 10 disappier.

I source of this problem was a wrong ME firmware flash (I think so…), when i flashed a 2570p ME firmware to my 6560b. After that thing i can’t turn on my notebook only with the key sequence: Win+right arrow+left arrow (enable the writing to the ME region). And it was last summer since i ude this notebook without any other problem.

Hopefully I dumped and saved the original bios dump with the original ME. But im not able to enable the writing to the ME region because when i push the key sequence (win+right+left) the display stay black and the cooler start to spin on 100%.

I cant install any ME interface, because i get errors like (this computer isnt compatible and so…)

So here i need your help if you can! What can i do?

You will either need a pinmod or a hardware SPI flash programmer to reprogram your flash chip, as it’s in unpredictable state now.

So it doesnt matter its working (i can turn on, turn off, use …), I can’t repair it without hw mod? What if i flash a bios with this mod?:


Maybe the easiest way to buy a pre programmed one and solder them?

EDIT by Fernando: Put the inserted picture into the left side (looks better)

You were able to enable write access to the ME region in the past with that hidden HP key combo. Try reflashing the BIOS first in case you can make that combo work again as it’s the easiest way to fix your issue. Have you tried another combo I’ve heard (Right Arrow + Left Arrow and hit Power Button at S5 state)? If you can’t (for some reason unknown to me) to do that trick anymore then the only way is to do what CodeRush said. Try the “pinmod” first by sorting the two audio chip pins while the system is booting and test with Flash Programming Tool command fptw -d spi.bin (no error 26 or cpu access error). If that doesn’t help as well, then you need to get a programmer, desolder the chip, flash and resolder if you cannot flash while it’s embedded to the board. Never flash the ME region of another model, no matter how similar it might look. Small differences can cause actual system issues after flashing. When you find a way to reflash the ME region, attach me a dump and I’ll make you another one which has a cleaned+configured ME region ready for your exact system.

Now I tried your advice with the other combo in S5, but the red message didnt pop up. I tried to reflash the bios under Windows but everything the same. As I see we get a new bios update. I dont know it couild help or not. Now i have this version: F.61 Rev.A.

Anyway I have the original one here, so just have to find out how to enable write access to ME.

Ok, when you have read/write access to the ME region, use this spi image which is your provided Dump + Updated/Cleaned/Configured ME + Unlocked Flash Descriptor. Let me know how it goes.

orig 6560B (HM65,2520M)_fix_me_fd.rar (2.27 MB)

Thanks man!(No homo! :smiley: ) I appreciate it! But now I have to learn some car diagnostic stuff for my exam… So as soon as i will have more free time i will give a try to this mod.