Problem installing / running driver on ASUS Z87-A

I was sent here from the Windows Ten Forum. Please forgive me for not meeting the requirement: “Only users with a certain knowledge about what they are doing can calculate the risks of their work”. And please forgive a very long description of the problem.

The Win Ten Forum thread is at
http://www.tenforums.com/drivers-hardwar…ed-drivers.html
if anyone cares.

I have a performance problem which may be driver related. I have a program that reads hundreds of files from an SSD and build about 2GB of data in memory. After an upgrade-in-place from Win7 to Win10 this process would take about 30 seconds. After a clean reinstall of Win10 the process takes 3 to 4 times longer. Process Explorer shows the disk activity now happening in spurts with pauses of 20-30 seconds being common. The problem always happens but the length of the pauses varies.

I decided I should try updating my AHCI Controller driver and was directed to this forum for information, but I don’t really have the background to interpret what I’m reading. I [i]think[i] I should use either the Intel v131.0.1058 or v13.2.4.1000, but I had very bad results.

I installed driver 13.2.4.1000.
It made my original problem far worse. Files were loaded in spurts for about 30 seconds and then completely stopped. The program reported 52% of the files had been loaded. That did not change for another 30 seconds so I killed the program and rolled back the driver. In the Event Log I saw

About 20 iaStorA eventid 129 errors (Reset to device, \Device\RaidPort0, was issued) were logged,
followed by event id 7040 The start type of the Microsoft Standard SATA AHCI Driver service was changed from demand start to boot start.)
followed by a flood of Kernel PnP eventid 225 errors (The application x with process id n stopped the removal or ejection for the device PCI\VEN_8086&DEV_8C02&SUBSYS_85341043&REV_04\3&11583659&0&FA.)


I think the 225 events happened after I killed the program trying to load the files, but I’m not sure.
I rolled back the driver.

Since I’m not using Raid, and was not using any removable drives at the moment, I decided this was not a good situation.

I installed driver 131.0.1058.
I got only 17% of the files loaded before they stopped loading.
No iastor errors, but but the 7040 error and the flood of 225 errors were there.
I rolled back the driver.

Just for grins I tried installing the 11.2.0.1006, but Windows said I was more current.

Did I pick the wrong drivers?

Edit:
At the suggestion of Kbird on TenForum, I tried the v12.9.4.1000 driver. It did not produce the errors that the v13 drivers did and all the files were read. The read time was just a bit better than using the default Windows driver, but not by a significant amount.

Edit #2:
The program hung up again. This time it reported being 72% complete at the hangup. I mush have been lucky in my previous test. I’m going to roll back the driver update.

@pokeefe0001 :
Hello Patrick,
welcome at Win-RAID Forum!

I doubt, that your problem is caused by the tested Intel AHCI drivers. Otherwise thousands of users with a Z87 chipset mainboard would have reported about similar experiences.

Are you sure, that it is not this program, which causes your problems? Maybe it is not 100% compatible with Win10.
Please give us the name and the author of that program.
Question:
Have you ever encountered a similar performance breakdown while doing anything else than running your “program”?

If the used program should be ok, I suspect either a wrong BIOS setting, a suboptimal Win10 configuration or a faulty hardware as source for your problems.

Regards
Dieter (alias Fernando)

Hello Dieter,
I don’t know whether my performance problem really has anything to do with the drivers. I actually doubt there is any direct connection. I think I was directed to this forum because of the problems I had using the drivers I installed rather than because of the performance problem. Hopefully the Win10 forum will help me with the performance problem.

As near as I can tell, at least one of the drivers should have worked, and certainly should not have made the problem worse. I’m very puzzled by the EventID 225 errors I got while using the drivers.

I doubt that the problem is BIOS related. The problem did not occur until I did a clean reinstall of Windows. Following my original update in place there was no performance problems (but a lot of stability problems). No BIOS change when I did the clean install.

Or did you mean that the errors with the newer drivers was caused by out of date BIOS? That is certainly possible since my BIOS is pretty old.

Since you asked:
The program involved is the notation software Sibelius. It has many Win10 users. None that read various Sibelius Forums have seen this problem. I’ve asked. In addition, it didn’t have problems with it before I did the clean reinstall.

The problem occurs only when Sibelius is processing a large orchestral score - many instruments and many different music articulations causes it to read in many music samples. It seems to load them in parallel rather than sequentially. The Windows Resource Monitor shows hundreds of the files open at once when the pauses start happening. There certainly could be a sub-optimal Windows setting that makes this problematic (and that was changed by the reinstall), but I haven’t been able to find it.

Which Sibelius version are you using?

My advice:
1. Check the system files of your current OS by running the Command Prompt as Admin and entering “sfc /scannow” (without the quotation marks).
2. Make sure, that you are using the latest available BIOS version.
3. Set all BIOS settings to “Optimized Defaults” unless you have a strong reason to change the default setting. Avoid any overclocking!
4. Check the RAM sticks of your system by running a memtest.
5. Unplug temporarily all Disk Drives except the one, which contains the OS.
6. Change the “Power Options” (depending on your current setting either to “High Performance” or to “Balanced”).
7. If the problem persists, do a fresh install of Win10 (maybe there went something wrong during the previous installation).

Which Sibelius version are you using?



Sibelius 7.5
Zitat von Fernando im Beitrag #4

My advice:
1. Check the system files of your current OS by running the Command Prompt as Admin and entering “sfc /scannow” (without the quotation marks).




I’ve done that several times (plus a DISM Restorehealth), but I just it again. No violations found.


Yes, I supposed I should do that. But the performance was okay with this BIOS prior to the clean install.


Except for changing Boot order I have not touched the settings. I don’t know enough to do overclocking, and I don’t normally need it. If I get brave enough to update the BIOS I will take “Optimized Defaults”.


Could you elaborate on this? I don’t usually trust myself to mess with inside-the-case hardware. And I have needed files on an internal HDD. Do I need to do this just for a test?


I use “Balanced”. I’d rather not go to “High Performance” unless there is a good reason to. I do spin down my HDD after 20 minutes of non-use, but I don’t think that is involved in this problem.


I’ve been thinking about doing that for the last week

Sibelius 7.55.


Actual is v8.3. I am not sure, whether Windows 10 is fully supported by v7.55.

Do I need to do this just for a test?


Yes, it is just for testing purposes.
Maybe your PSU is not able to give all the Disk Drives enough resp. the required power.

I mis-typed. I’m using Sibelius 7.5 (not 7.55). It is fully supported on Win10. And as I said, it worked fine prior to the reinstall of Windows.

Hi P.

Dieter was asking you to run a memory test program , I use Memtest86 , it is Free , you burn a CD and then run it at Boot , and hopefully it does not report errors.

http://www.memtest86.com/


Are the files for Sibelius 7.5 being read off the SSD or HD , I was wondering as it maybe possible that the HDD or SSD is start to fail and having issues reading , there should be diagnostic software available for them too.


KB

@Kbird :
Welcome at Win-RAID Forum and thanks for your contribution!
Regards
Dieter (alias Fernando)

Thanks Dieter , and thanks for the Site , I have to admit to lurking here for a number of years and using your Modded Drivers for many too…since NForce…

Patrick had issues over on the Ten Forums and I suggested he post here and try and get your help , He just posted over there that he has bitten the bullet and has Reinstalled windows 10 again , and so far it seems to have fixed his issue.

I have a copy around somewhere, but I don’t know where. I haven’t used it in over 5 years. I’ll download new copy.

They are currently on SSD but I temporarily moved they to HDD. Loading was taking so long that I gave up after about 3 minutes. It was only 52% complete (as I recall).

But all of this is now in the past. The people that built the PC (Puget Systems - builder of custom PCs) recommended I try doing another clean install of Win10 before doing anything else. I did, and the problem has gone away. No more problem with performance. No more errors when installing Intel drivers. I have no idea what my previous “clean” install did to break the PC, but it is now fixed.

I may run memtest just to see what it says, and if I get really brave I may update BIOS, but for now I’ll just enjoy a working PC. (Well, I’ll start enjoying it once I get all the Windows setting back the way I want them. Grrr.)

@pokeefe0001 :
Asus Bios Update are very easy actually , I always do it from within the Bios itself , the utility is usually under Tools and is called EzUpdate , it will look for a USB2 Fat32 formatted Drive , you then point it to the bios file if needed, and answer a few Yes questions. If it is your 1st time it is a good idea to take photos/notes of the bios settings so you can check they are the same afterwards, as it is usually recommended to “load Optimised Defaults” just once and then go back in and set things up as before. My Asus bios also has the ability to export all the settings to a Text file , which is under the Tools>Profiles section. It will export the Text file to a USB so you can view it on any computer/tablet which is handy when setting the options again.

EZ Update FAQ
https://www.asus.com/support/faq/1012154

ezupdate on Utube
https://www.google.ca/url?sa=t&rct=j&q=&…125221236,d.cGc

EDIT by Fernando: Completely unneeded fully quoted text replaced by “@nickname” (to save space)