Problem: Integration of AHCI-drivers in Windows 2000 failed

Hello,

i want to build a Windows 2000 install-cd with integrated updates and AHCI-drivers. My testing-system is a real C2D-board with ICH9, no VM.
Setup always ended with error-message “The file xxxxx.sys is corrupted” (xxxx depends on driver(s) integrated, with intel-drivers it is “iastor.sys”).


Update: I opened the completed image, it seems the iastor.sys is missing in DRIVER.CAB (find in folder i386), is that right?

Thanks!

This error message usually indicates, that the user (or someone else) has integrated a driver with a wrong architecture (32bit/64bit).
A 32bit OS needs 32bit drivers, whereas a 64bit OS only will accept 64bit drivers.
Since a 64bit variant of Windows 2000 doesn’t exist, you should check the architecture of all integrated drivers.

What does this mean? Which specific driver(s) did you integrate?

Yes, i read a few times about that problem x32/x64, but i’m absolute sure i downloaded the right driverpackage. These are the links:
From Intel “STOR_all32_f6flpy_9.5.0.1037_PV”: https://downloadmirror.intel.com/18668/e…5.0.1037_PV.zip
And your package “Universal 32bit Intel RST AHCI+RAID driver v11.2.0.1006 mod+signed by Fernando”: https://1drv.ms/u/s!AjMjdZ6bIhRQg_sVgXGGNDO-ypUF3w

I also tried to integrate other AHCI drivers from AMD, nForce, VIA,…only for testing, but i got the same message: “amd_sata.sys/nvgts.sys/viamraid.sys (for example) is corrupted”…
So i guess something is wrong with .sys-files or integration with nLite isn’t correct. I did a similar task few years ago with Windows XP and had no problems with driver integration.

That would be more surprising for me than the assumption, that your used source CD contains Windows XP x64 instead of Windows 2000.
To save time you should look into the content of your source CD.

It is a Windows 2000 Professional - i used it two times for installation (IDE-Mode) and i can differ between XP and 2k Setup is also showing the well-known bluescreen with “Windows 2000 Setup”.

I used an image from this download: https://winworldpc.com/download/3f4dc3ab…c3-a4e284a2c3a5

Ok, i will try another image from this site…perhaps this one did’t like the drivers.

Okay, i tried 3 different images and got always the same failure with corrupted iastor.sys.

Can please someone do the same process and confirm that it works/not works? I have absolutely no idea whats going wrong. Either the driver-files are not W2k-compatible or nLite is processing wrong.

Next try:

  • I used XP Iso Builder instead of nLite → same error.
  • Today i integrated the same drivers in an untouched Windows XP Professional image with nLite → that worked, no iastor.sys-error

This indicates, that none of the previously loaded/integrated Intel AHCI drivers are usable with Windows 2000.
Tip: Try a much older Intel AHCI driver, e.g. the attached one.

32bit Intel MSM AHCI & RAID driver v7.8.0.1012 WHQL.rar (175 KB)

Thanks, but same error again :frowning: