[Problem] Lenovo X1 Yoga 2nd with AMT Firmware v11.8.90.3987

I have a Lenovo X1 Yoga 2nd. It now has AMT firmware It used to have full corporate capabilities, but now when I enter MEBX, it only shows me small business configuration. I ran MEAnalyzer on the firmware file and it shows:
Release │ Production ║
║ Type │ Stock ║
║ SKU │ Corporate LP ║
║ Chipset │ SPT/KBP-LP C ║

but somehow something must have changed so my AMT MEBX no longer has the full corporate capabilities. Is there a command line tool to reconfigure it to corporate?

I already tried a fpt64 -greset, but it did not help.

To clarify more, I attached screenshot of MEBx as well as meinfowin output. Would someone be willing to help me reset the ME data region of the SPI bios chip? My notebook has 1 spi BIOS 16 megabyte chip that contains the main BIOS and the ME 5MB full corporate firmware. I am scared of rendering my notebook unbootable. I downloaded the CSME 11 tools, latest version. I ran a firmware update to CSME 11.8 COR LP C NPDM v11.8.90.3987 from this site. It is still stuck in Small Business Mode instead of Full Corporate. I think what triggered this issue is that I changed my wlan adapter from AC 8265 (supported by CSME 11.8) to an AX 210 vpro version (may not be supported by CSME 11.8 Corporate ME firmware). But even when changing back to the old wlan adapter, my management engine does not return to full corporate and is stuck in small business mode.


Edit by Fernando: Thread title specified and customized

MEInfoWin.txt (4.01 KB)


MEInfoWinVerbose.txt (8.7 KB)