[Problem] LPT port doesn't work after Amibios 8 mod

Hi all
I have an old Gericom PC with Amibios 8
Could someone mod this bios
the problem is that the laptop has an LPT port that does not recognize the device
This device is a programmer based on the 74LS05 chip LPT to I2C
The programmer works on the EPP port in another laptop, but it does not work in this one
I’m not sure but I think the problem is DMA which cannot be turned off
In the BIOS settings you can only change the LPT Port address
Is it possible to modify the bios so that LPT port works in EPP mode ?

AmericanMegatrendsInc.-080014.zip (432.7 KB)

Edit by Fernando:
Thread moved into the “BIOS Modding Problems” Category and title customized

Hello. You can try my mod. Tried to replace Port Address options with Normal, Bi-Dir, EPP and ECP options. There is no built-in hidden Parallel Port Mode setting, so I had to go with replacement. CMOS token 3410 changed to 247C.

Hello @Sweet_Kitten

thank you for your work but not work for me.
In the printer port tab has actually changed and there is no DMA anymore but the programmer are not recognized.
The programmer work standard EPP port with adress 0378-037F.
The next problem is that I cannot enter the bios.
Bios frezze on the main tab but Win 7 start normally

There may be other requirements for the programmer to work you don’t know. Is there any way to check which mode is active?

I’m deleting the mod file as it didn’t help.

I also have Quatech SPP-100 pcmcia EPP true parallel port
when I insert it into this PC and install it as an EPP parallel port, the programmer works normally on the address 0378-037F

@Sweet_Kitten maybe I chose the wrong options when uploading your mod bios ?

which options should i select ?

You did everything right.
My mod is faulty.

@Sweet_Kitten can you look at it again with fresh eyes and think about it?
I am open to further attempts

Not willing. I think I won’t succeed.

There was one way to go in order to get port mode options, swap one value with another. I’ve never tried something like this. No wonder it didn’t work.

I’m able to unlock fully implemented settings (name handle + options handles are present), but in this bios only options handles are there for port mode.

Not sure why the mod didn’t work. It’s either my bad or the setting is problematic. Don’t know.
I can try unlocking another setting just to see if it’s me or not.

@Sweet_Kitten if you can, try it again.
Maybe it will work.
I was thinking about using a bios from another board but I don’t know which one
I know that Dell E1505 has the same board chips, but it does not have a Parallel port at all

It must be the same chipset model, RAM type and flash memory size.
You may end up bricking the board.

In the 2nd mod I tried to place the setting as non-external, maybe that makes sense.
080014~2.rom - Download

Edits in 080014~2.rom

In the 3rd one I set the Parallel Port Address setting values from the ones that ​​belong to the known workng Hard Disk Configuration setting.
For the test, if previous attempt would fail.
080014~3.rom - Download

Edits in 080014~3.rom

Mod V2 now i have the port setting menu in bios.
in general, the device does not work yet.
Mod V3 bad - change parallel port to IDE/AHCI :rofl:
At this stage I had to purchase a Parallel port tester but from China and i have to wait about 3 weeks.(cost 5 USD)
I need to check whether the pinout of my adapter is correct and whether changes in the bios cause any changes to the laptop port.
Thank you very much for now, I will contact you when the tester arrives
You are master

That’s what I planned.
In the very first mod I tried to turn Parallel Port Address into missing Parallel Port Mode setting. → Didn’t work, black screen.

In the 3rd, using the same method, Parallel Port Address into Hard Disk Configuration setting. → Worked.

Which means Parallel Port Mode is broken, thus why was not implemented in the bios.

In the 2nd mod I used a different method, the setting is not connected to any external structure and probably doesn’t do anything.

@Sweet_Kitten that’s what I suspected
in mod v3, if I go to the parallel port settings, I can choose between AHCI or IDE
the V2 are correct settings, but they probably don’t change anything