[Problem] RAM Usage of a Lenovo L3 15IML05

Thanks a lot

I own a laptop
IdeaPad L3 15IML05
A year ago, I bought a ddr4 - 2666 16gb
According to the information on the site here, the memory is compatible with the product:

The memory has been working normally, for a whole year, but two weeks ago it no longer supports the system.
The installed memory has become only 4 GB RAM
The system now works on 4 GB instead of 20 GB !
I checked the motherboard and all the ports, and made sure there was no problem.

Please help and thanks.

Edit by Fernando: Thread title specified and customized

I have read comments from Sweet Kitten
These files may help solve the problem


Thanks Sweet Kitten

I have a different problem.
Laptop supports:
- 4 GB RAM, installed with the motherboard (cannot be removed).
Additional memory slot (4 GB, 8 GB or 16 GB). It works on 16 gigabytes. SODIMM

2 weeks ago, Memory 2 is no longer defined.
The system does not recognize the presence of removable memory, except for the memory installed with the motherboard.

I tried running 4GB, 8GB or 16GB RAM. No benefit.
When accessing the BIOS
Memory only 4 GB
The problem is most likely related to the BIOS not recognizing the additional RAM.
I have done the following operations:
Update bios to the latest version
Reinstall Windows 10, once with an HDD and once with an SSD hard. I didn’t get any change.
I checked the device and hardware at a specialized engineer, and he confirmed that there is no problem with the ports or with the RAM itself.

Excuse me
I don’t know English well
Ask for help, even if it is for a fee.
My life has turned into hell. Because the resources of the laptop decreased from 4 GB memory only, and I was working on 20 GB for a whole year.

Now I understand.

It’s almost the same problem Here

Hi, I have tried all to no avail.
Today there is something new.
This is the information that appeared on the MemTest86 screen:

CPU Type: Intel Core i7-10510U @ 1.80GHz
CPU Clock: 1855MHz
L1 Cache: 4 x 64K (111931 MB/s)
L2 Cache: 4 x 256K (50495 MB/s)
L3 Cache: 8192K (27316 MB/s)
Total Physical Memory: 3850M (10,959 MB/s)
Number of RAM SPDs detected: 1
SPD #0: PC4-25600 DDR4 3200MHz / 22-22-22-52 / Lexar Co Limited LD4AS008G-H3200GST
Number of RAM slots: 2
Number of RAM modules: 1
DIMM Slot #0: PC4-21300 DDR4 2667MHz / Samsung M471A5244CB0-CWE
DIMM Slot #1: Empty

Windows and Lenovo only recognize one memory:
PC4-21300 DDR4 2667MHz / Samsung

It is almost certain that the problem is bios. This means that Lenovo is supposed to release a new update that will solve the problem.