[Problem] Struggling to unlock Razer Blade 15 Base 2021(RZ09-0369)

Good morning or good evening, I hope everyone here is doing well. I’ve been trying to follow guides on archived notebookcheck forums on how to unlock my Razer Blade 15 Base 2021’s BIOS to get everything from IMON SLOPE and memory overclocking unlocked. I’ve done the former with absolutely no issues but but have been going round in circles trying to achieve the latter, three times over infact. I’ve tried surpressing every flag I can find but I seem to continually be failing to unsurpress something somewhere. I tried to make the new link to the overclocking menu and went down the entire list, I believe at least, turning every value relevant to FF so it didn’t match and trip the suppression flags but i’ve come up flat. I’ve uploaded the original BIOS and my attempt at modding the BIOS (I’m changing the final BIOS file from .rom to .bin because I need to use CSME System Tools v14.0.20+ r18 to flash the file, just incase anyone is confused about the discrepancy though I imagine you’re all well above me in aptitude and knowledge haha). Any and all help/guidance would be greatly, greatly appreciate. Just want to let this laptop run truly loose since I’ve already managed to bypass the abysmal 35w lock. Thanks! Link to the BIOS i’m trying to get working: https: //mega.nz/folder/ PzwSmDJL#_dJIOIcZWVeGsl_So5KM7Q

Edit by Fernando: Thread title customized and shortened

Ok, I see that I’m not allowed to post a link yet with not enough posts, I hope making replies to this post satisfies the requirement? I apologize if this is the wrong way of going about it

I hope this third post will now allow me to attatch the mega link for the BIOS I have been working on.

@Coleh

Try my mod then respond to the result ,it was made based on the stock.rom you provided. (This mod is only for Coleh.)

You’re an absolute legend mate! It’s 99% unlocked he BOS and exposed the overclocking performance menu! The unfortunate part is that it hasn’t properly unlocked the memory overclocking section. Otherwise every thing else looks perfect. Thank you so much! If you’re able to diagnose why that might be and update it that’d be really kind too. Once more, thanks!

EDIT: Just to be explicit since I imagine it’s a bit confusing; only two options are changeable within this field; only TurnAround timing was adjustable

Screenshot 2022-04-02 081714.jpg


Just wanted to say I sent a small donation as thanks for the BIOS :slight_smile:

@Coleh

1. I thought i have abolished most suppressed in this bios ,so most hidden menus are visible now. Please capture screenshots and explain what is not unlock and let me know.
*.The stock.rom is not 100% clean as you have changed something under the OverClocking Menu.

2. There are two method to change memory freq.
(1) Load xmp profile :
Choose xmp profile1 or xmp profile2 under Memory profile. The number of xmp profile is depended on the bios detect and if the memory support xmp. Refer to your screenshot ,the memory seems not support xmp feature so it got a empty contents.
(2) Manusaaly adjust :
First set Memory profile = Custom Profile ,then tune “Memory Reference Clock” and “Memory Ratio”. For example , if you set Memory Ratio =11 ,you will get (133x11)x2=2933mhz(ddr4 300) ,set it to 12 then you will get (133x12)x2=3200mhz.

Some tips :
1. Not all of laptops can run ddr4 3200 stably , the bigest reason i think is that there is no heatsink cover the memory module and laptop only has limit space for dissipate heat. Only cpu and gpu has large copper conduit included. So ,ddr4 300 is a great freq and it’s stable.

2. If you don’t understand how to clear cmos on your machine ,don’t tune timing setting easily ,it may get a brick.

Hey, you’re right, i’m very sorry it seems in my own blunders i’ve lost the completely stock profile which was stupid of me. Here is an IMGUR link of what I see when i’m in BIOS and trying to adjust the memory settings. I am unable to adjust any of the given settings. I was hoping to follow the step in step 2 of making a custom profile, and thankfully these models should be able to clear CMOS via power button which I will be testing via TREFI first and then attempting to clear via power button for 45 seconds as reported by other users. If i’m unable to clear BIOS this way then I will avoid memory overclocking. I hope this helps!

EDIT: Otherwise everything else in BIOS is adjustable and works as it should :slight_smile:

@Coleh

Picture1:
You already loaded the xmp profile2 ,but its contents is empty.
Pucture2 :
You have to set "Memory profile" to Custom Profile at first then you just can manually adjust other settings.

The issue is I cannot select the profiles/change between them. In the images only those two blue lines can be changed. I enabled overclocking feature in BIOS of course but it doesn’t seem to be changing anything. I may have to check whether or not disabling CFG and Overclocking Lock via RU EFI is necessary if on your end everything seems correct

EDIT: This did not change it unfortunately, I still cannot switch between profiles.

@Coleh

1. Now i found i can’t understand what does your meaning , why you mentioned “OverClocking Feature”? The only features of OverClocking Feature is expend the full oc menu when you set it to enable.

2. Disable CFG Lock and Overclocking Lock is not related with overclocking memory ,why did you mentioned them?? They are processor patameter ,disable them you can activate ThrottleStop ,but no any assistance for memory.

I’m sorry if I’m confusing you, I did want to use throttlestop. I disabled the other features just to check if it was causing conflicting issues. As I said, I’m unable to change from XMP2 to custom profile. I am unable to determine why I cannot adjust the memory settings and just wanted to see if it would do anything. Do you think it’s impossible for me to change memory settings on this laptop?

@Coleh

1.Capture a screenshot under the Memory profile’s select items. I want to know what items you can see.

2. I Checked this bios again ,i’m sure when you set “Memory profile” to Custom Profile ,then the grayed limitation will be abolished.

3. Load the bios default then try to set it to Custom Profile again then check if the grayed limitation is disappear.

As I said, I outright cannot set the memory profile, none of those options can be interacted/changed/selected. I’ve uploaded this video, hopefully it is informative of my situation.

@Coleh

1. There are two new mod. After flash one of them if you can see XMP
appear on red line location ,then click it on if it can be set Enable or Disable ,try set one of them then option “Memory profile” should appear.


2. Now you already got the unlocked menus ,go into Advanced >> Power & Performance >> CPU - Power Management Control >> CPU Lock Configuration ,then you can directly disable “CFG Lock” and “Overclocking Lock” in the bios ,you don’t need to waste time to use RU.efi

Using the mod included in folder 3 and then enabled all the settings in memory overclocking menu to USER has now unlocked every single memory configuration, thank you so much!! You’re amazing!