[Problem] TYAN AMI BIOS modding for VMD support

Hi. Thanks for this great forum and any support.

Question #1: Many settings and specifically the ones I would like to look at changing ae under Runtime Error Logging. Seems odd that they would be there?

Question #2: The issue I have is that on this dual CPU platform there should be 3 + 3 VMD domains/pstacks. They do show in the BIOS, BUT only CPU1 pstack 0 and pstack 2 have VMD ports showing. 4 on pstack 0 and 2 on pstack 2. I’d like to get more ports available so that I can use VMD for a quad M.2 PCIe X16 card. The bifurcation is working. They are already set to Show = YES but I believe if I changed access/use to USER then they would be exposed in BIOS settings and should work as VMD and achieve what I’m trying?
Question #3: Flash is protected; I’ve checked the various how-tos. ME is not visible within the OS/HWINFO64. The chipset is C621. I tried MEINFO 9-16 and can’t get anything to detect. Always warns C621 or WHITLEY detected. Maybe I missed a version or is it that ME is hidden so this won’t work? Then how to unlock…?



7108V203.zip (7.21 MB)

So I must have messed up FPT 11 works to dump BIOS portion (rest is error 318)

AMIBCP reports saving secure unsigned…

Writing back fails with error 368.

Tried IFR extract and it doesn’t find locks.

Any suggestions please? Don’t use AFUDOS?


Nyce TYAN motherboard model… and by the way thank you for providing bios file or download link for users can help a bit…

Intel ME FW tools only works in OS environment if ME is present and loaded driver and if its bios enable (DOS/OS).

Thanks for replying.

Tyan board is 7108

I have an eeprom programmer and can read and write :slight_smile:

VMD enabled/disabled settings is available on both sockets CPU0 and CPU1 and 3 pstacks each. However only the CPU 1 has the VMD ports listed and available to enable… 4 on pstack0, 2 on pstack2.

I want to make VMD ports available on all pstacks.

I don’t know why these would be under Runtime Error Logging but that is the only place they are listed. I set them all to USER but the settings still do not show up.

Any help appreciated thanks.

Dont know how to perform your request… but any changes/mods cant be done with AMIBCP, its ineffective in modern AMI Aptio Core V bios, it has to be with IFR/HEX edit.
You should wait for another users opinions/tips, if its ever possible to do it.

Thanks for replying. I’m not sure why you thought it wouldn’t work that but I’ve dumped with eeprom programmer, edited in AMIBCP, re-flashed and the changes are successful: all VMD ports are now accessible and I’m able to create VROC RAIDs on the ones that were hidden.

In the unlikely event that anyone needs to know how…this thread.

My statement is based on user experiences and other reports, but ill correct it then… "Mostly new gen of AMI Aptio Core V bios"
It is known that it breaks CAPSULE bioses and that changes made sometimes require another module edit.
So congrats on your success… others dont have such luck with the same tool in recent bioses.


Thanks! Sorry I did not mean to sound like a jerk/condescending.

Edit by Fernando: Unneeded fully double quoted posts replaced by directly addressing