[Problem] Unable to Flash Modded HP BIOS

Hello,

I have an HP comet lake system with AMI apito V Bios which i’m trying to mod DVMT option from default to USER i have used AMIBCP 5.02.0031 to edit the option and save the bios image but when trying to flash the rom to bios using AFUWINx64 bios /P /B /K i get the following error: 12 - Error: No non-critical blocks found in ROM file. I also tried using afuefix64 with same result, I’m new to bios modding and i need some help

Regards

Edit by Fernando: Thread title specified and customized

@h3llb0y :
Tried to use intel FPT? make sure the bios you modded is the bios from your laptop dump, and it’s good to go to flash using intel fpt.

where can i download this tool?

thanks

You could download it here Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

just make sure to download the correct tool with the correct ME you have right now, otherwise i wont work. better to read the guide first and do the flashing.

@Koekieezz :
Hello again and thanks for your reply, i’m really a noob and dont get what to do, i have tried to download some files from the link you have provided they are all .bin format and i dont see any tool that could flash my bios file, if you could guide my further through the process.

Regards

@h3llb0y :
Sorry, i just changed the link, you could try using that one. search the one that says CSME Tool. also could you send your bios dump (dumped from your laptop)?

@Koekieezz :
I have backedup my bios using AFUWINx64.exe bios_back.rom /O and here is the dump file: https://mega.nz/file/zawBhAYa#L-EST565h5…Rce1qfwA7xZkoZk
also here is bios backup with intel fpt which has 4MB side difference, i used command FPTW64 -d bios_backup.bin here is the file dump: https://mega.nz/file/fC5ynDLC#Qf-KwIsVWh…HLuhRnMtEl3yK-8

thanks for your help

I have run the MEInfoWin64

BIOS Version 1715.40.15.0.0
MEBx Version Not Available
GbE Version Unknown
Descriptor Version 0.0
Vendor ID 8086
FW Version 14.1.53.1649 H Consumer
LMS Version 2130.1.16.1
MEI Driver Version 2131.1.4.0

PMC FW Version 140.2.1.1017
PCHC FW Version 14.0.0.7002

PCH Information
PCH Version 0
PCH Device ID 684
PCH Step Data A0
PCH SKU Type Production PRQ Revenue
PCH Replacement Counter 0
PCH Replacement State Disabled
PCH Unlocked State Disabled

FW Capabilities 0x31119140

Protect Audio Video Path - PRESENT/ENABLED
Intel(R) Dynamic Application Loader - PRESENT/ENABLED
Intel(R) Platform Trust Technology - PRESENT/ENABLED
Persistent RTC and Memory - PRESENT/ENABLED


Capability Licensing Service State Enabled
Crypto HW Support Enabled
End of Manufacturing Enable Yes
FWUpdLcl Enabled
Firmware Update OEM ID 00000000-0000-0000-0000-000000000000
Integrated Sensor Hub Initial Power State Disabled
Intel(R) PTT State Enabled
Intel(R) PTT initial power-up state Enabled
OEM Tag 0x00
PAVP State Yes
Post Manufacturing NVAR Config Yes
TLS State Disabled

FW Type Production
Last ME reset reason Unknown
BIOS Config Lock Enabled
Host Read Access to ME Enabled
Host Write Access to ME Disabled
Host Read Access to EC Disabled
Host Write Access to EC Disabled
SPI Flash ID 1 EF4018
SPI Flash ID 2 Not Available
BIOS boot State Post Boot
M3 Autotest Disabled
EPID Group ID 0x3565
Keybox Not Provisioned
RPMC Replay Protection Unsupported
RPMC Replay Protection Bind Counter 0
RPMC Replay Protection Bind Status Pre-bind
RPMC Replay Protection Rebind Unsupported
RPMC Replay Protection Max Rebind 1
Storage Device Type SPI
Minimum Allowed Anti Rollback SVN 0
Image Anti Rollback SVN 9
Trusted Computing Base SVN 1
Re-key needed False
HW Binding Enabled


FPF UEP ME FW
*In Use
— — -----
ACM SVN 0x00 0x00 0x00
BSMM SVN 0x00 0x00 0x00
EK Revoke State Not Revoked Not Revoked Not Revoked
Error Enforcement Policy 0 Disabled Disabled Disabled
Error Enforcement Policy 1 Disabled Disabled Disabled
Intel(R) PTT Enabled Enabled Enabled
KM SVN 0x00 0x00 0x00
OEM ID 0x00 0x00 0x00
OEM KM Present Disabled Disabled Disabled
OEM Platform ID 0x00 0x00 0x00
OEM Secure Boot Policy 0x00 0x00 0x00
CPU Debugging Enabled Enabled Enabled
BSP Initialization Enabled Enabled Enabled
Protect BIOS Environment Disabled Disabled Disabled
Measured Boot Disabled Disabled Disabled
Verified Boot Disabled Disabled Disabled
Key Manifest ID 0x00 0x00 0x00
Force Boot Guard ACM Disabled Disabled Disabled
PTT Lockout Override Counter 0x00 0x00 0x00
Persistent PRTC Backup Power Enabled Enabled Enabled
RPMC Rebinding Disabled Disabled Disabled
RPMC Support Disabled Disabled Disabled
SOC Config Lock State Enabled Disabled Enabled
SPI Boot Source Enabled Enabled Enabled
Txt Supported Disabled Disabled Disabled

OEM Public Key Hash FPF 0000000000000000000000000000000000000000000000000000000000000000
OEM Public Key Hash UEP 0000000000000000000000000000000000000000000000000000000000000000
OEM Public Key Hash ME FW 0000000000000000000000000000000000000000000000000000000000000000

Edit by Fernando: Put the details into a “spoiler” (to save space)

I have tried flashing the modded bios here is what i get:
C:\Users\qudah\Downloads\CSME System Tools v14.0.11- r1\Intel CSME System Tools v14.0.11- r1\Flash Programming Tool\WIN64>FPTW64 -f bios_back.bin

Intel (R) Flash Programming Tool Version: 14.0.11.1205
Copyright (C) 2005 - 2019, Intel Corporation. All rights reserved.

Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
W25Q128FV ID:0xEF4018 Size: 16384KB (131072Kb)


Error 167: Protected Range Registers are currently set by BIOS, preventing flash access.
Please contact the target system BIOS vendor for an option to disable
Protected Range Registers.

FPT Operation Failed.

Thanks for your help

No luck.
By the way, only HP OEM flashing utility can flash BIOS.

@Sweet_Kitten :
so no solution to flash modded bios? :frowning:

I don’t know. I did it once, but ended up bricking the device. It is very dangerous.
[Request] Unlocking HP Envy x360 Laptop BIOS (2)

@h3llb0y

It is not a good idea to run a command from within any personal sub-folder (too long path and too many error options). It would have been better to copy the FPT sub-folder named "WIN64" into the root of drive C: or D:.
FPT Command example: C:\WIN64>FPTW64.exe -f bios_backup.bin

Usually it is not a big problem to get a modded BIOS properly flashed into the chip of "normal" mainboards (from ASUS, Gigabyte, ASRock, MSI etc.), but Companies like HP protect their BIOS Chip extremely good against any modification done by the user.

I think he need to disable the bios lock?

Variables are also locked.

Variables are also locked.





so there is no way to disable Protected Range Registers?

thanks