Problem with dumped ME

Dear plutomaniac!

Please I need your help. Had to flash a new bios to my Notebooks board with spi flasher. Problem was the original dump was faulty, so I had to take one from another machine.
Everthing works fine except the ME Region errors like black screen while booting…

Tried several methods und guides but I simply can’t figure it out how to get thing straight.

Please, would you help me?

You need to give a lot more info on what the problem was, what you did, what files you used, what exact system you have and so on.

Sure, I am sorry.

The machine is a thinkpad T470s. As I said I had to flash the Bios with SPi Flasher because it was bricked. Poblem is, that I had to use a Bios someone provided from the same machine. Didn’t know at first but as the machine was running again it did strange things like booting but no screen and in general booting is really slow. This is at the moment the only problem I encountered.

Tried some techniques already to get the me region problem fixed but nothing works or I am simply to dumb.

Analyzed via Me Analyzer got the following:

Family: ME
Release: Production
Type: Region, Extracted
FD: Locked
SKU: Corporate LP
Rev: C0
VCN: 173
PDM: Unknown
PV: Yes
Date: 16/11/2016
FIT Ver:
Size: 0x603000
Platform: SPT/KBP
Latest: Yes

As I said tried different Guides with different techniques like trying with a Hex Editor.
Tried to upload the used bin file but it is to big for uploading.

I 've tried the Easy Clean method but alway got no result and couldn’t load my bios file. Also tried to work trough the Guide with flash image tool an once it loaded my bios.bin and other times I got errors loading the file.
I am working with the .bin file that I flashed and is working, maybe my fault was to not make another dump from the machine to work with that. As I read in one of your guides the Data segment should be initialized but in the me analyzer reading I provided, there is no Data information.

The whole thing is no to me and I am really confused whre I am going wrong

Tried different Flash Image Tool reversions. Evertime I try to load my bios dump it states, can’t open file reverting to default.

Also tried fptw -greset and get an error (pic)


Download and use the latest version of ME Analyzer. Compress & attach/upload/link-to the dump you flashed.

I tried to compress the files but they are even to big to upload. But I managed now with the newest version of Easy ME Clean to get to version which were looking ok.
One of them I flashed just now but the same problem with black screen at boot and booting takes longer than expected.…yKSXuJOv6D-Y3lw

Provided the files via Google Drive

t470s.bin → was the file I started with
t470sdump → file I dumped from my machine with spi programmer after flashing t470s.bin in the first place

t470s_dump_11_6_12.bin → is the 1. file I created with Easy ME Clean
t470_dum_easyclean.bin → is the 2. file I created with Easy ME Clean

checked them with ME Analyzer an one has File System State initialzed and the other Configured

These “Easy ME Clean” programs are trash, delete and don’t use them. What you need to do is follow [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization on a dumped SPI image before flashing it back. In your case, the provided dumps have severely corrupt CSME firmware File Systems and are neither safe to flash nor capable of being cleaned via Flash Image Tool. You need to find a proper dump for that model and use that for CSME firmware cleaning, exactly as instructed in the aforementioned guide. The BIOS update from Lenovo includes the BIOS region only and not full SPI image so that is not helpful in your case.

Ok just as I suspected. But I really don’t know how to get a full image. The t470s.bin was already one provided from somebody else. I have another one from the same person but I think it has the same problem.
Also googled for some time and didn’t find anything. When worse gets worse I think I have to live with the problems I have. Machine is running and no unwanted reboots till now.

But I try to get another image. How can I verify if a new image is right for the process? Just checking with ME Analyzer?

Thanks for your help!

Found a legit dump checked with Me Analyzer and followed your guide except I didn’t understand the section with the platform protection. left this steps.
Following the guide I got an outimage.bin, checked with ME Analyzer and looks ok.

If you would take a look, the files are on the GoogleDrive Link.

Thank you very much!!

Yes that new dump is healthy. To check the firmware code + file system health, drop it in MEA and use “-unp86 -bug86” parameters. If you don’t see any red/error messages, the firmware is healthy. The CleanUp Guide clearly indicates how to proceed at step 7, depending on what you see. Read the first three sentences again carefully.

Checked like you said, everything is looking fine! Also took a look on the Clean guide again and I did it right as I have no section Platform Integrity. Will flash the file and see what happens! Thank you so very much for your help!

Just wanted to let you know everything worked fine, the flashed .bin which I got following your guide ist fully working. Thank you so very much for your support and patience!

Great, I’m glad the guide solved your issues. Could you temporarily upload again that corrupted dump you had so that I can keep it as an example/sample of a badly broken CSME File System?


You are Welcome :slight_smile:

Thanks again!

Got them, thank you. Enjoy your repaired system!

now i am in the same boat !! accidentally flashed the system and the system is now in a un usable state !! the flash bin from lenov is too large to flash into the system :frowning:

See #2- seems you’re really in the same boat…

I am on T470 Lenovo with serial number PF11C5D1 which is a i7 core gen 7 laptop. as this got old i felt like playing with coreboot and accidentally flashed it with wrong bios and then my problems started, luckily I backed up a old bin file. the new firmware files to flash on the lenovo website are all 9mb or larger where as when I try to flash using that it is throwing me all kinds of errors like size is large. totally lost in how to find the right bin file for the lenovo T470 to flash with a CH341 bios firmware flasher !

Lenovo doesn’t provide complete firmware images, the lenovo bios updates are only bios region. Attach / post your ‘old bin file’.

the backed up bin seems to be this one