Problem with installing Win7 on Ryzen 5900HX + 6600m

Good afternoon! There is a need to install Win7 on miniPC Minisforum HX90G. miniPC has a 5900HX processor and 6600m video. Chipset drivers are integrated into the Win7 distribution ([Solution] Win7/8.1 Drivers for USB 3.0/3.1 Controllers of new AMD Chipset Systems) , as well as all updates from SimplixPack. Integrated modified Intel225v drivers (Installing i225-v ethernet drivers (W10 drivers) on windows 7? - #3 by justintime20).Win7 successfully copies itself to disk, and hangs after the first reboot. Booting in safe mode does not help. In ntbtlog we see:

I didn’t find how to disable 225v in the BIOS. When the iGPU was turned off in the BIOS, Audio was also turned off there, but when booting from Win PE, they are still in the system. The Win7 image proposed here ([Solution] Win7/8.1 Drivers for USB 3.0/3.1 Controllers of new AMD Chipset Systems) behaves the same way.
Help solve this problem. I’m sorry for the bad English

If you meet hangs after the first reboot, I think it is the USB driver problem, don not use the usb driver in SimplixPack, use the USB driver package for ASUS only.

1 Like

Good afternoon Thanks for the recommendation. I have already moved beyond this point on my path. For the followers, I will note a few points:

  1. You need to install a clean Win7. The assembly with all updates hangs on the flag. Even an already installed system starts to freeze after installing the UpdatePack. Later I’ll try to figure out what update leads to this.
  2. The image was prepared using Flashboot pro, an item with the integration of usb and nvme drivers. But these drivers did not make usb 3 work. I had to additionally integrate modified drivers from canonkong ( -controllers-of-new-amd-chipset-systems/33603)
  3. Disable Above 4G Decoding in BIOS. Without this, VgaSave throws an error.

After that, the installation is completed and the system works

At the moment, did not solve the problem with the video card drivers. The computer has a discrete 6600m graphics card. There are no original drivers for Win 7, only 10 and 11.
I assumed that you can get the rx6600 video card drivers to work, since they are relatives. On rx6600 there is a version for Win 7.
Editing in the ven/dev inf file didn’t help. As well as forced installation of an unmodified rx6600 driver. When installing, it says that this software does not work in this version of Windows, I checked that this is the latest version of drivers for rx6600 for Win 7.
After that I tried installing from DriverPack Snappy Driver Installer (SDI). Some new drivers have been installed on the video
Снимок (3)
Their release date is fresher than the latest official driver for Win 7 for 6600. Therefore, I suspect that the driver for Win 10 was installed.
But in the control panel, the device is error-free and looks as it should.

But the device still doesn’t work. The resolution is small and does not change. In the properties of the screen it looks like this:

There is no monitor in system devices.
Also here you can see that the current driver is VgaSave, and not 6600, as the device manager

I ask you for advice on how to move forward?