Problem with Samsung SM951 NVMe SSD

Hello everybody. I have sm951 , died after using the m2-usb adapter.
(I had to buy an adapter because the main pc died, but old was no m2)
now get a new pc with m2. tried to restore ssd, but without success.
I think the firmware went off due to poor power management on the adapter.
when the pc turned on with this ssd, ssd emits a quiet ultrasound, then pc waits for ~30 seconds, and starts to loading. OS defined only controller, and that’s it.
I tried to close the rom-pin for reinstall firmware, so ssd displayed as a disk that needs to be initial with Gpt/MBR, which offc ends with an error.
firmware utils available in google do not see ssd, magician too.

please help me, any way what can I do?

ps, i attach how the controller shows, first one - without drivers, next one - if install nvme driver from samsung.



EDIT by Fernando: Threads title specified

@lalala987 : Welcome to the Win-RAID Forum!
The Samsung SM951 SSDs were only delivered to OEMs and were not designed for for being directly bought by the customers. That is why Samsung doesn’t support their users with Firmware updates and drivers.
Nevertheless your Samsung SSD should work fine with all Windows Operating Systems from Win7 up, if you have chosen the required BIOS settings (enabled booting in UEFI mode and disabled “Secure Boot”) and use an appropriate NVMe driver.
1. Which OS are you using?
2. Can you boot off the SM951?
3. Which specific Samsung NVMe driver did you test?
4. Which error has caused the yellow flag within the Device Manager (do a right-click into the listed Samsung NVMe Controller and choose the option “Properties”)?
Dieter (alias Fernando).

@Fernando : hi thanks for the answer.
0, I have it by default. (enabled booting in UEFI mode and disabled “Secure Boot”)
1. win10x64
2. I don’t quite understand what you mean. in the post two options for loading a PC with this ssd, the first is simple, and the second is with a jumper for the ROM-pin.
3. general nvme-driver from the official site. same page where DL all staff like Magician and firmware. not special.
4. I have shown on screenshots, I/O error. code 10. there is no more useful information there.
ah, and information difference with/without driver only in the name of the controller, it becomes samsung.
and in place of “I/O error”, inscription changes to “object not found”. thats all. nothing really change.

This behavior is typical for a situation when the firmware gone. poor power management of the adapter has done an evil deed.
usually this case - easily re-flashed, but I cannot find a utility to flash this model …

Did you already check >this< thread?

yes, this utill dont see the ssd

Ask the Samsung Support or the person/merchant, who had sold the SSD, for help - or buy another (more modern) non-OEM NVMe SSD.

support not support OEM ssd

eeemm/// i want to try to back my data, topic not about buy or not…