Problems setting up SOL

Seriously annoyed with Microsoft and their stupidity. I am trying to configure serial over LAN on W10. I am running a system with a laptop (HP8440p ElitePro) running W7 and version of Intel AMT and I want to connect to a desktop running an ASUS B360M-C/CSM running W10 dual-booted with W7.

Just loaded AMT version ME_SW_1909.12.0.1236 for W10 but did not know if my mobo is consumer or corporate. I presume corporate since it is rated as a business model. There was no SOL I could see under consumer so I loaded the version under corporate/ME_SW_DCH, not knowing the difference between that and ME_SW_MSI. I presumed the other option was MEI only.

Anyway, the SOL would not load. In fact, it did not even appear under Ports on Device Manager even though Intel claimed it was working. So, I loaded it manually using an INF file in the SOL directory. Got a code 10 error with inadequate resources with no means of adjusting com ports, IRQ, or address.

I looked at my W7 SOL install and it’s INF file had an entire section of options for IRQ and address that is missing on the ME_SW_1909.12.0.1236 version. I d/l’d an SOL-only INF file from this site and it managed to give me the Resources option I need.

Now for the Microsoft stupidity factor. When I have both serial ports enabled in BIOS, Msoft tells me there is a conflict between the devices (comm ports) and SOL.

DUH!!! No kidding. They still only have two comm port IRQ settings (3 and 4) available on W10 even though they now have scads of extra IRQs. The idiots are not allowing other IRQs as far as I can see.

The SOL INF from this site allows for 8 options which 'include ‘any’ IRQ. I have tried them all and msoft apparently can’t read INF files.

When I disable one or both serial ports in BIOS, Msoft then tells me there are no devices available. DUH!!! No kidding. I just turned them off!!! Can the W10 system not figure out that I am trying to load a virtual system?

Asus has to take part of the blame here as does Intel. If those three cannot work out IRQ/addr settings for simple comm ports then who can?

Is there someone out there who might have an answer for this? Has anyone seen SOL work on other ports/addresses when the two main serial comm ports are in use? I have a parallel port on the board as well but if I try to use it’s comm port I am sure msoft will whine that the device is either not available or in use.

Man…it annoys me seriously, that this IRQ nonsense is still an issue nearly 40 years after the issues began.


Replying to my own post above I have taken further steps. I have enabled both serial ports on IRQ 3 and 4 and disabled the printer port which is normally on IRQ 5 and/or 7. I now have the SOL attached at IRQ5 and address range 2E8 - 2EF. I have checked with all addresses that 2E8 - 2EF is not in use.

BTW…W10 won’t let me select an IRQ higher than 5. I may be able to force it in the registry, I have not gotten that far yet.

Device manager reports no conflicts but it complains there is no device on IRQ5.


Aha, a light goes on. Maybe I have to activated SOL first…but how? Still, that should not interfere with the implementation of an IRQ and an address for the port. It didn’t in W7, so why in W10?

That is not how IRQs are supposed to work. They are a signal (interrupt) to the processor (an Interrupt ReQuest) from a port that a device attached to the port needs attention. SOL needs attention, not some stupid phantom device Microsoft thinks should be connected there.

My W7 SOL Device Manager resources report:

I/O = 5050 - 5057
IRQ = 11
Memory = 00000000D472B000 - 00000000D472BFFF

Why can W7 figure this out but dumbo W10 cannot???

I’ll tell you why. W7 is a superior OS to W10.

I would force an IRQ and address like in W7 in my W10 INF file but it would likely be rejected by the W10 anal permissions system as being unsigned.


ps. hope no one takes offense at my Microsoft bashing. I am somewhat frustrated right now, trying to solve an issue related to Microsoft going out of their way to kill W7 on newer generation motherboards and processors by withholding USB 3 drivers for them. They are so desperate to kill W7 and force people onto W10 that they have cut off W7 users on newer mobos/processors from updates.

I am posting on another part of win-raid to that effect. I can’t even get windbg going over a serial connection due to the bloatware with which Msoft has weighed down Windows. As I tried to explain to someone the other day. serial connections are dead, stupid simple, yet Msoft have gone out of their way to make the process seem ridiculously complex.

I grew up on computers in DOS, in which I had to configure my own IRQs and addresses many a time. I got used to it but this latest exercise in futility, trying to configure W10 IRQs, where they have bazillions of IRQs and addresses compared to poor, old DOS, yet Msoft has limited serial comm ports to two main IRQs.

There is likely something I am missing but Msoft deserves the abuse for their on-going meanness and stupidity.