Problems to get the GA-X79-UD3 BIOS modded and flashed

@Fernando , I was doing an intense search about X79-UD3 rev 1.0 modded bios, you and @Ghostearth came up.
You have any link of the lastest moded bios and ME firmware for this MOBO? I’m having issues with the original/last F20 bios from Gigabyte (can’t overclock).
I’m using a Windows 8.1 PRO x64 and a A400 SSD.

I finally found two links from 2014 that is working. Probably has newer modded bios and ME, but is what it is…
X79-UD3-F21e.mod and ME firmware

Now the question is: how should I flash this on my gigabyte MOBO?
I have to download UBU and MMTool or isn’t necessary? I don’t know what to do from here… should I just put this modded bios on a flash drive and i’m ready to Q-FLASH?
I found a more stable ME firmware, the Can I use it or I have to use the that the guy said to?
I’m trying to understand how to mod a bios properly but all the infos are mixed.

@sonix moshi, moshi, can you help me?

link the BIOS @yuki88 I will check it, did you already try to flash with Qflash? Sometimes mod BIOS is blocked by Qflash, sometimes not, but it’s an easy fix.
If you have not already tried Qflash, try now and see if it lets you (Or wait for ME update mentioned below). If you do try and it wont let you Qflash, I can fix file for you, or you can flash with the stock flashing tool (EFIFlash) that comes with BIOS download from gigabyte in DOS

You cannot update ME from 8 to 10, the latest you can update to is >> >>!WQFWgLYC!Yfg7eR58o4wZY…a_oI3ymqVn3aCQI
Do that following the cleanup guide here, or if you need this done when I check your BIOS for Qflash block mentioned above I can do that for you.
[Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization
This is the bios and its using MEI FW. After flashing it I would update to ME or (actually i don’t know if would work).
Which should I upgrade to?

Also, if i use UBU Tool with MMTool I don’t have to flash using Q-Flash and a usb stick? Or i will have to use the usb stick anyways? I don’t get what this software does exactly
Btw, I have to update the ME NOW or after i flash the bios?

Boys, can someone help me

@yuki88 :
Welcome to the Win-RAID Forum!

Since your problems have not much to do with the topic, where you posted them, I have created a new thread within the “BIOS Modding Guides and Problems” Sub-Forum, gave it a meaningful title and moved the related posts here.
I hope, that this is ok for you and that you will get answers to your questions.

By the way: If you want to directly address a request to a specific person, you should use the correct nickname (it is SoniX and not sonix).

Dieter (alias Fernando)

Thank you, @Fernando
Can you just answer one thing to me? After I put the modded BIOS on UBU/MMTool, pass by all steps, will generate a new renamed BIOS, right? I have to use this BIOS on a flash usb drive (FAT32) and flash it on Q-FLASH (Gigabyte) or isn’t necessary because UBU is already a software like @bios made to flash?

@yuki88 - I answered your exact questions before your new replies, did you miss all that? As for UBU/MMtool, those are for BIOS modifications, not for BIOS flashing. Qflash and a USB Stick will be used to update the BIOS.
This motherboard can overclock, a lot actually, even with low range CPU like 3820. If you are having issues it’s settings related not BIOS issue or BIOS can’t allow overclocks etc.

Here is that 21e-mod BIOS updated and fixed (microcodes were patched incorrectly, now fixed and updated except one ES Code), ME has not been updated to, please wait patiently on ME, I need advise below…328658549351359

Plutomaniac Can you advise here please and thanks! No matter what I do, using v8.1.40.1456 and ME region extracted, my saved config settings are not applied on build.
I tried many ways, and even made sure to check they are set before build, which they are, but resulting outimage XML does not keep the config files settings.
Number of flash components, MCTP Address" to “0x00” etc all get changed on build, several others too that I don’t even adjust. I tried leaving SKU blank, setting SKU, etc all look OK until image is built.
I know now to leave SKU blank as is, only mention to let you know I tried that as well. v8.1.10.1286 does not work either as expected, unknown SKU, reverting.
Can you please make an image for this, using BIOS above as ME source, I’d appreciate it? And please let me know how you get it to keep the settings so I’ll know later, thanks!

I cannot remember if Gigabyte built in flash routine updates ME, once we have proper image what is best method here FW Update tool or FPT -ME?

On UBU modification, at the end you can choose to rename or use default input name.
Yes, stock or modified BIOS must be put on root of FAT32 USB for Qflash or DOS Flash via EFIFlash.
Slow down, be patient, flashing or modifying BIOS is not something you want to rush through, unless you don’t want to be using your board anymore for 3-5 weeks while you wait on recovery tools

The modded BIOS that I sent to you was from @Ghostearth but I found 2 hours ago (I didn’t slept at all) looking into tweaktown bios modding thread a post from @stasio.
Here’s the link…
I don’t know if it will helps or not but…

Also, what is the problem with ME FW I’m not using windows 10, i’m on windows 8.1 pro x64.

Found it! Uploaded by @stasio
Lastest ME with MEUpdate and MEINFO included.…

Older ME with MEUpdate and MEINFO included.…

X79-UD3 F21-E beta by stasio (apparently has three modded bios “F21-E”, I linked all).

The user “Amurtigress” specified here How to upgrade MEI X79-UD3 just scroll down or CTRL+F “FPT flasher”, thats what you’re talking about, right?

My CPU is a I7-3820 SANDY Bridge-E (non-K). LGA2011. Rev 1.0 mobo.
Just trying to help you guys fixing this BIOS for x79 users, was pretty hard to find those links (99% of links were screwed).
I really want to sleep now, 19 hours just reading and searching… I will be back on 5 hours (anxiety)

Thanks for helping, @Lost_N_BIOS @Fernando

Yo, @plutomaniac

These are Flash Descriptor settings so they don’t apply when you input and work on a bare Engine region only.

Thanks Plutomaniac I didn’t think about that! There are a few others that get changed too, but I forget them right now, I will check and update this if I think they may need looked into by you.

I redid and found this - Number of Flash Components @ 0 goes back to 2 (I guess this is OK, inserting back into image anyway)

DensityComp2 value=“8MB” >> DensityComp2=“true” (False in saved config, I assume changes due to component count changing back)

Config -
<ProcMissing value=“No onboard glue logic”
ProcMissing="No onboard glue logic,Glue logic tied to GPIO24,Glue logic tied to GPIO28"

Changes to after mod
<ProcMissing value=“No onboard glue logic”
ProcMissing="No onboard glue logic,Glue logic tied to GPIO24"

Dropping entire BIOS into FITc and comparing with extracted ME only XML config, I see entire “PCH Strap 16” missing too, also ProcMissing value false in ME only, true on entire BIOS. SoftStrap16 added in Config, not in original
PCH Strap 15 - IntLanEn=true in config vs false in entire BIOS. Managappshipsate false vs true on entire BIOS (and <PbgDWsHedt edit=“true” entire tree missing in config), and several settings at beginning of ICC profiles differ as well (CSS, SSS, and PLLRCS values).
IcBtSoftStrp="Full Clock Integrated Mode in config vs buffered in full image drop. ProcMissing value=“No onboard glue logic” = False in config vs True in entire image drop
I know all these may be bugs due to the version of FITc we have for this, but asking just in case since it is not for my own board and don’t know how easily this user can recover if needed.

Here is all three XML if you want to check anything I mentioned (Config, mod, and entire pre-ME changes BIOS dropped in)…379569493376003

Is all that safe/OK to ignore and proceed with reinsertion? Thanks!

@yuki88 - nothing is wrong with that older ME, it’s just not the latest version, and OS you use does not matter. You can use that BIOS I posted as it is if you want. Latest ME FW is -!WQFWgLYC!Yfg7eR58o4wZY…a_oI3ymqVn3aCQI
ME cannot be simply updated with FPT, you need settings transferred using Intel Flash Image Tool first. ME can be updated without doing that settings transfer if you use ME FW Update tool (FWUpdLcl.exe)

Or wait for one more reply from plutomaniac and I will send you BIOS with updated microcodes as before and update ME, based on the Mod3 BIOS you originally linked.

Same thing. Anything outside of XML tag

<Region2 name="ME Region">
must be ignored when you're working with ME region only. The FD, GbE, BIOS etc settings don't matter. Also, the whole point is to not use the full SPI image with FITC v8.1.40 because it reports wrong info. Compare extracted bare ME region to output bare ME region only.


For some reason the quote didn’t work.

Thanks again Plutomaniac That leaves only this within the ME Region section, is that OK?

Config -
<ProcMissing value="No onboard glue logic"
ProcMissing="No onboard glue logic,Glue logic tied to GPIO24,Glue logic tied to GPIO28"

Changes to after mod
<ProcMissing value="No onboard glue logic"
ProcMissing="No onboard glue logic,Glue logic tied to GPIO24"

The “value” is the same, that’s what matters in the end. The other difference could be because of different FITC versions used or similar.

OK, thanks again Plutomaniac, just wanted to be sure since I doubt he’s ready for quick and easy recovery

@yuki88 - here is BIOS as linked previously, but now with updated Intel ME. Once flashed, please check your ME version via HWInfo64 (On the left of large window, expand motherboard to see ME section, then check FW version).
If it doesn’t update it automatically I’ll help you get it updated. First, if ME is not updated, reboot to DOS and flash again using EFIFlash that comes with the official download, then if it’s not updated still I’ll help you get it with FPT…966695268851532

@yuki88 note that mobo v1.0 have problems with f20 BIOS, I beleive it’s for v1.1 only. F16 should work, search this forum.

@Leon_pro - Rev 1.0 and Rev. 1.1 use exact same BIOS, download both and extract, then compare in hex editor = 100% hex match (Same for any other BIOS version that has matching version as well)