Problems to get Win10 installed in UEFI mode onto an Intel 6-Series chipset laptop


I thank you for this fine forum and all its wonderful contents.

I have used its information for several years, but this is the first time I find myself in need of asking for help.

I have an old laptop, Asus zenbook UX31e, and i would like to install windows to it in UEFI mode.
So I using a ubuntu usb stick i made the drive GPT, and set the bios to boot in UEFI.

Windows 10 64bit setup boots from the stick, but then it needs a f6 driver to install.

I have tried a few different of your modded drivers: v8.9.8.1005, v11.2.0.1006, v12.9.4.1000 but have come up empty.
Setup locates the driver, but when it loads it windows allways BSODs.
"Page fault in non paged area"

The laptop has a intel qs67 chipset and uses SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)

Can someone please advice wich AHCI f6 driver could be suitable, if any?

@technot :
Welcome to the Win-RAID Forum as well!
Only WHQL certified storage drivers are accepted as F6 driver during the installation of Win10.
Furthermore it is very unlikely, that the "missing" F6 driver is an Intel AHCI one. Reason: Win10 has a generic AHCI driver in-the-box, which supports all AHCI Controllers from all manufacturers.
I suspect, that another storage driver type is missing. Onto which HDD/SSD do you want to install the OS? Who is the manufacturer and which is the model?

Dieter (alias Fernando)


It is a mSATA drive: SanDisk U100 128GB SSD

@technot :
How is the mSATA SSD connected and which driver did you use for its SATA/mSATA Controller until now?
P.S.: If you want, that i get notified about your post, you should enter my correct nickname (with a capital "F" as first letter) while using the directly addressing feature.


It is connected in the laptops mSATA slot. Its a ultrabook, so I cant really open it up easily to look closer.
I have not previously used a driver, I havent used UEFI boot before. With legacy bios, there was no need for additional driver during windows install.

Right now I am using ubuntu on it, which is working flawlessly booting in UEFI mode(not CMS mode), and from the looks of it Ubuntu is using the default AHCI kernel module.

@technot :
Since I suspect, that your on-board SATA Controller is running in AHCI mode, I have no idea about which F6 driver the Win10 Setup is missing.
Which are your BIOS settings regarding the SATA Controller?
How did you create the USB flashdrive having the OS image on it? Did you boot off it in UEFI mode?


I created the usb flash by first using diskpart to create a GPT table, then format it as fat32. After that I used rufus to install the win10 iso image to it.
Yes I am booting of it in UEFI mode, to boot i click ESC during POST to get a bootmenu, where i choose UEFI: Corsair usb stick.

SATA controller settings in the bios i as you suspect set to AHCI, there are not much more settings regarding SATA. I can switch it to IDE, but there are no IDE devices so I dont think that would help.

Boot settings is set to UEFI BOOT enabled, FAST BOOT off, and PCI ROM Priority set to EFI Compatible ROM (other option is legacy rom). But as I am trying to install UEFI, I assume EFI roms should be priority.

This computer is old, 2011-ish. And came preinstalled without UEFI enabled. Could it be the bios is missing the UEFI rom for ACHI/SATA ?
(I guess not, since ubuntu 20.04 is working flawlessly in UEFI mode)

@technot :
Your problem has nothing to do with the topic of this thread, because the Win10 in-box generic MS AHCI driver named storahci.sys supports all AHCI Controllers from scratch.

The first extra steps were not necessary, because the tool Rufus lets you choose them and will create the desired configuration automaticly.

No, the UEFI BIOSes neither need nor use such EFI modules.
The only EFI module, which may be missing, is the GopDriver for your in-use graphics adapter, but this should be no problem unless you had disabled CSM in the BIOS.

Ok, please delete these posts then I will take this problem up in another suitable thread.
I am at a loss as to why windows10 fails to detect my disk, and asks for a driver.

@technot :
Maybe it is the old on-board USB Controller, which cannot be handled by the Win10 Setup.
Has your system an Optical Drive? If yes, try to boot off the Win10 DVD.

As soon as we have found the origin of your issue, I will move our discussion into a better matching Sub-forum.


USB works fine, as I can see all the contents of the usb drive i boot from, and I have also used a second usb drive in another usb port when I tried to install the modded drivers. So windows 10 is infact loading drivers for both my USB2 and USB3 port
I dont have a Optical Drive on this ultrabook Im afraid.

@technot :
Only WHQL certified storage drivers are accepted as “F6 drivers” at the beginning of the Win10 installation. That is why it doesn’t make much sense to load any of my mod+signed drivers.
By the way - which are the HardwareIDs of your on-board Intel SATA AHCI Controller?
At the moment I see only 2 possible reasons for your issue:
a) Your on-board Intel SATA AHCI Controller doesn’t support bootng in UEFI mode. You can easily verify it by trying to install the OS in Legacy mode using the Master Boot Record.
b) Any of your on-board IDE or Storage Controllers is not detected by the Win10 Setup. To find out which one it is, you may try to install an older Windows OS like Win7 (if available), open the Device Manager and tell us the names and HardwareIDs of all Controllers, which are listed within the “IDE ATA/ATAPI Controllers” and “Storage Controllers” sections.


The hardware ID for my Intel SATA AHCI is: 8086:1c03

a) We can rule this option out, as I have a working ubuntu install in UEFI mode booting perfectly.

b) I can install windows in legacy mode and check that, but I allready know the answer. This laptop only has one SATA controller. And that is this:
Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)

I have attached a file called lspci.txt that lists all pci on the system with hardwareIDs.
You can safely assume windows 7 will not detect more pci devices then Linux.

But if you want, I will install windows in legacy mode to check the device IDs as well

lspci.txt (8.62 KB)

@technot :
By doing a Google search for “mSATA SSD not detected by Win10” I found >this< discussion and the solution.
Hopefully it will help to solve your problem as well.

Well, afraid not. That discussion is regarding someone who can see his drive during setup, but not after installing windows.
Also his problem was solved by repartitioning the drive.

I allready tried repartitioning the drive, multiple times. But setup doesnt detect a drive at all.

Thanks tho. I guess this laptop just isnt meant to UEFI boot windows 10

@technot :

You may be right - Intel 6-Series chipset systems were the very first with an UEFI BIOS, but many BIOSes of that series do not fully support all UEFI features.

It’s possible to use Win10 on UX31E - I google Win10 Asus UX31E and see many threads of people with certain driver issues (post install type issues, hotkeys, touchpad etc)
And the main driver page offers Win8 drivers, and generally Win8/Win10 same same for most all this kind of stuff. I see many discussions of updating from Win7 and Win8 to Win10 on the system as well, so it is possible, you just may have to do it in MBR mode if UEFI Fails.

Try making your Win10 ISO with Windows DVD creation tool, I’ve seen many times Rufus fail for this while Windows tool just works, prime example here for similar model too…ux310u.3139045/
Here is the tool, ignore sys requirements/targets etc I use on Win7-10 to install Win7-10 always without any issues -…s.aspx?id=56485
Make sure Target Disk is either RAW or Initilized as GPT when you point the installer at it, then do nothing except click next at disk target page, don’t create any partitions let the installer do that.

If you still cannot get it, install Win7 or Win8 in UEFI Mode, then update

I never said i couldnt use win10 :slight_smile: Ive used win10 on it for a few years allready, using MBR and legacy bios.
I was just exploring UEFI, and installed ubuntu in UEFI mode, flawlessly, so I was expecting windows10 to work easily too.
Sometimes you just want to do something, not becouse you have to, but to figure out the obsticales :slight_smile:

Now, however, i have crashed the whole laptop. I used AMIBCP to unlock all of the bios options, and it gave me access to settings I didnt even know existed. But aparantly I enabled something i shouldnt have, and now all i get is a blinking led on the power button and caps lock button(blink in sync) when I try to start it. So now I will have to order a torx 4 to open it so i can reset the CMOS and hopefully get bios settings to default.

When I get that done, I will try the win7 install->upgrade to win10 method and see if that works.
Thanks both of you :slight_smile:

@technot - Yes, I knew that, and realized later thinking about it that many threads I noticed may not have been about UEFI install issues too.
Please test creating the USB Installer with the tool I mentioned, I’ve seen Rufus cause issues many times in regards to this kind of thing.

Sorry to hear!! Sounds like you set some incorrect voltage, or changed a display option you shouldn’t have
If you changed display related items, you can maybe get lucky and get display to come up on external display output (wait a few minutes for Windows to load, or spam BIOS hotkey and see if that will load)
If you can get external display in windows, reflash BIOS, or if you can get into BIOS load optimized. If you can’t get anything, you will need CH341A + SOIC8 / SOP8 test clip with cable


I tried connecting an external HDMI display, but its really "dead". No fans spinup, nothing on display, not even a bios post logo :slight_smile:
I didnt touch the voltages, but I did enable some display related settings, also some power managment related settings.
I cant remember all the settings, there was a ton of settings I have never seen on a laptop bios before, and a ton of settings I have never seen in any bios before. Related to T-states, P-states, C-states, power/voltage of CPU and IGP, ACPI settings, ME settings, you name it…

But its np, the computer booted fine with my modified bios untll i did a few changes to many in the settings. Im sure a CMOS reset will reset all settings to default, and allow the computer to boot up again. If not I will defently look into the CH341A + SOIC8 / SOP8. Having that available will make me more adventerous regarding other BIOSes as well in the future.
(For the record, the only modification I did to the bios was upgrade the CPU microcodes using the UBU tool. Did not touch or upgrade or inject any ROMS. And then after use AMIBCP to make the bios show every possible setting.)

Will post back when I get the torx to open up the laptop for a CMOS reset, and then try booting using a USB stick made with the microsoft DVD tool.