Problems with AMI BIOS

Hi there!
I have this mini PC here which has AMI BIOS and supervisor password (which I know) in default settings (so I can’t reset it) as well as a custom logo. My goal is to remove the password, adjust default settings and change the logo. However, I’ve ran into issues right from the start.
I don’t have a ROM file from the vendor and I don’t think I can get one. So I have tried to backup my current ROM but only two programs worked: AFUDOS 4.4 and Universal BIOS Backup. Others were quitting with error 46. Both backups produced are 1MB in size, which is smaller than usual and won’t open in any of the modding programs I have. So far I’ve tried MMTool, AMIBCP 7.6 and Change Logo v5 to no avail.
I’m wondering if anyone could help figure out how to modify my ROM. Thanks in advance!

The result of BIOS identification:

ROM file is attached. (436 KB)

@nikkar - If you know the password, then remove it from within the BIOS. What is the motherboard? Why do you think BIOS not available?

The BIOS you attached is complete BIOS, it’s AMI BIOS and you can open with AMI tools (AMIBCP, MMTool, AMIDMI, AMIMMWIn, AMI OEMogo, etc)

What do you really need, do you need the tools that work with this BIOS, or do you need someone to modify it for you? I can mod BIOS, but I cannot remove password, for that it sounds like you know the password so you can remove in the BIOS (If not, ask for removal at forum)
If you need tools, I can send to you

Like I said I’ve tried opening this image with multiple tools and they all threw an error message. I appreciate if you can share the tools you’ve mentioned. Maybe I have mismatched versions.
The password I have is a supervisor password and it is persisting through settings reset. Never saw anything like it before, so my guess is that the password is baked into the ROM.

I opened it just fine in all the tools I mentioned, that’s why I asked if you wanted a package of tools, or for me to modify the BIOS for you. I’ll send you PM
Settings reset/clear CMOS etc, wont remove password, you need to go to change the password, enter current pass, then enter blank pass and save.
PM coming your way

hello. i am having the same problem with a "baked in" password. how do i clear it/ where to look and delete. i tried amibcp v3.46 but im at a lost. thanks for any help you can provie