Problems With Asus P9X79_LE NVMe Boot Drive

I’m new to BIOS modding. @MeatLoaf was kind enough to provide me with a Flasback Bios. The process went just as expected.
If I may tell you about the other hardware I am using I have an i7 4930K, A Kingston KC3000 4 TB drive in a Vantec adapter, Asus 710 Silent video card V, 8 GB x4 for 32 GB of RAM in the order specified in the manual, an EVGA P2 750 Watt gold PSU, a Noctua NH-D15 CPU cooler and Windows 10 Pro 22H2. It had been a home file server with an LSI RAID controller and worked well.
The computer ran fine with a Samsung 850 EVO previously. I’m not sure if I have a problem with NVMe drivers or some chipset driver or what. The computer BSOD’s with much disk write activity. The error is a generic WHETA UNCORRECTABLE ERROR.
There are no memory dumps just an information error that the drive was disconnected in the Event Viewer.
My bios setting the first time I reset to factory defaults, Disabled CSM & enabled secure boot. I formatted the drive with the adapter in another PC, And let things go. I let Windows reformat the drive and create all the partitions to be a boot volume on my Asus. Sometimes it BSOD’s during install sometimes not. I went in to the BIOS set BLCK=100 Disabled PCI-E & CPU spread spectrum also Disabled all C states in BIOS for stability. Still no joy,
I ran PassMark MemTest 4 passes twice over about 12 hours all passed. I am able to Read and write to the disk using bootable errors. When I insert it in the other computer It has no SMART errors & runs ChrystalDiskMark OK.
Here is what I installed for drivers, Installed .net3.5, Installed Visual C Runtimes
Installed Asus from the Asus site for the P9X79-LE
Installed the Asus ASMEDIA_Win7_81_10-Ver3160 SATA 3 Driver Intel RSTe Drivers & Software Set v13.1.0.1058 WHQL From for the SATA II to work. Device manage looks OK, I tried a different Video Card a NVIDIA 1030 and on old ATI card with no better results. When the computer is not writing to the drive it can rum Prime95 at 65 degrees for a long time with no problems. I always set Power to high performance in control panel, disable disk timeout & PCI Express Link State Power Management.
So far I have tried About a million clean installs, tried Fernando’s Phison Storage Controller which was worse and made the Kingston software not work, tried Fenando’s Community or Samsung Storage Driver no better probably worse also stops the Kingston Software from running.
I have done all windows updates, tried both with and without the million intel updates that are offered optional updates. ChrustalDiskMark will always cause a crash in the second write test, Aida64 runs for about 7 minutes and crashes.
The computer seems OK until it has a lot to write to the disk then hard crash yet the disk is fine in other machines. I am at a loss & any suggestions are greatly appreciated.
I appreciate all the help MeatLoaf and 68-k Dude have provided.Thank you all! Berg

Please let me express my sincere apologies it was MeatWar who gave me the BIOS & put up with my PM’s. Sorry about getting your name wrong!