[Problems with] ASUS ROG Strix Z490-E Gaming BIOS

Thanks for the answer
In that case, I will wait and check what programmer I will get and look for a data sheet for bios sticks.
To be sure, in my case I will ask:
Stick 25B64CSIG is an 8MB chip and 25Q128JVSQ is a 16MB chip?
8MB contains data for operating the processor and 16MB is the BIOS itself?

Sorry for the stupid questions, I have more experience with electronics and electricity than programming.

Yes, if you get the pdfs like i instructed to, you’d know this already, don’t make me lose time and repeat myself.
A GigaDevice GD25B64C and a Winbond W25Q128JV, this is done by detailed visual inspection of the ICs.
And no, also you’d know this if you read the tread a bit, it should be EC/ME FW on the 8Mb and Bios Region on the 16Mb…
Same as Electronics…you’ll have to know the specs of the component…

I ask a lot of questions out of fear of the unknown :face_holding_back_tears:
I have already received the programmer and analyzed the datasheet of the sticks. I extracted the contents from both chips. I merged them into a 24MB file. I checked everything with MEAnalyzer.

According to the program, everything seems to be fine.

Unfortunately, as a new user, I cannot upload files, so I will share them via wetransfer.
I hope it will not be a problem.

What steps should I take next?

GUID raw 63F23E9D-5FDA-415E-9C2A-64C4E2A6ECE8

Follow guidance on post #124

Get the Asus bios file 2701
Extract the GUID from it, its the ME FW image, yours is corrupted as shown in post#120

EDIT: You also cant follow and read a guide? You have a serious problem my friend… try again.
“Open the bios with UEFITool ,select “Extract Body” , save as .bin”

Is that what you mean?
63F23E9D-5FDA-415E-9C2A-64C4E2A6ECE8.zip (1.8 MB)

Sorry, this is a lot of news for me. And the guide is very extensive, not entirely understandable to me, but this is due to my lack of knowledge in the subject. To be sure, we are talking about the same guide? [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

I am sending the correct file.

Section_Raw_63F23E9D-5FDA-415E-9C2A-64C4E2A6ECE8_body.zip (1.8 MB)

Thanks for your patience

The guidance on post#124 from rogerfuk is very extensive?
I dont need that file, its you who need it to program the GD25B64CSIG with it now.

Hello, I have the same motherboard, which also has problems. The computer restarts 4-5 times each time until it finally starts properly. As soon as Windows loads, I always get the message that my MEI driver is not installed. The ME firmware version is stored under BIOS. So something is wrong with the BIOS. I bought the CH341A program with the hope that it would work. I had previously bought the BIOS chip. Unfortunately, I then saw that there were two chips on the mainboard and I couldn’t get any further.

@Bobo331982 @MeatWar @lfb6 @LEKA @68k-dude @rogerfuk @Damian93 @S3riou5
This thread was sorted into the Forum Category “Offers: Already Modded Special BIOSes”, but contains reports about different BIOS problems with the related mainboard (and possible solutions).
That is why I have moved this thread into the Category “BIOS Modding Problems” and customized its title.

Gigadevice backup:

winbond backup.rar

ME Analyzer results

i think i have to use also but i dont know how to do it :confused:

Put the two dumps together, smaller (FD, ME) first, larger (bios region) second. That’s a complete firmware image which will open in FIT.

Then follow this guide:

If you finish the process correctly it’ll give you one complete firmware and files for the two SPI chips. You only need to flash the smaller (8- MByte) chip.

Hmm ok, i hope i can do it :see_no_evil: i think its too high for me :face_with_diagonal_mouth:

Well, it’s up to you. The other (possibly better) solution would be to download the latest Asus ROG STRIX Z490-E GAMING BIOS 3001, open it in UEFIToolNE

Expand this volume:


Almost at the end of the volume you find 63F23E9D-5FDA-415E-9C2A-64C4E2A6ECE8. Extract the body of the shown Raw section of the update:

That’s exactly the content of the 8 MByte chip and this way you’d bypass the Asus trick with the placeholder PHY P partition…

Good luck

Thank youuuuu. :smile: it worked, the restart problem is gone :heart_eyes: thank youuuuuu

Good to hear that it worked :+1:

There’s an ME update on Asus pages: MEUpdateTool Version

I’d recommend to update your ME since the one hidden in the bios update is rather old.

(Latest is though, but I don’t know a readily stitched update file that contains the latest PHY P, too, which is part of the Asus ME update)

@lfb6 Buddy, its funny that you mention this… because it reminds me that i would like to hear your opinion on it.
The thing is that the first couple of past ME FW images updates I’ve done to my board, based on 14.1.6x.xxxx versions, they did contain the PHY sub-component and always sticked in bios, but last 2 ones starting the 14.1.7x.xxxx (14.1.70.xxxx and last i lost the PHY sub-component in bios.

Still the official ME FW image update from MSI, (currently on my board) does contain the PHY stitched, but i never researched what could be done to re-engage this sub-component again.

Here’s the link to the official MSI Intel ME Update Tool_ME14172_H (2024-01-17) file with PHY

Thank you

What do you mean by ‘you lost it’? What board are we talking about and did you check on a dump with MEA? What’s the output?

14.0 didn’t have PHY (and SAMF) module, those came with 14.1, so a ME 14 will be able to work without. But if they’re in the firmware they should stay there even if they aren’t part of the update?

That’s the strange part… not anymore.

Z490, i don’t have PHY on firmware anymore, it was always 14.1.xx.xxx from start, not 14.0
I know they work without it, still it was present before and of course the board has USB-C

Current state, only main CSE ME, PMC and PCHC, no issues at all, just curiosity on the issue

Anyway, just wanted to share the complete FW update

EDIT: Anytime, this mb of mine doesn’t have BFB feature or dual bios, has main system not going to try to fix it anyway, FPT/FWUpdL doesn’t write it anyway.
Oh, and it’s not April’s fool… by the way.

Well, would be curious, too, but will ask again on April 2nd, sounds too unlikely to follow up today?