[Problems with] ASUS ROG Strix Z490-E Gaming BIOS

thank you to all who can help me get my head out of the water, I know that very competent people will be able to answer this subject.

see you later thank you meatwar

1 Like

As far as I understand this very long text you have a dump of both the 8MB and the 16 MB chip in original state?

Attach both!

yes indeed, I have recovered the data from the 2 chips in their state with the programmer.
how should i attach them?

MXIC MX125L12872F 128mb HS.rar (6.1 MB)
Winbond 25Q64JVSIQ 64 mb HS.rar (1.8 MB)

OK- 16 MB chip is bios region, 8 MB chip is fd and ME region

Bios region is a 100 % identical stock bios 607 with machine specific data - OK

ME region has corruption in MFS partition.

Put those 2 files together for a complete firmware image: Use a hex editor and copy the content of the 16 MB file at the end of the 8 MB file thus generating a 24 MB firmware image.

Use this for:

Post the result.

I doubt that this is the reason for the board not starting, the bios region is perfectly fine and the ME region shouldn’t even have been touched by the update since Asus updates for these boards don’t contain ME regions/ complete images.

Thank you very much for the information,
I would try to do this procedure with a rested head which does not seem to be so simple. when I have some time. and I will keep you informed.

I applied the procedure, I see a little improvement but there are still problems there.
I forgot something ?

Update your MEA to get proper results.

If I follow the procedure I get no error mesages.

BUT In addition this is one of the firmwares where Asus included a placeholder PHY, not sure how to handle this when cleaning, there were just some cases and afaik all regarding updating, not cleaning. Compare output of MEA for the bricked image, it’ll show you one additional item…

Did I choose the correct version?

Yes, that would be the correct version.

But as written:

Asus has a placeholder PHY partition, which only can be configured in FIT if you choose CML with Rocketlake, but these configs do have slightly different options.

@plutomaniac How would one clean a ME with Asus placeholder?

Is it possible to find a working BIOS?

Me for the moment I can’t already have a bios without error.

why am i still getting errors?

I try as best I can to understand but I surely don’t understand all of them otherwise I will arrive at the same result as you.

Difficult when you’re not from the profession

I’m trying to revive this motherboard but I even realize that it’s not that obvious even with tutorials.

thank you very much for your explanation

If in doubt attach the resulting file, I might then find where the error might be?

yes I would like to thank you, not for lack of will but for incomprehension of the system. And as I like to know how to do with myself even that frustrates me and embarrasses me.
it’s always more complicated to understand a new thing by trying to look for information right and left than to see a person who explains and where you can see the do’s and don’ts visually.
I attach the results which are not good
bins outpout.rar (7.8 MB)

You’re still using old ME Analyzer:

Latest is:

I don’t see any error for your file, it has a different order of the ME partitions, that might be related to an older FIT version you used. MEA says ‘configured’, it unpacks without errors, I think it’s fine according to the guide :+1:

There’s of course still the difference with the placeholder SAMF and PHY which Asus inserts. Afaik they’re not functional in this setup, so your file might work as well. In addition i tried to manually rebuild the original structure, I assume this might be useful regarding possible Asus ME updates in the future.

Maybe there’s really an error in the ME that keeps your PC from booting. Looks like a firmwareupdate went wrong, there’s a 4k block in a module that’s missing and after that block there’s unexpected code (might be from an older ME version?)

The 16 MB file is identical to the one you sent, so no need to flash this chip.
I’d appreciate if you could flash the 8 MB chip with your file and the one I created- I’d like to know if a ‘simple’ rebuild according to the guide without paying attention to Asus’ dummy placeholders might work in case of brick and I’d like to know if my reconstructed file with Asus placeholder PHY would work, too.

(And there’s still the possibility that this is not firmware related)

Thank you for everything you do but why am I still getting errors with the latest version of MEA?

it’s because it needs all 2 files, right? 24mb

MEA reads the flash descriptor for detecting start and size of ME region if there is one. Since it seems you just gave it the 8 MB part to read it complains that the complete image is supposed to have size 0x1800000 and not just 0x800000

Try the complete firmware image and the errors will disappear.

Or cut the first 0x1000 of the 8MB file and MEA will just complain that there’s unneccessary padding

Or cut the first 0x1000 of the 8MB file and then all the FFs after 0x321000 (the size mentioned in the main block of the MEA output) and MEA again will give you no warnings since this will be a correct sized me region,

ok thank you I will install my version and then your modified version to see what it gives and I will keep you informed.