Problems with ICH10R / Windows 10.


I’ve been searching the web for a long time now, but didn’t find a solution for my Problem. Seems it’s a relatively exotic config.
From reading other threads here, I have the feeling, the guys here are real specialists, so I hope you can help me to solve my Problem.

My Mainboard is a Gigabyte GA-X58A-UD7 Rev. 1 running without a problem for several years now. I have the latest Beta-Bios from Gigabyte installed.
At the beginning, I had 2 500GB HDs in RAID 0 which contained two Pratitions fpr the System and Data-Files.
Some years later I bought a Samsung 128 GB SSD, on which I moved the system partition, keeping the data on the RAID 0.
This worked well for Windows 7 and 8.

Now after the switch to Windows 10 (clean install) I have the following problem:
The Raid is recognized correctly and accessible, but the Drives are constantly spinning down after a few seconds, ignoring what delay is set in windows energy settings. So for every access to the data Partition i have a 2 seconds delay while the drive spins up again plus that the constant spinning up/down can’t be healthy for the drives.
I am currently on the stock windows 10 raid driver. When I try to upgrade to the latest version from Intel, Windows hangs during boot, as it’s described an several places including Intel forum.
They just seem not to be interested in bringing out working drivers for there not long ago top class chipset.

I have also tried installing the modded drivers from here, but this failed too with a “could not install some drivers” message.

I hope, you can give my some suggestions how to solve this.

Many thanks in advance

@Riemen :
Welcome at Win-RAID Forum!

The Win10 in-box Intel RAID driver v13.2.0.1022 seems to be not the best choice for older Intel RAID systems, especially not for ICH 7-10 Southbridges. That is why I recommend to “downgrade” the Intel RAID driver either to the “classical” Intel RST driver v11.2.0.1006 WHQL (requires a clean install of Win10 by booting off an image, where the in-box Intel RAID driver had been removed and the desired driver integrated, for details look >here<) or to the Intel RST(e) v11.7.4.1001 WHQL. Both drivers do natively fully support Intel ICH10R Southbridges.

Why did you try to install the “modded” variant of these drivers and how did you try to get them installed?

Dieter (alias Fernando)

Thanks for your answer.
Is there any way to change the windows 10 raid driver without a fresh install?

Seems I managed to replace the driver. I used the floppy-version of the older 11.7 driver to manually replace the default one in device manager. I will report, if my Spinning problem is gone now…

You can change the Intel RAID driver version to any Intel RST(e) version (from v11.5.x.x.xxxx up) having an additional SCSI filter driver named iaStorF.sys, but if you “downgrade” it to any “classical” Intel RST RAID driver (latest and best: v11.2.0.1006) from within a running Win10, you may get an unbootable system.