Problems with the mainboard fan adjustment

I have been busy trying to sort our my chassis fan controller why it isn’t working and still going. Fan speed stays at +/- 1300 rpm (corsair ML120 and ML140) and no matter what I change in BIOS nothing happens.
Thank you guys.

EDIT by Fernando: This discussion, which had been started within >this< thread, was moved by me into this new thread, because it was completely off-topic.

For your fan issue, you may need to clear CMOS and reset your setting again,

@Lost_N_BIOS I tried resetting the CMOS (jumper and removed battery) and also tried flashed older BIOS versions as well. Nothing helped, the BIOS control of the case fans is just not working (near a week dealing with issue and its annoying).

Only if I install Asus AI Suite 3 software that I would get the fans to spin at +/-700 rpm (quite) but when I install the this software I start to experience driver issues with the graphic card which is connected via displayport. I will never ever an asus product. Second bad experience with the first, asus overclocked vram too high so gpu overheats and pc locks (was very glad I returned it).

Sorry but I had to write this. Much appreciated and thanks for you help guys.

Does it happen on all fans, or just a single header @iraqiwarrior

I had two fans connected to motherboard 1 fan per chassie fan header (#2 & #3) but since i bought a new gpu vega 64 i decided to change my fans and two of the case fans which were connected to psu started to be noisy.

So currently i have 2 fans using a splitter connected per mb fan header (#2 & #3). I didnt use the psu connector because original fans are 3 pins and the new fans are 4 pins.

The only thing that is left is to connect the fans to mb fan header #1 which i have never used and see if the control works.

@iraqiwarrior :
Since your problem with the adjustment of your mainboard fans has nothing to do with >this< thread, where you started the discussion about it, I have split the related thread and started a new one within the “Off-Topic” Sub-Forum.
I hope, that this is ok for you.

@Lost_N_BIOS :
Just for your information.

Test these fans one at a time, without splitter for testing for now, then see if any BIOS changes have effect or not.

@Lost_N_BIOS I did connect a single fan to fan header and also connect 1 fan to the fan header I never used before but nothing changed, the bios fan controller controls the fan to +1400 rpm. the fans minimum speed is 400 rpm. I think it is just the way how the bios fan controller works, you need silent fans that are calibrated so when at 60% speed isn’t too high or just fans with limited speed e.g. max 1000 rpm something like that.

@iraqiwarrior - Some fans need lower voltage to work slow RPM, maybe this fan at boards lowest voltage amount can’t go down to 400 RPM. It’s strnage that AI Suite can make run lower, but BIOS cannot.
In Control Panel, Power options, change plan settings, advanced, processor power management, System Cooling - what is set here (Active/passive), did you try other setting and see if it then does what you set in BIOS?
I can try to look at BIOS for you if you want? If you want me to look and see if I can find anything that could possibly be changed, please give full motherboard model, or link to the BIOS you are using now.

@Lost_N_BIOS I have Asus Maximus VI Hero
Just to recap I changed the minimum speed in the bios to 400 rpm and selected silent but this didn’t help and I also put it in manual but as mentioned the minimum speed is 60%. I didn’t try the power management but this should only affect when windows load and not during boot.

@iraqiwarrior - Maybe BIOS only put out certain range of voltage, and fan RPM of this fan vs that voltage range can’t go down that low. Versus say a cheap 1200-2500 RPM fan with less range in RPM when yours is 400-2400 (or 400-1600)
I see on Corsair page 10.8V - 13.2V operating voltage, so it’s designed to run that low RPM at 10.8V I assume, and it’s likely BIOS maybe doesn’t lower voltage enough. Have you measured fan header voltages with DMM on high/med/low?

Do you have set PWM in fan voltage mode? CPU Q-Fan Control should be set to Auto for PWM, Advanced is for 3-pin fan/DC mode (If you did not know)
CPU Fan Min. Duty Cycle should be set to 40 for PWM, did you try that or leave it at that?
CPU Fan Speed Low Limit is only for warning (or not), this is not for controlling fan speed. On this, fans should be able to go down to 400 RPM, since I see 200 RPM as lowest amount before warning or disable warning option.

Also, try manual if silent isn’t working for you, maybe that will work better? Also, you can try disable Q-Fan control, then fan itself would use it’s own RPM controller, but would then rely on windows sensor/power management control.

@Lost_N_BIOS Q-Fan control is set to Auto. I did disable the Q-Fan but the fans just went to 100% and I also changed the CPU minimum speed to 200 rpm but didn’t reduce case fans speed.

FYI, CPU fan is 4 pins and CPU_OPT is 3 pins and all case fans are 4 pins.

@iraqiwarrior - Does manual instead of silent make any difference at all? Maybe it’s just these fans, do you have any others that go kind of low you can compare with?

I just read on Asus forum that CPU_OPT is not controllable, and The bios has 20% restriction on the CPU_FAN header, while for chassis fan headers its 60%, so using only the CPU_FAN header will allow you to drop the fans very low (as long as the fan can).…rol-alternative

Seems like they like using FanExpert2, did you try that, or is that part of the AI Suite that was giving you issues?

* Edit - Did you test “Min. Duty Cycle” less than the standard (40 for CPU, 60 on chassis)? If you cannot set lower than that in BIOS, which it looks like, maybe I can send you mod BIOS to test, I can set lower in BIOS mod.
Or you can also test via Grub and Setup_var command without flashing BIOS mod, here is a guide for doing that meant for other changes, but you can use just the same. efi file name you need to use is Shellx64.efi
[GUIDE] Grub Fix Intel FPT Error 368 - BIOS Lock Asus/Other Mod BIOS Flash

Here is variable you need to edit >> 0x444 (Default is 0x28 = 40h 40 in hex) Try 1e instead (30 in hex)
Setup_var 0x444 0x1e

After you enter that, type the following for it to output current setting, so you can see if the change applied or not
Setup_var 0x444

@Lost_N_BIOS , the minimum case fan speed is 60% in the BIOS and cannot be set any lower even if in manual. Fan Expert 2 is part of Asus AI Suite and used to tune the fans, the minimum speeds drops down to +/- 800 rpm. It looks like the fan curve pre set in the BIOS is a linear curve 2.4 v = 1600 rpm (max 13.2 v- min 10.8 v @ 2000 rpm with minimum = 400 rpm) but when used fan expert to tune the fans it is more exponential curve than a linear curve. New MBs have fan tune built in in BIOS.

@iraqiwarrior - Yes, I saw the same limits in AMIBCP, but they can be edited in NVRAM or Setup module of BIOS. From your software experiences we know they can go lower than that.
So without a BIOS mod you can test the above mentioned grub edit and see if it applies, if it doesn’t you can use grub to put back default.

This sounds like some corrupt bit/bytes in the BIOS or NVRAM, since it’s not even actually going to the default locked limits of the BIOS minimums. If you want, I can help you to first make a BIOS Backup, then we’ll verify that we have your UUID, LAN MAC ID, Serial etc.
I will put that into clean rebuilt BIOS from parts of your backup Then I will show you how to erase/rewrite the BIOS regions included in the package I will send you.

Before any of that, lets update your Intel ME to latest version, to be sure this is not part of or adding to the issue. This will also help you get familiar with some of the tools/methods we’ll use to make sure the BIOS is not corrupted.
This will also get you familiar with booting to grub, so you can later try the edit I mentioned (@ variable 0x444), and if that works we can later make edits to set it or others even lower once confirmed these edits get applied beyond the current constraints.
Please download this package of Intel ME System Tools V9.1 -!uQV12IxD!KGAUutQZrdL7T…SugQhzGkt5K5EWU

Inside you will find Flash Programming Tools (FPT) folder, we’ll use that in later procedures, but also you will find FWUpdate folder, and inside that the Win32 folder is the one we’ll select in a little bit.
Please download this latest Intel ME FW for 9.0 systems ( unzip this and put the file into the Win32 folder mentioned above -!nVslyIaY!P4r7p843C491A…NjbusBs2bepVsrU

First, lets confirm your Intel ME FW is not corrupted, do this by checking the main page of the non-GUI part of the BIOS (the F7 textual type). On the main page, do you see ME FW Version number, 9.x.x.x something like that, or or N/A.
If you see zeros, or N/A we’ll have to use FPT, if it shows number we can proceed with ME FWUpdate. If your BIOS does not show this at all, some do not, check with HWInfo64, on the large window, in motherboard section expand and see the ME section, then check FW version, if you see version and not zeros or N/A then OK we can use FWUpdate tool

If ME is showing OK/healthy, not or N/A, then we can now update it using method below. If the FW is not healthy and is showing or N/A we’ll have to use another method, I will provide later if that is the case.
If all is OK, then go to the FWUpdate folder, and inside that select the Win32, then hold shift and press right click, choose open command window here.
Once command opens, run the follow command

FWUpdLcl.exe -f

Once that is done, reboot and either check ME FW Version in BIOS or once back at desktop check ME FW Version again with HWInfo64, it’s now updated to correct? If yes, let’s proceed.

Go to Intel ME System Tools folder, and inside find the Flash Programming Tool folder, inside that the Win32 folder. Select Win32 folder, hold shift and press right click, choose open command window here.
Then run the following commands, and send me the files created.

FPTw.exe -bios -d biosreg.bin
FPTw.exe -gbe -d gbe.bin
FPTw.exe -desc -d FD.bin
FPTw.exe -me -d ME.bin

The ME.bin one may fail, it’s OK, don’t worry, it may be locked from this tool accessing.
Once done, zip all those files and send to me, I will use them to create new BIOS with your specific board details (Serial, LAN ID, UUID etc) and we’ll erase and reflash a few regions of your BIOS to ensure all is in their properly without any bits or bytes corrupted.

If once done, all this does not help, then only option is for you to try the grub edit I mentioned at post #13 in attempt to lower current minimum limits. If that works, we can lower all the specific limits using other variables which I’ll give you when and if we get there.

@Lost_N_BIOS I think it is going to the default minimum of 60% = 1600 rpm and don’t see why you think it is corrupt? As mentioned previously the operating range of the fans is 2400 to 400 rpm (10.8 v to 13.2 v) so 60% of the fan operating range is 1600 rpm but I don’t know if the MB at 60% is meant to produce the voltage to run the fan at its 60% limit.

My original ME

I have generated the files (see link below). The ME.bin failed and my ME version is!AnMDQn11O3jym6I30s-p0cTUP-uM9A

I was only thinking maybe corrupt, or some issue. I assumed you were testing on the CPU header too, which should go down to 20% or 40%, but I thought that was also not working for you.

FPT ME command I expected would probably fail. That’s why I went ahead and sent you link to latest version and showed how to update it. Since it is healthy you can follow the instructions I provided in the middle of previous post to update ME to latest
Once you’ve updated ME to latest check and make sure new version is reflected at BIOS main page location or with HWInfo64. Then once that’s done, I will redo BIOS for you. This is just in case something is messed up, if you do not think it is, then we don’t need to do that.

Did you try what I mentioned in post #13 yet, changing that CPU default of 40 to 30 and seeing if it takes effect or not? If it does, we can lower the other 60% limits down to 20 or whatever value you want