ProBook 4540s - he starts when he wants


I have a very strange problem with my HP ProBook 4540s so ANY help is appreciated:

Press the Power button, the power LED turns on for like 1.5 seconds (including the caps lock, AC LED and also fan, the display doesn’t turn on) and then turn off and then he tries to startup again and sometimes it does show the HP screen and boots normally sometimes doesn’t and turns off and then on for 1.5 seconds and so on and on…

I tried:

- Reflash the latest version version of BIOS
- Rollback of BIOS doesn’t work (invalid signature file says when I try to flash the BIOS but I tried different versions but same problem) and I still have no solution for this to work.
- Take out SSD.
- Take out the RAM, I tried switching the slots but has no effects.
- I tried reset the BIOS via taking out the CMOS battery. I even replaced the battery and nothing.

The problem is present no matter if I am on battery or AC power.

It happens randomly, sometimes it boots up on second try sometimes on first try sometimes at all.

I hope that I explained the problem good enough, If you have questions please ask me because this problem is driving me nuts !!!

Did this happen on older BIOS? If not, do you have the old BIOS you were using before?

Did you try the BIOS rollback from Diagnostics menu? Hit ESC at startup to get boot menu, then choose “system diagnostics” Then in there you should find “Firmware Management” that will let you roll back BIOS
When doing this option, have all files extracted from to root of FAT32 USB, and all files from “BIOS Update” folder too (These extract to c:\SWSetup\BIOS-exe-name folder when you run the exe, get these files I mentioned from here or extract exe with winrar)

Also, did you try this “Hard Reset” See last post…/6219808/page/2

And then follow link in that post to create USB Recovery BIOS from the older version you want to use


Like I said I tried that via HP UEFI Diagnostic Tools and no luck. I did get invalid signature file on the older BIOS. I have all the files on the USB like you said. If I want to flash the current bios there are no problems…

I tried even the last method via Windows Key + B key but nothing. Caps lock blinks continously and the fan is at max speed but no activity on the USB.

I don’t know why this happens when I have rollback option and I downloaded and put the correct files on the USB drive formated via FAT32.

Here is the log:


2018-12-12 21:37:20 Verifying Binary match
2018-12-12 21:37:20 Loading Signature File
2018-12-12 21:37:20 New Bios Verify Signature Return Result not handled (Invalid Parameter)
2018-12-12 21:37:21 Verify Image signature: Bios Verify Signature Not Succeed (Invalid Parameter)
2018-12-12 21:37:21 EfiBiosUpdateLibEntry(): Result is 0x3

This is with F64 BIOS version. The current installed on the system is F67.

You never said that (HP UEFI Diagnostic Tools ), at least not on this forum in the above post

You didn’t answer my question, did this not happen with previous BIOS? If not, then it’s worth looking into further to rollback, if it did happen then too then there is no point, something else is causing the issue.
Have you ran memtest86+ on the memory for any length of time (8+ hours)?

I can maybe help you roll back “BIOS Region” but since this system is RSA signed BIOS, it may fail to boot, so I would suggest you purchase CH341A flash programmer and SOIC8 test clip cable on ebay ($2.50 each) before we did that.
And once you have those, no reason to use that method anyway, you could then program in any BIOS version you want provided you can find a full valid dump for it (Since rom.bin is not a complete BIOS)

Ok sorry about the first thing. I posted on many forums.

No, it didn’t happen on previous BIOS that why I am tring to downgrade.

If the system boots (like I said boots after a couple of tries maybe), can I just dump the entire BIOS from Windows or Linux ? if I buy something from ebay it takes a month at least to get here.

It’s OK, I thought maybe you had posted around a few places. No, you can’t dump entire BIOS due to security locks in place within the BIOS, not without pinmodding the board, and we don’t need this BIOS dumped anyway (you hate this BIOS)

Yes, it will take 3-5 weeks for programmer and SOIC8 cable to arrive from China, place your order now. If you are in US, you can get these on Newegg or Amazon, or you can also pay more for faster shipping to anywhere on ebay or amazon, you just have to find/ask the sellers if they offer quicker 2 week shipment for more $$

As a result of this, this hard reset, resets which memory if is not the SPI ?