QL32 Kaby Lake Xeon Engineering Sample on Asus Prime Z270-AR - Works but Can't Restart

Hi, as the title says I recently modded my Asus Prime Z270-AR to work with my QL32 CPU. It works 100% fine after I turn it on, but once I turn it off, I can’t turn it back on again without power cycling my PSU. Same goes for restarts as well. I modded the board’s BIOS through Intel FIT and flashed it with a CH341A SPI flasher. It doesn’t do the same thing with my Celeron G3930, which sounds like it’s an issue with my CPU, but I can’t find any owners of A0-stepping Kaby Lake chips complaining about this issue.

Any help would be appreciated. Thank you!

What did you do via FITc? Update ME or roll back ME, anything else? Have you tested other ME versions?

And does your BIOS have correct microcode to support this CPU?

Sorry, I just saw this.

I used FIT to disable ME. My BIOS has the 506e8 microcode for my CPU.

I also attempted to use ME version as I’d heard that would work, but my board wouldn’t boot at all then.

Sorry, I forgot to tag you @_haru Did you test older ME instead of disable? And did you test disable in other ways?
How did it act before you did anything to ME? I see this comment here, same CPU/Board and it’s OK, maybe it’s you? http://www.cpu-world.com/sspec/QL/QL32.html

Did you try adding 506E3 microcode too? https://page.auctions.yahoo.co.jp/jp/auction/r287575678

The power problems you describe is due to ME is disabled, you can try doing that in other ways (ME Cleaner can do a few ways), or you will have to live with it if you want to run this CPU on this board since ME disabled seems to be required.


That’s okay! I just saw in the original thread about the mod that the original ME version had to be 11.0.xx before you disabled it. I’m about to try that. What’s the earliest 11.0.xx ME version that can be used on z270 boards?

That listing is false, this is a kaby lake a0 chip and uses the 506e8 ucode. but regardless, this bios has it anyway.

What options can I try with ME Cleaner?


@_haru - I don’t know, I would try 11.6
On ME cleaner, I don’t know, I’ve never used it, but I know it has several options/method to disable (Some partial, some more fully etc). I would make three BIOS, two with that tool, and one same way you did before with FITc, and the new older ME.

@Lost_N_BIOS 11.6 was what was on the board to begin with :frowning:

I’ll try the different options now and get back to you.


Tried everthing, no luck. There’s a Biostar Z170W for cheap and I’m going to just buy that :stuck_out_tongue:

But did you try 11.6 with the ME disabled three ways? @_haru

@Lost_N_BIOS Yup. I ended up getting a MSI B150A Gaming Pro for dirt cheap locally, and aside from a warning about the missing ME on boot it works 100% fine, including restarting. Thank you for your help though!

@_haru - at least now you have good working board for that CPU, resell the other and get your $$ back. You’re welcome, but sorry I couldn’t help figure it out for you.

Haha, I will!

Minor necro - just tried a retail E3-1230 V5 on an Asrock H270 Performance, and i’m suffering from the same issue. I think this means most, if not all, 200 series boards can’t fully work with Xeons for now.

Maybe true @_haru - Probably @dsanke or @svarmod or @revlaay could tell you more for sure on that.