[QUESTION] NVME in Skylake after BIOS flash invisible?

Hi,

First of all: This is my first thread, if it is in any way deemed to be inappropriate, please tell me.

Long story short: I have an Samsung Spin 9 (NP940X4L-K01US), updated BIOS to latest P09AFD, and tried to get a 950Pro 512gb to work.
Slot fits, after intel documentation it should only be a matter of “flexible” IO to assign the SATA-Ports to PCIE storage.

The original BIOS is a joke, so I went for IFR extraction and played with “setup_var” till the point where I bricked my laptop.
Then came this forum to the rescue (thanks to @CodeRush for his very good thread on this matter), and I purchased a CH341a and reflashed my BIOS.

Furthermore I managed to activate all the advanced settings.
BUT: Whatever settings I try, the NVME is not showing up. Neither in BIOS, nor in my efi shell (thought it might appear as a mere pci device).
I tried nearly all combinations of SATA-Controller enable/disable/AHCI/RAID, Intel RST PCIE storage remapping enable/disable, port auto/5/6/7/8 (should be 8 on Skylake PCH according to Intel).

Nothing.

Maybe anyone is familiar and I’m missing something? I’m a quick study, but maybe I still overlooked something.


When ever I try to update the Intel RST OROM via UBU, the menu “Intel Rapid Storage Technology” disappears in BIOS when I put the controller in RAID mode.
With the original BIOS this entry is hidden, unless “RAID” is selected, but then again “no disks connected”…
There are even options for NVME-drives in the BIOS, AMI EFI NVME driver is also present.


Thanks for this forum, at least it helped me to unbrick my laptop several times :slight_smile:
Regards
CodeRookie

Just how or what method did you employ to activate Nvme??

@CodeRookie :
Welcome at Win-RAID Forum!
Questions:
1. Which OS are you running?
2. Did you install the OS in UEFI mode?
3. Is there an NVMe EFI module within the notebook’s BIOS? If yes, has it been there natively or did you insert it?
4. Have you tried to boot with a FAT32 formatted USB Flash Drive containing any Win10 image in UEFI mode?

You certainly mean the Intel RAID EFI module named “RaidDriver”, because the UBU tool doesn’t update any Option ROM module on systems with an AMI Aptio V BIOS.

Regards
Dieter (alias Fernando)

@Fernando :

Hi,

Thank you for the welcome.
To Answer your questions:

1. No OS currently (because of fore mentioned problems)
2. I cannot say, there is no way to start an OS, but UEFI is enabled, CSM is disabled, Secure boot is also disabled
3. Yes there is, UBU says its an AMI EFI NVME, there is even a module called NvmeRecovery, so the BIOS should be definitely capable.
4. I’m about to try with Windows 10, I also reflashed the “original” bios, just containing the menu mod. So far no luck.

Greetings

@davidm71

According to various sources it is a feature of Skylake PCH, at least the device should show up somehow.
By configuring RST PCIE mapping, sata ports are going to be “remapped” to pcie, so the device should show.

I am aware that there will be also some troube getting a OS with nvme to work, but I’m pretty confident that I’ll manage.
Problem is, the device is completely hidden.
Also in my BIOS, under advanced, there is a menu point “NVMe Configuration” (help string says “NVME Device Option Settings”, but again nothing detected.

Hope this clarifies it a bit

Oh so your having a configuration issue. You should have native support. First of all how is the drive connected onto the motherboard? Does turning off RST pcie mapping make the drive visible?

@davidm71

No. I tried all possible combinations, from SATA Controller disabled, AHCI, ports enabled and disabled, RAID ports enabled and disabled, RST on and off. The drive never shows.

@Fernando
In order to answer question 4:
I also reverted back to P08AFD, no OROM tinkering whatsoever.
However in Windows 10 setup, the device is never recognized, using all combinations mentioned above.
I also checked HKLM\System\CurrentControlSet\Enum\Pci, never shows anything than the usual suspects…

However what is strange is that “Intel RST device cfg#1” is disabled and its showing “Intel RST device cfg” for #2 and #3 respectively.
Intel doc states, there are only 2 configurations, namely #1 and #2 present. So maybe the bios is faulty.

I’m trying to determine the EFI modules for PCH/PCIE intialization, maybe the modules from DEll 9350 are in any way compatible.
If not, I’ll flash the working bios back. Maybe the Bios is doing the initialization wrong.

If I had more time, I’d go through the trouble of writing an own UEFI application, but at the moment I cannot spare the time.
Interesting though that I can disable “BIOS lock”. If I’m not mistaken, this would allow for remapping of the ports even after leaving BIOS, because the PCH is not notified that the BIOS phase has been finished…
Interesting stuff…

The NVME is working, had it in an XPS 13 9343 before…

@CodeRookie :
This is what I recommend to try:
1. Create a bootable FAT32 formatted USB Flash Drive with the desired Win10 image by using the tool Rufus. Make sure, that the GUIMode Partition Table has been enabled within the Rufus GUI.
2. Unplug all devices except the NVMe SSD.
3. Boot off the USB Flash Drive in UEFI mode and check, whether your NVMe SSD will be detected by the Win10 Setup.

@Fernando :

Hi,
As I said, Windows 10 is not the issue here.
No need to use Rufus, just made a 4GB FAT32 gpt partition by myself, copied the contents of the Win10 Iso directly onto the stick, boot.
Now I’m using a Micro-SD, because my stick is very slow (~3MB/s).

However: I’m booting in UEFI mode, Windows starts, there is nothing left to unplug since this is a Ultrabook containing only 1 m2 slot…
And as I said, with all combinations nothing is ever detected. When I exchange the 950Pro with Liteon CV1-8B256, then it is detected right away (so the slot is working)…

Cheers

@CodeRookie :
If I were you, I would contact the Samsung Technical Support and ask, whether the Samsung 950 Pro is natively supported by their Spin 9 Ultrabook or not.
Maybe the BIOS needs another/better NVme module.

@Fernando :

Hi, even though it sounds like a plan, I already had my encounters with Samsung “Technical” Support, and helpful answers like “Please install the latest drivers”.
Not so helpful.

I’m now going for a WinPE, and try to fiddle the PCI registers with H/W RW Everything. Maybe something comes up…

If anything changes, I’ll keep you posted.

So long…

Hi All,


I found a promising lead. Looks like the feature I’m seeking is called “SATA Express” which allows switching of M.2 connection between SATA and PCIE mode.
While reading the INTEL PCH specification, I found this:



In my Bios I have an option for each port, called "Typology" with an option called "Flex"… Never set it to this value, according to Intel this should let the controller probe for and enable PCIE instead of SATA…
Keep you posted…