R720 Bricked Bios Help


I have a dell R720 that I bought but the bios seems to be corrupted. I have tried almost all the options in order to attempt to fix and troubleshoot it hut have had no luck. I have working IDRAC but no vga or virtual console. Idrac shows the post code 0x7f after a couple of minutes although I suspect this is an error as it does not have any os installed.

I have bought a bios flasher clamp but I do not know how to locate the bios chip or how to use the clamp to repair the bios. Can anyone help me?

Thank you



Are you sure that across those threads and posts there’s not a single info or foto with SPI location…

Those posts do not have the same issue

Hello @LeCodyMan ,

Are you using the onboard VGA connector?

Have you tried using a VIdeo Card?

Using a video card doesn’t work

Anything over the serial port?

There should be messages during the boot process.

How many CPUs are installed?

2 cpus, haven’t checked the serial port. I am thinking I need to swap in an older cpu to update the bios

Using a E5 -V2 ?

Are you able to flash from the iDRAC web interface?

No as for that you need to be able to boot into the lifecycle controller