Raid 1 Windows 10 1 Drive in Bios 2 in windows..

Ohla… So I’ve gone through hell and back and can’t get this to work. I’ve reinstalled windows like 5 times but nothing seems to work so now I’m looking for help…

I’m running a fully updated Windows 10 installed in Raid mode on an Asus P5Q-Deluxe motherboard. Bios is latest version… Raid1.

Problem nr1:
In the raid setup my two 3TB drives (same modell) show up as one drive. All though it shows as 746gb instead of 3tb.
Problem nr2: In the bios the raid shows as 1 drive. But when I sign in to Windows they are 2 sepparate drives in Windows DIsk Manager…???
Problem Nr 3: when I run the latest version of Intel Rapid Storage Technology Driver it says it’s a successfull installation but after reboot I get BSOD saying Boot device is not working so that’s not an option…

What am I missing, please help! Thanks in advance…

@alexgilseg :
Welcome at Win-RAID Forum!

You forgot to give us some important informations:
1. Which chipset has your mainboard?
2. Which version has the RAID ROM module, which is within your current mainboard BIOS (= version of the RAID Utility)?
3. Which RAID driver version did you install?
4. On which drive disk is your OS?

Dieter (alias Fernando)

Thanks for the quick reply!

1. Intel P45/ICH10R with Intel® Fast Memory Access(FMA) support.
2. Intel Matrix Storage manager option ROM v8.0.0.1038 ICH10R wRAID5
3.Version: (Latest) Date: 12/14/2015 from;…RST-RAID-Driver
4. Os is installed on a SSD not related to the drives I am trying to RAID. Would you like a picture of what the Intel Storage Manager looks like for my drives?

Thanks so much for taking you’re time with this… Spent so long fiddling with this, if I don’t get it to work it will feel like I’ve wasted so much time…

Your currently installed RST(e) RAID driver v14 does not resp. does not fully support your old Intel Chipset.
This is what I recommend to do:
1. Uninstall the currently used Intel Rapid Storage Software from within the Control Panel.
2. Reboot.
3. Install the Intel RST(e) RAID Driver & Software Set v11.7.4.1001 WHQL.
This way you probably can solve your main RAID problems.
If you want to get your >2 TB sized RAID partitions detected, you have to update the Intel RAID ROM of the mainboard BIOS to an RST version > 10.5.

Thank you so much…
I’ve downloaded the set from your website. This page is truly amazing btw, thanks for this!

I’ve tried to uninstall the drivers. I even reinstalled windows but it seems windows 10 comes with drivers that are version SARA RAID CONTROLLER DEV:2822 (
Not matter what I do when I launch your installfile it says that that version is alredy installed, do I want to downgrade. When I choose yes, it starts installing but after a few seconds it crashes with the error: The setup program failed to install one or more evice driers, setup will exit. This happens after:
Copying file difxapi.dll
Installing Driver Sata raid controller DEV:2822

Seems there is a conflict with your setup and the existing version. I don’t know how really remove the existing one. Any sugestions?

PS. If I uninstall from the device manager without rebooting and then try and run your Setup.exe it says This computer does not meet the minimum requerments for installing the software… Grrr, thought I could trick it…

Edit, read my post and it was a bit unclear… Even if I uninstall the driver in device manager it’s there as soon as I have rebooted… I can’t get rid of the driver. Whatever I do it’s there after reboot…

Did you uninstall the Intel RST Software?
If yes, you should be able to downgrade the Win10 in-box Intel RAID driver manually from within the Device Manager to the v11.7.4.1001 WHQL, but you have to force the installation by using the "Have Disk" option.
The best way to get rid of the in-box Intel RAID driver is to remove it from the OS image by using NTLite according my guide and to do a fresh OS installation.

Yes, uninstalled the software…

“Hard Disk” option doesn’t work either… “Windows encountered a prblem installing the driver software for your device”. Error bla bla, no details at all just says it doesn’t work…

So I’m following you’re guide on how to prepare the windows iso in NTLite.
At this section: Optional for Intel RAID users: Removing the generic Intel RAID driver named iaStorAV.sys from the chosen Windows image:
When trying too:Uncheck the “Intel Corporation | iaStorAV.inf” section. The box goes grey and stays checked and I get a message on the right hand side; "locked by copatability. - Host machine (DESKTOP -UT3KUll)

Can I skip this step since it says it is Optional or do I have to do something about this?
Thank you…

My appologize, i figured out how to remove they grey marked fields and remove the drivers… Now about to reinstall windows with my newly modded installfiles… I’ll be back to tell you how it went…

It is fine, that you have removed the in-box Intel RST RAID driver from the Win10 image. In this case I recommend to integrate or load the Intel RST RAID driver v11.2.0.1006 WHQL, because it is the better choice for your system.

ARgh…, saw this just now… Spent another night with this and darn it still no raid… I got the Drivers loaded into the win10.iso and installed that… And it worked, got the drivers in the new windows but the raid is not working. It still shows as 1 drive in bios but in windows it’s still 2 separate drives… Sadness…

Do you recommend me to try again with Drivers or should I go and buy another motherboard? ;)… My wife is not happy with me spending so much time infront of the computer 3 nights in a row haha…

Please post a screenshot or a picture of the Intel RAID Utility.…nt=folder%2cjpg

there you go… pictures of both the inte rapid storage utility and from the Raid Bios utility… Hope that helps…

Just dodged a bullet… Thought that if I flashed the bios and got a later option rom that things would get better… So I downloaded Intel-RST_RAID-ROM_v10.5.1.1070_TRIM-mod-acc-CPL0 and modded my biosrom with mmtool according to guide. And I thought it was a success… At first reboot I got into my raid utility and it was 10.5 and I got my raids full size =)… But then after that it rebooted and the whole computer froze, not ossible to do anything other than ctrl alt del… No bios no raid utility no nothing… Pulled out battery and praise the lord I get into bios after that and reset it to previous version and now I’m back at square one hehe… Should I maybe give up this version and reinstall windows on the one you suggested a few posts back?

My advice is to update the Intel MSM RAID ROM to the Trim modded Intel RST ROM v10.1.0.1008 as first step.

Good luck!

But you said I need at least 10.5.* for the 3 tb disks to work properly…??

Yes, that is correct, but your mainboard obviously doesn’t accept much bigger sized Intel RAID ROM modules. The latest much smaller sized Intel RAID ROM module is the v10.1.0.1008 one.
I am rather optimistic, that the recommended update of the Intel RAID ROM module will solve your RAID problems, but it will not solve your >2 TB RAID Volume detection problem.

Woop Woop!!! Raid 1 Success!! <3 3tb and all!

As it is now I didn’t update the bios… Sorted out everything. See the raid in Intel Rapid Storage tech application =) last question:

When I boot it still says that the raid is 746gb… DO I have to care about that? Could it make the raid less stable??

Can’t thank you enough dude!! You are a raid-rock-star!!!

It makes me happy as well, that your RAID array is now properly detected and working with Win10.
Unfortunately you may have to live with the 740 GB size limitation, but this problem is caused by the currently working Intel RAID ROM module version and has no negative impact on the stability of your RAID array.
Enjoy the success!


But in windows it says the drive is 3tb. And it seems to be running fine… Are you saying that when I reach 746gb the drive will stop taking in more data even if it says it’s less than 1/3 full? It’s quickly tested… I will start loading it with things and see if it can handle more than 746gb… I’ll get back to you with results…