RAID 5 and Seagate Archive SMR drives


I need some advice on where to start troubleshooting my RAID 5 issues.

I have written over 9TB’s of data to the array and was fine with the average of around 50-80MB/s (i think it was). I don’t need it to be fast… But the above is PAINFULL.

The ARRAY also initialised fine but took about 2-3 days.

But last week the ARRAY disappeared from W10 and I had to set ‘normal’ I think in the RSTe interface and the drive came back.

Now it said it needed initialising again…
It has been 7 days now and it is at 51%

Something is wrong but I do not know what?

The original ARRAY was on and ASROCK x79 Extreme9 board. But that died and I transfered it to the current ASROCK x79 Extreme4 (same chipset).
The RAID had been running fine since moving it about 3 weeks ago I think.

Installed RSTE v4.6
3 x ST8000AS0002 (8TB Seagate Archive).
128K Data Stripe
Write-Back Cache enabled.

Any info you need / troubleshootinmg you can point me to???


@FizzerUK :
Welcome at Win-RAID Forum!
It is not easy for us to help you, because we do not know the reason for your problem.
There are too many possibilities. Only you know, what you have done in the past and especially just before your RAID5 array has been degraded.
Dieter (alias Fernando)

Thanks for the welcome, actually been using the forum for a couple of years now, just never had a issue, all the guides have been great.

Yes, not knowing… This is the difficulty especially for me now!

RAID has been fine for 3 weeks after the Motherboard change.
BUT, I did not check write speed when I swapped it out, everything appeard fine.

SO could a difference in RAID firmware be the case?

Last week it went offline, not disk errors. No data loss.
Set back to online, I am looking in RSTe Help for the exact statement RSTe interface gave.

Write speed down to above post.

No hardware change since the motherboard 3 weeks ago, not OS change, no driver change.

9 days and still initilaising 66%. :frowning:

@FizzerUK :
Some ideas:
1. What about overclocking? RAID systems don’t like it.
2. Is your PSU good/strong enough?

I used to overclock in my ‘youth’ but stopped that game a loooong time ago.

Yes the i7 and x79 is from my golden of (only 5 years ago) gaming.

PSU I have not considered.

Have downscaled from 2 x 750W PSU to a single one running the 3 x Seagate archives and the GTX980Ti.
Before I had 4 3TB and 6 2 TB on 1 supply and the system SSD’s and Gaming card on the other.

I am going to do some power tests and let you know.
I still have my meters kicking around.

You maybe onto something here…

I did not even consider that!


There you go. Just takes an independant eye to suggest some troubleshooting that I have not thought of…

Put a PSU just on the 3 Archive drives and Bang!

This is while I am still initilising. Read speed is back up quite a bit.

Will wait until initilising has completed and do some further testing / troubleshooting / tuning.

Next step is to make sure my New / OLD motherbard setup has correct Firmware / drivers I guess!
Just as I did with the old one.

Thanks. Have a coffee on me!

@FizzerUK :
Thanks for your interim report, which seems to be really promising.
I hope, that your problem has been solved.


Finished initialising, write speed still very slow.

Now it has happened again. This time I have screenshot the exact error, except this time I could not set the disk to 'Normal’

Intel RSTe Interface

After a reboot I have

So I cleared the MetaData as the disk was not moving back into the array.
I was planning on creating a partition on the failed disk so I can test it out of the array to see if it is slowing everything down.

But have this in diskmgmt.msc and RST interface.


RSTe Interface

Here is the SMART info for GOOD and BAD disks is the BAD one failing? Can you tell from the SMART info.


BAD Disk out of ARRAY

I could try and RMA the disk but it appears online and healthy. That may not fix the issue.
I want to test the bad disk out of the ARRAY first.

Any advice!

Found the error in eventvwr.
Looks like a disk timeout for 2 minutes with disk resets issued, ARRAY marked as BAD then the disk cameback online.

@FizzerUK :
1. Is your on-board Intel SATA RAID Controller running in RST or RSTe mode?
2. Which Intel RST/RSTe RAID driver version and which Intel RST/RSTe Software version are you using?
3. Which Intel RST/RSTe RAID module version is within your mainboard BIOS?

RSTe mode (as above screenies)

Driver Software set installed was Intel RSTe Drivers & Software Set v4.6.0.2116

I have Intel RSTe v4.6.0.1048 listed in Programs and features

And BIOS ROM in the option ROM states v3.5.0

Is that what you wanted?

Why didn’t you use the RST mode RAID configuration?

I don’t know, whether it has something to do with your problems, but it is not a good idea to have the Intel RAID BIOS module and the in-use Intel RAID driver from different RST/RSTe platforms (Option ROM: v3, driver/software: v4).

Yes will look into this, I am going to re-install the OS.

The v3.5 ROM must have slipped in when I swapped Motherboards.
I will swap over from RSTe to RST, can’t remeber why it was RSTe as the system was built along time ago. Must have read somewhere…

Thanks for the input.

I remember why I use RSTe.
Motherboard is an x79 chipset C600, I believe I read somewhere that RSTe was the best way to go with it due to support.
Tried a W10 reinstall and RST but it was AWFULL disk performance.

Anyway back to RSTe. Install of Intel RSTe Drivers & Software Set v4.5.6.1009.
BUT again I have a disk going offline .
This time it is a different disk on Port 5.
Momntarily drops out, I have to reboot and reset the Metadata and add back to the array.
Before it happened I was getting 30MB/s write speed.

I do not know what is happening.

EDIT by Fernando: Unneeded blank lines removed (to save space)


Last update for a while, as I will have to put all the 8TB’s of data onto a ‘Pooled’ configuration so will take a while.
Before I do that I will need to really really read around and find the best software solution.
Something like ‘SnapRaid’ or 'DrivePool’

Updating post to RAID 5 and Seagate Archive SMR drives.

My issues are down to NOT reading around enough before buying what appeared to be good value hard drives.
ACTUAL useable storage cost of $220.00/7452GB = 0.295 Cent/GB.

If you want to read about the SMR (Shingled Magnetic Recording) then there are some great articles now as this technology becomes more popular.
Briefly SMR is a method of overlaying data tracks to increase storage capacity.
I am sure in the near future a lot of people will be looking at cheap large storage using this technology but should be aware of it’s limitations.
Anyway, I have defiantly had better luck with these drives utilising RST, once I got it installed and playing nice with my x79 chipset board.

The Seagate Archive ST8000AS0002 8TB is not really designed as a general RAID storage solution.
Seagate themselves does not recommended utilizing these drives in RAID or NAS environments.
Drives are more suited to ‘Cold Storage’ or WORM (Write Once Read Many). Below I posted an example of performance you get in RAID Read which I think is really good, but write is poor.
Also, attached a Cache drive SSD as I can now use RST as expected write is pretty level BUT read has dropped off significantly, shame I can’t just do Cache for write only.
I must also add, the drives still time out a little during testing, maybe due to the SMR technology but RST does not as aggressively drop the drive from the array as RSTe did.
Or so it would seem.

So, now to re configure the whole system and utilise these drives as intended.
I have an unused 120GB SSD for a cache drive.
Just need to find a software solution that is compatible to Windows and Linux if possible. May just stick with a windows solution, but I worry if I retire this PC to being a home server only then I would want to install a Linux environment.

So folks any suggestions / experiences of software like Stablebit DrivePool, any recommendations are greatly appreciated.

I will do a final update once the whole system is configured. Maybe it will be of help to 1 person someday.

Speed Raid 5 no-Cache drive in RST

Speed with 64GB of Cache in RST

@FizzerUK :
Thanks for your interim report.
You forgot to mention the “Write Caching” settings regarding the RAID5 array:
1. Which are the “Policies” settings of the RAID5 array (right-click onto the RAID5 device within the “Disk drives” section of the Device Manager > “Properties” > “Policies”)? Both options should be enabled, if you want the best possible write performance!
2. Did you enable the write caching option “Write-Back” from within the Intel RST Control Panel?

Had very little change in performance with both enabled.

Whenever I choose Write Back in the cache it would freeze on testing the Write in CrystalMark requiring me to Task kill the window.
System slowed also.
Testing read was fine.
This happened on BOTH my RAID0 SSD’s and the Archive drive RAID5.
Never found why, it would do this on the 3 different versions of RST I tried it on v11, v12 and v15.

Whenever I choose Write Back in the cache it would freeze on testing the Write in CrystalMark requiring me to Task kill the window.

Have you ever tried another (better) benchmark tool like “Anvil’s Storage Utilities”?

Yes, I use both along with ATTO.
I post Crystal as it is easier to post / read at a glance and I have found Anvil gives massively varying numbers 10MB/s to 60MB/s. Crystal always seam to be around the same, maybe a few MB/s different on each run.

The ATTO benchmark tool is the worst of all benchmark tools, because it only works with compressable files, which is not the situation while doing your daily work.

I do not agree with you regarding both points.
1. Posting an Anvil benchmark is as easy as posting a Crystal one. The only difference is, that the Anvil GUI uses more space, because it contains much more informations.
2. Different results do not automaticly mean a bad benchmark tool. If there is any system activity simultaneously running in the background (e.g. Windows Update), the benchmark scores will automaticly drop.