RAID 5 rebuild fails (Intel RST / Win10)

I have a RAID5 with 3 x 6TB SATA-HDD under Win 10 64bit. Recently one of the disks became unreliable.

At first, “Intel Rapid Storage Technology” marked the volume as degraded and offered to rebuild it. That of course won’t make sense with the damaged disk still in place, so I bought a new one with the exact same specifications (but unfortunately not the same make/model, because they are not available anymore).

Now if I pull the damaged HDD (Seagate ST6000NM0024) and plug in the new one (WD Ultrastar DC HC310) at the same SATA-port, Intel RST won’t accept it as member disk and therefore not offer a rebuild. The best I can do is to flag the new drive as “Spare” under Windows, but I still can’t figure out how to force RST to rebuild the volume on it then.

The only way RST is giving me access to the (degraded) volume at all is with the damaged disk plugged in, setting the volume to “Normal” under Windows and thereby automatically performing a rebuild on it. That of course will always fail at some point - after about 50% or so. After that, the volume is being flagged as “failed” (not just “degraded”) and not accessible anymore. All I can do then in order to access it again is reset it to “Normal” again, but that will start the rebuild process all over and the volume is terribly slow during that. Too slow to even copy files from it for a backup.

So my questions are:

What am I missing here? How can I trick RST into just using my new drive to rebuild the volume on it?
Or alternatively: how can I prevent RST from automatically starting the tedious and slow rebuild process and just give me access to the degraded volume instead (without that process running in the background and slowing it all down)?

Any help is appreciated. Many thanks in advance! :slight_smile:

@IntelRST_User :
Welcome to the Win-RAID Forum!
Your problem is obviously caused by the fact, that you are trying to replace one of the RAID5 array members by a disk drive from another manufacturer. Please keep in mind, that the current RAID5 array configuration inclusive the details about its members is layed down within the usually hidden track 0 of the array.
Bad consequence: You can only let the Intel RST Console "repair" the RAID5 array, if the members are still the same as during the former creation of the array (same manufaturer, same model, same size).
The only solution I know is to backup the data of your degraded RAID array, to break it thereafter and to create a new RAID array consisting of the 2 still working Seagate HDDs and the new WD HDD.
Good luck!
Dieter (alias Fernando)


- You’re sure your WD is 512e like your seagate disks? (WD Data sheet states “512e models can be converted to 4Kn format and vice versa”)

- Even a slight size difference- meaning your new disk being a tiny bit smaller than the old disks- could make a rebuild impossible.

Which RST version in bios and software?

Thanks a lot, guys!

Interestingly RST now seems to actually rebuild the volume on my spare disk. 31% now and counting… fingers crossed.

The only thing I did differently was to “initialize” and format the new drive, because I was already planning to just use it as a backup volume instead. Before that, I just plugged it in as is. I did not bother to put a volume on it, as it was already recognized by RST as a spare drive and I thought initialization and formatting was all done by RST anways. However, this could have made the difference now. Stupid me!

After one more failed attempt to rebuild the volume with the broken disk and a system hang-up thereafter, this now worked flawlessly after reboot: the spare disk was already allowed as RAID member in the BIOS and now it is rebuilding under Windows. Let’s see if it goes through.

So it could have been my fault altogether :slight_smile: Again thank you very much for your input! I’ll keep you posted!