Raid crash, OROM corrupted?


I have done the backups with ATI2014, in january 2015 then in may the computer crashed and everything looked bad, wasnt sure I would get the raid rebuilt since I got two or more drives from the raid10 with 4 hdds, many was seen as NON MEMBERS and the raid wasnt seen at all.
I changed cables and took apart whole computer, flashed the normal bios to latest and changed CMOS battery.

Fast Forward >> >>


I got my raid rebuilt and but was booting from it and after every reboot or shutdown the raid showed “SMART Verify Failed” on two drives (have changed the two to other sata-ports but get message on random sata-ports)
I connected the ssd to the Rocket 622 sata-card (pcie) and booting from ssd with win81(64-bit).

Every time I reboot/shutdown I still get that message and have to rebuild raid for 1-10 hours.
I havent lost any data, the harddisks are fine.
The computer is now stable and I have done backups.

I dont know what is wrong with the computer.
Q1: could it be the OROM that somehow got corrupted?

Intel  ICH9R - OROM
Intel Matrix Storage Manager (IMSM) with volume c:128GB, d:1.7TB

I havent flashed the OROM but is it possbile that the computer somehow got it corrupted?
Is it possible to verify the OROM?
Q2: could it be the motherboard that somehow got bad?
Q3: could it be the powersupply?

I could go on and on but Im asking on here, win-raid, and the first question, Q1

Have downloaded the latest IRST but after reading about alot of problems I haven’t installed it yet and not running Win 8.1 64-bit more than a few times a month since november 2013 and installed a backup program TrueImage 2014. I will do a backup when the OS is stable with a good raid driver.

There are much more but I leave that for later.

Computer information

Gigabyte P35-DQ6 - rev 1.0, F7 bios
Intel Q6600 G0 - 2.4 @ 3.200 Ghz, 400x8, Vcore 1.300V (Kentsfield)
ThermalRight Ultra EXTREME 120 + Noctua NF-P12 120mm fan
Corsair XMS DDR2 PC6400 5-5-5-18 2 x 2x2048 8GB kit @ 800MHz +( default )V in bios
Corsair HX-620W PSU | mb:Realtek HD audio 7.1 mb
Intel ICH9R - OROM
Intel Matrix Storage Manager (IMSM) with volume c:128GB, d:1.7TB
SATA: 0-3:4x1TB Samsung Spinpoint F3 in RAID 10, 64k stripe
nonraid SATA: 4:250 GB Samsung SSD 840 EVO, 5:1TB Samsung Spinpoint F3
Gigabyte SATA2/Jmicron - OROM 1.06.59
nonraid SATA: 0:1TB Samsung Spinpoint F1 1:
usb3:Silverstone EC04P- (1x-pcie)
nonraid SATA:Rocket 620 (4x-pcie) 0: 1:
MSI Geforce 780 3 GB Twin FrozR Gaming (16x-pcie)
27" QNIX 2710LED @96Hz PLS 2560x1440 | case1: CM Stacker T01
OS: 1:Windows XP Pro, 2:64-bit 3:Win 8.1 64-bit
VMware7: 2a:Win 7 64-bit, 2b:Win XP Pro

Boot order

1… 0:WinXP-1TB, 0:Win64-R10, 0:wProg-R10, 5:PS R10-SP, 4:Win8.1-SSD
2… 0:Win64-R10, 0:wProg-R10, 5:PS R10-SP, 4:Win8.1-SSD, 0:WinXP-1TB
3… 4:Win8.1-SSD, 0:Win64-R10, 0:wProg-R10, 5:PS R10-SP, 0:WinXP-1TB

Gigabyte… green, Intel… blue, Highpoint Rocket… orange, Samsung Spinpoint… red

Here is some SMART info from Crystal Disk Info of the four hard disks.

click to ZOOM…zps7n74z9m9.png…zpsq264l4yj.png…zpsjrvmcnjr.png…zpsxfzjci1a.png

* links works on other forum, ~original at the end of url

@ X-hellfire:
It is not easy to understand, what you have written within the thread opener, because you made some formatting mistakes. Example: Please open both “spoilered” texts and compare their contents.

This is very unlikely.

I don’t know, but this seems for me unlikely as well.

Yes, this seems to be possible for me.

This is what I recommend to do:
1. Check the PSU.
2. Try to update the Intel RAID ROM (minimum: MSM v8.5.0.1030, better: RST v10.1.0.1008, best: RST v11.2.0.1527).
3. After having succeeded with the update of the Intel RAID ROM, you should install an apprpriate Intel RST Driver & Software Set.


There is no " formatting mistakes" as the two spoilers has the same information, one with this forum BBcode, and the other one is a screenshot from another forum of what the vBulletin colored looked like, which I tried to make it similar to.

It´s the current system info, dont compare them, read one or the other spoiler, hopes thats explains the spoilers.

PS something happended to the forum now and the forum displays in german only now, the replay-button etc, so I will replay more later when it okay again.

Ok, that explains the similar content of both spoilers. Nevertheless I don’t understand, why you have posted them both.
Have you already tried to follow my advices?

Yes, that was temporary language package update bug of the Forum, but meanwhile everything should be in english language again.


Now the forum works again, thanks.

— Part I —

I have only described a small part of what is wrong with my computer, will try to show some history of what has happened.

It began some time last year, 2014, when I restarted computer and changed Boot Order in bios to the hdd-winxp, which is on the Gigabyte SATA2 controller (gsata2). It sometimes was missing when booting but after a reboot/power-off it would show again. However the computer would then use the safe-bios, its a dual-bios motherboard, and start with slow speed, no overclock etc, and I had to enter bios and enter the oc again. This could take 2-3 reboots to get the hdd-winxp to start correctly. Then I could have then computer on for a week, no problems.

Over time it has gotten worse, so it was a pain todo backups with Acronis True Image 2014 (ATI2014), when I booted raid-hdd-winxp(64-bit) it also was missing the gsata2 and the same procedure was required until a "good" boot was achieved, but it took maybe 10-20 reboots/power-off, this was in january 2015 when I did a backup in ssd-win81(64-bit).

In may 2015 I was going to do a backup again and then it took maybe 1 hour to get a "good" boot for raid-hdd-winxp(64-bit) and I ran that os for a week no problem.

Then I tried to reboot and get a "good" boot for hdd-winxp but it took 2 hours but eventually it worked and I ran winxp for a week with no problem and was ready todo a full backup. The ATI2014 is on the ssd in win81(64-bit) so I shut down the computer.

The next day it started in a bios-loop, powing down and cycling between "nomal" bios and "safe" bios but not not showing the screen to to enter bios, try to shut down computer but the same problem.

I read on internet that it could happen to my type of gigabyte motherboard so I followed a guide and removed all but one memory stick, all harddisks, ssd and changed reseated all sata cables


PS This is taking too long, will continue later, sorry I dont type fast to give the "full story" now, will post "part II" later.

Im not sure if something got broken when I rebooted so many times. As stated, the normal bios was flashed to latest and CMOS battery was replaced.

The Crystal Disk Info with SMART shows no "sector relocation" problem (ID 05) but some UltraDMA CRC error etc (ID 01, C7, C8) so harddisks looks fine, but the powersupply, Corsair HX-620W which is a quality good one could be bad, but I doubt it. I have a HX-520W in my other computer which I could test to see if boot problem continues.

I wanted to ask if you had seen similiar problems but was somehow a result of OROM that had been corrupted somehow before changed PSU.

I have some photos of the problems with raid volumes when booting, will upload later.

As I already have written, it is very unlikely, that the Intel RAID ROM became corrupted.
My advice:
1. Unplug all drives except the system drive.
2. Boot into the OS and test, whether the problem is still there or not.
3. If everything is fine, re-connect one drive after the other and find out, which drive is responsable for the issue.
4. If the problem persists, but cannot be assigned to a certain drive resp. SATA port, check the PSU.


I tried to recall the "full story" but it wil be later.

The short story is that it is random which drive gets "SMART Verify Failed" message at boot on random sata ports. Its not one drive that is bad, it is something else, what I dont know.

I have already disconnected all drives and changed all sata-cables. Previous I had problem booting the hdd-winxp drive on the gsata2 controller then I connected it to the Rocket 622 sata controller (pcie) and it worked without a problem for a week then disconneted it.

I have now the other "system" drive on the Rocket 622, the ssd-win81(64-bit), and it works on that controller without a problem. I have also connected the raid-hdd (the four harddisks in raid 10) and get boot problem, "Smart verify failed" on random drives, and after the "raid rebuild" which takes 1-10 hours the computer works without a problem until next reboot/power-off.

Its not a drive that is bad.

I can now do full backups so the data is "safe".

I will change PSU and see if it helps, I doubt it.