raid doesn't work after replacing motherboard

Hi, great forum. I am not sure if this is the right spot to ask this question…

I have a PC with a asus m2npv-vm mother board with an nForce 4 raid controller. I had winXP 32bit installed on a raid-0 partition. I was having BSOD issues sometimes and was having to run scan disk alot. I plugged in an ide drive and installed xp on that and used the raid partition as a data drive and removed the original OS from it. That worked better for a while but still had BSOD issues. I then noticed the errors were related to the raid controller still, so i disabled raid in the bios even though the raid bios said the stripped array was healthy. then things were a bit better. I then installed win7 on the ide drive to see if the raid would work better in win 7. no not really haha, but it did work. The onboard nForce network card had always been flaky (although bios updates helped a bit) and now it wouldn’t work at all. Then the motherboard completely died.

At this point I really just wanted my data off the raid drives but I learned you can’t just use any old controller so I bought the identical motherboard off ebay, hooked it up and got back into windows 7 fine (still with the raid drives unplugged). I updated the bios to the latest 5005 again like I had on the old board. The network card even works now yay. then I plugged the raid drives back in and enabled raid and the system wouldn’t boot. just got hung on " Media Shield Rom Bios 6.50 detecting array…" screen. I though maybe it mattered which sata ports I had the drives plugged into originally so i tried every combination to no avail. I couldn’t even get back into the bios. so I cleared the cmos, got back into the bios and left raid disabled.

I leaned through experimentation that I could boot with the raid controller enabled with no drives attached to it ok. The previously raided drives were detected in windows 7 as normal drives although one of them didn’t get a drive letter and seem to have issues in computer management. If I put one of the drives back under raid i could boot and get into the raid bios and see that there was an error with my striped array (because the other drive was missing). but if i plugged in the other drive by itself under raid, I couldn’t boot or get into the raid bios, just stuck at “detecting array…” again. So i am worried that the second drive is damaged or corrupted or something.

I really want my data back so I am not willing to give up but I am not sure what to try next. Can I turn off raid, plug the drives in and run scan disk or something in windows to try to fix them of will that ruin my array?

I have just installed your Fernandos non-AHCI nForce Performance Pack for Win7Vista 64bit v9.0 drivers in anticipation of things working but I realize if I can’t boot, that won’t help.

@ holderar:
Welcome at Win-RAID Forum!

I suspect, that the OS (Win7) has not installed the correct NVIDIA nForce SATA and RAID drivers for all RAID devices.
This is what I recommend to do:
1. Boot into Win7, open the Device Manager, hit "View" and choose the option "Show hidden devices".
2. Open the "IDE ATA/ATAPI Controllers" section and check the driver details of the listed SATA Controllers. The SATA Controller, where the RAIDed HDDs are connected, should use an nForce SATA driver. If not, install it.
Dont reboot!
3. Open the "Storage Controllers" section of the Device Manager and check the driver details, which are used by all the listed NVIDIA nForce devices (one after the other) by doing a right click onto them and choosing the "Driver" tab.
4. Choose the "Update Driver Software" option for all devices, which do not yet use either the NVIDIA nForce SATA or RAID driver, and instell them.
Dont reboot when prompted!
5. Verify that the "NVIDIA nForce RAID Devices" are using the nForce RAID Driver and the NVIDIA nForce Serial ATA Controller is using the related NVIDIA nForce SATA driver.
6. Now you can reboot.
After having done this your RAID array should be detected by the OS.


Hi Fernando,

Thank-you for taking the time to comment. You provide an excellent service here.

doesn’t the idea that Win7 doesn’t have correct drivers assume that the raid bios can see a healthy partition to start with? I am not booting to the point of even starting windows 7 yet before the system hangs.

My drivers seem ok from what I can gather


If the NVIDIA nForce RAID (MediaShield) Utility sees the RAID array, but the OS doesnt, the reason is clear: Win7 hasn’t installed the correct nForce drivers for all devices, which are part of the RAID array:
1. NVIDIA nForce Serial ATA Controller,
2. NVIDIA nForce RAID Controller and
3. the 2 NVIDIA nForce RAID Devices (that are the HDDs, which are members of the RAID array).

Does this happen even after you have unplugged the RAIDed HDDs?

And what about the other NVIDIA nForce RAID devices?

Hi Fernando,

I can boot into win7 with the raid controller enabled if I have either none of the drives attached to it or just one but not the other. I can boot into win7 with both drives plugged into non raid sata ports and i can see the drives in windows although their fire system is unknown .

Attached is a pic of the raid controller driver info in device manager. It sure looks like your drivers. I’ll have to reboot and plug the raid drives back in to see the drivers they use. brb.


@ holderar:

What about the (usually hidden) NVIDIA nForce RAID Devices? Which driver are they using?

when I boot with the raid controller enabled in the bios but with no drives attached to it, and also have my two raid drives plugged into non raid ports so I can see them in windows, the two sata drives use the microsoft drivers not the nvidia ones! see attached pic. Also you can see from the other attached screenie that in computer management, the second sata drive is not initialized and computer management wants me to initialize it before it can go anything with it. I am fearful to do so as i worry it will distroy the raid array so I haven’t.

looking into the usually hidden devices now…



when I show hidden files the only thing I notice different are the storage volumes and storage volume shadow copies. all drivers for them are microsoft. they don’t provide much info regarding what they are. I assume the last two storage volumes ate the sata drives.


You should not look into the "Disk Drives" section of the Device Manager. All Disks are and should be managed by the generic MS disk driver.
Please do, what I have written some posts ago:
1. Let the Device Manager show the hidden devices ("View" > "Show hidden devices").
2. Open the "Storage Controllers" section of the Device Manager.
3. Check the driver of the listed RAID devices.
4. If the in-use driver should not be the NVIDIA nForce RAID driver, do a driver update of all listed RAID Devices - one after the other (maybe it has to be forced by using the Have Disk" button).
5. Reboot.

EDIT: The (usually hidden) RAID Devices are only listed within the "Storage Controllers" section, when the members of the RAID array are connected with the correct SATA ports, which are running in RAID mode.

Hi Fernando,

as I mentioned before, I can’t boot with both raid drives connected to raid enabled sata ports. I can only boot with one drive or it hangs. so I booted with the one drive attached to raid and posted the details of the hidden raid device like you asked. It is using a nvidia driver but I am unsure if it is the correct one. Perhaps you could tell me. I currently have no way to check the other drive.


@holderar :
This is what I suggest to do:

  1. “Downgrade” the in-use nForce RAID driver v10.6.0.319 (= Win7 inbox nForce RAID driver) to v9.99.09 by navigating to the SATARAID folder of my “Non-AHCI Performance Pack”. You have to force the installation by using the “Have Disk” button.
  2. Check the driver version of both NVIDIA nForce Serial ATA Controllers, which are within the “Storage Controllers” section. Both of them should have v9.99.09. If not, install them by updating the driver.
  3. Power off the PC, unplug the RAIDed HDD, where you just have corrected the nForce RAID driver version, and plug in the other RAID member.
  4. Boot into the OS and repeat the just done procedure with the other RAIDed HDD.
  5. Power off the PC and reconnect both RAIDed HDDs.
  6. Try to boot into the OS (finger crossed).

ok so I was able to downgrade the drivers on the first raid drive but I cannot do so with the second drive because the system won’t boot with it plugged in to a raid enabled sata port regardless if the other drive is plugged in or not. I always hang on the detecting array… screen

when I plug it into a non raid enabled sata port I can see it but computer management pops up a request to initialize it. I so far have not done this. perhaps if I did this the drive would be magically fixed, or more likely, the raid partition would be destroyed. I don’t know.

so i am stuck at this point.

Have you ever tried to connect both RAIDed HDDs to another SATA port resp. to switch both SATA cables (1. HDD 1 to port0 and HDD2 to port 1, 2. HDD1 to port 1, HDD2 to port 0) ?

Hi fernando,

of the three accessible sata ports on my motherboard ( port 2 is blocked by the video card now and back when the raid did work on the old motherboard) I have tried every combination of the three with the two drives.

Now I am at the end of my knowledge as well.
If I were you, I would try the following:
1. Unplug both SATA cables from the RAIDed HDDs.
2. Boot into Win7.
3. Do a hot plug-in of the HDD, which obviously doesn’t let you boot into the OS.
Worse case will be a BSOD, but if you are lucky, the HDD will be detected by the OS. In the latter case you may be able to downgrade the driver of the NVIDIA nForce RAID Device.

Another option may be a fresh install of Win7 or Windows XP with the option of a better support of the nForce RAID array from scratch.

ok I will give it a try.

The whole point of this is to get the data off the drives. I have some family photos and videos that I’d like back. There is no OS on the raid drives and I don’t care about this computer as a whole other than the data. I bought a matching motherboard to give myself the best chance to get the data back.

if this fails, I might just initialize the drive in windows when its plugged in as non raid and then try to connect it as raid again. if that destroyed the partition then oh well. it sounds like we are out of options for this recover attempt.

You are right: There are not so many options left.

Good luck (fingers crossed)!

ok so I have made some progress under your astute tutelage.

Once I got your drivers running on the first drive, I still could not boot with the other drive plugged in. so I did what you suggested and hot plugged in the first one and it appeared in device manager as an originally hidden raid device. it took a few minutes but it came up. Then the nvidia storage control panel popped up a message alerting me to the ability to manage the drive. I went there and it showed me it had one 500 gig drive listed as part of a 1000gig raid array and that the array had errors (probably because it was missing a drive). so I plugged the other drive in but nothing happened. I scanned for hardware changes but nothing. i had to go out for a bit and when i got back i tried again to scan for hardware changes and then it appeared! slowly but it did. it had the nvidia ver10 drivers so i down graded them and rebooted. still would not boot! So I unplugged the second drive, booted and plugged the second drive back in immediately after I passed the raid bios detection screen and when win7 came up, there is was with the correct driver! yay!

But the nvidia storage control panel now shows one drive under the array and one free drive. There is no option to combine them, just create a new array with the one drive or delete the existing array. I then notice that under the custom option for creating an array you could fine tune some options, none of which help me but the last page says that “if no data is being preserved, i must partition and format the array” does that mean that if I AM preserving data, i don’t need to partition and format and my existing partitions will be detected? I assume I’d have to delete my original array, make a new one with both drives, don’t format or partition and just see what windows does with it?

I won’t try until I hear from you.

we are getting so close!




@ hoklerar:

It is a big progress, that you now got the NVIDIA nForce SATA and RAID drivers v9.99.09 correctly installed onto all related devices and that the Device Manager shows them all without any yellow mark.
Usually the RAID should now be detected by the OS while booting (unless the partition table of the RAID array cannot be found or read).
I am not 100% sure what happens, when you hit the "Finish" button of the MediaShield Control Center, but I suspect, that the utility will create a new RAID array and overwrite the old partition table. As a consequence you may get a proper created new RAID array, but without having access to the old data.
Maybe I am wrong, but in this situation I would try to reboot without hitting the "Finish" button of the MediaShield Control Center. While rebooting you should hit CTRL+S (or similar) to enter the RAID Utility and look, if the RAID array is shown as "healthy".

The last time i rebooted it still hung on detecting array with both drives plugged in. I have a feeling if I delete my array and make a new one with both disks, it will probably boot ok, but ya I am worried it will smoke my data. but there isn’t anything left i can do is there?

hopefully it will leave the partitioning and formatting up to me but I am fearful it will not.