Raid0 Hard Drives Clicking

Hello everyone.
I’m having a hard drive clicking noise problem with my Raid0 setup.

I recently flashed my MSI Z77a-G43 with a modded BIOS including Fernando’s recommended RAID option ROM for my system (version 13.1 with TRIM). I don’t remember correctly what was the original option ROM version, most likely 11.9. I used the latest UBU tool to mod the BIOS.
So right after flashing I wiped the Raid0 volume, created it again (128Kb stripes) and installed a clean Windows 10 Pro x64 (I previously had Windows 7 Ultimate x64).

After Windows installation finished, I quickly noticed a clicking noise coming from the hard drives (I’m not 100% sure if it’s just one of them or both). It repeats every few seconds, and then gets quiet for some minutes.
One of the first things I did was updating all the drivers to the latest or best version. I matched Intel RST driver version with the option ROM version. But the clicking noise is still there.

I should also mention I never had this problem with Windows 7 and the previous ROM, so most probably the disks are OK (I didn’t even touch them physically, all I did was copying 1.5TB of data to other disks).

Any advice?
I tried changing APM values but they can’t be changed, probably because the drives are in a Raid0 volume. I also tried booting a Live Ubuntu from a flash drive, and there was no clicking. Oh, and also flashed the option ROM to the same 13.1 version without TRIM support.


@ Neblinio:
Welcome at Win-RAID Forum!

We got already reports about a HDD clicking noise from other users (look >here< and >here<), but we do not yet know the exact source of the issue.

And has the clicking noise been away after having flashed the original ROM module?

Dieter (alias Fernando)

Thanks for replying!

Yes, one of the first things I tried was the original ROM, with the same result.
I also tried disabling Link Power Management in the Intel Rapid Storage Technology application, but it didn’t work.

More info: This clicking noise happens when the hard drive is idle or almost idle. My disks are 2x Samsung HD103SJ (at least one of the other users having this problem has Samsung drives).

Should I try other (newer) ROMs with Intel series 7 chipsets support? I’m really interested in finding what’s causing this clicking noise (it’s quite annoying, to be honest)

Question: Is Samsung’s Magician running in the background? If yes, disable or uninstall it.

You can try it, bout I doubt, that it is the Intel RAID ROM, which has caused the noise.
I suspect, that it is either the in-use Intel RAID driver (in combination with certain HDDs) or a monitoring software, which ir running in the background. My tip: Uninstall the Intel RST Software from within the Control Panel and look, what happens.

There’s no monitoring software running in the background. I did a clean Windows 10 install (UEFI boot, GPT partitioning), and the clicking noise was there even before installing any driver or software.
I installed Intel RST software hoping it would fix the noise, so I guess removing it won’t help.

I think I’m going to try the newest series 7 compatible driver, and if it doesn’t work, I’ll probably flash the newest compatible ROM.

Try it, but don’t forget to post your results into this thread.
Question: How many optical drives are attached to your system?
I ask this, because I have read about a severe Intel RST driver problem, if more than 1 optical drive has been connected to the Intel SATA ports.

Intel Rapid Storage Technology WHQL installed (software & driver). The problem persists.

I only have one SATA optical drive.

Should I try the newest compatible ROM? I’m starting to think Windows 10 has some kind of bug, or maybe there’s a problem with one of the drives (or both).

More information, in case it helps:
Both drives have been used for 5 years in RAID0 configuration, and until a few days ago, they always had 2 partitions (small one for Windows, big one for data). The big partition has been almost full for 5 years, and I almost never accessed or changed most of those files.
Some times, when the clicking takes place, my computer freezes for a quarter of a second or less.

I can also try to record the clicking noise if you think it can help.

I tried Ubuntu live (EFI mode), and at least while booting up, the clicking still happened.
I think I’m going to flash the option ROM to the newest compatible version. If the problem persists, I’ll flash the original BIOS offered by MSI, with option ROM 11.9 (don’t know if this downgrade could affect my existing RAID0 volume and its data)

This is really weird. After rebooting my computer to exit Ubuntu Live and go back to Windows 10, the clicking noise stops. It comes back when I shut down the computer an boot Windows 10 normally.

Oh, I also checked the latest original BIOS released by MSI, and I was wrong with its included OROM and SataDriver versions.
Intel RST(e) OROM and EFI SataDriver

OK, so I just flashed a new modded bios with latest compatible OROM and SataDriver versions: 13.5.
Problem persists.
It even clicks when I’m viewing BIOS setup!
The only “fix” I could find is booting a Live Ubuntu and then rebooting to enter Windows 10 normally. The clicking sound disappears until I turn off the PC. Really really weird, but it may give us some clues to find what’s causing this problem.

Thanks lemon.
As I found a weird -but 100% effective- Linux workaround, I needed to relax for some days and not think about this problem.

I haven’t finished reading yet, but the Intel Communities forum has plenty of information and some workarounds. I’ll also inform them about my own workaround.
They recommend reverting to 12.9 RST drivers, which don’t support APM. Or disabling APM with some third party tools. Not perfect fixes, but they seem to work. I’ll test them soon.

If I happen to find a better solution, I’ll post it here.

Thanks again lemon, and also Fernando. You were very helpful.