[Razer Blade Pro 17] Disable Intel Me possible?

Please help - I have a headache trying to work this out.

I followed this guide here and nothing seems different: [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

Full BIOS dump with FPT here: https://gofile.io/d/fbNuPF

If you want support for me_cleaner, visit the official github repo.



I want support for my BIOS dump I posted.

EDIT: I’m able to get in here and change these options to visible however, with “ME State: Disabled” my machine takes 30 seconds to boot and has no sound … tried reinstalled sound drivers etc …

Also, applying “Me FW Image Reflash” makes my machine reboot and unset the setting. O.o

Is this the type of machine that won’t allow ME to be off?

ME.PNG

ME2.PNG

Maybe this file will be of some use - I can dump the descriptor just not write back to it. I do have all options in BIOS unlocked however.

Flash Decriptor dump with FPT here: https://gofile.io/d/2OXByd
-------------------------------

I found this which I thought was strange, shouldn’t a variable have much more letters and numbers? It also seems to be sharing with another option … O.o



EDIT: With ME Fw Image Re-Flash: Enabled the ME disables itself and therefore the firmware update tool cannot find the ME deivce and throws an error …

Removed anything to do with me_cleaner from this post as it’s nothing to do with me_cleaner - maybe you can pull your head out of your arse and look at the bins I provided now? :slight_smile:

@a.mihail91 - If you want ME FW disabled it has nothing to do with BIOS settings.
You need to make a mod ME FW using the guide you linked above, but on final build out set HAP Bit (Reserved @ “ME Kernel” last option in that section) to “Yes” and then program that ME FW in with ME FW Update tool.

Disabled ME FW can often have many various bad side effects, such as things you’ve mentioned above, fans running at full speeds, various CPU functions messed up/missing, or CPU speeds not working properly, same for memory speed/timings etc.
So, it’s not ideal or user friendly in some/many cases.



Thanks for the reply bud!

I see - yes I’ve tried setting that bit “Reserved” to “Yes” and build the image - this works fine and flashes perfectly however on next reboot ME is still there and reports as running normally. :S I can only assume this is something to do with no Flash Descriptor write access?

I’ve tried setting the “ME Fw Image Re-Flash” option to Enabled and my machine won’t boot, it goes in a loop then resets the setting back to “Disabled” - I believe this has been programmed in on purpose. Is my only other option using a programmer?

EDIT: I also noticed building the image this way reports “no flash descriptor” in ifdtool O.o

@a.mihail91 - You’re welcome! Then you are not flashing the ME FW in properly, or you’re not building the image properly etc - it’s not possible for the ME FW be functioning once you disable it in this manner.
Flash descriptor settings do not matter if you are flashing in the mod ME FW using ME FW update tool. ME Fw Image Re-Flash is not used here, that is for use with FPT

Your last comment makes me think you are not doing something correctly, maybe multiple things, when doing the clean/transfer/update process.
Sorry, I don’t klnow what ifdtool is, but if FD is in the file you start with, it should be there at the end, something is not right in what you’re doing.
Please link me to your stock BIOS download page, I will make you a ME FW with disabled ME FW and show you how to properly flash it in.

@Lost_N_BIOS Unfortunately I’ve got myself in a predicament because I followed the ME cleaning guide up there and updated my ME FW beyond the version number my manufacturer supplies and now I can’t downgrade back again - so I made the image following this guide: [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization and flashed it successfully, however, setting the reserved bit in FIT isn’t sticking.

The original manufacturer BIOS is here: http://rzr.to/dYkdR - if you open the .exe with 7zip or similar you will see all the files you need in there. “Dana17_2_0104.bin” is the full BIOS image.

I think it’s worth saying they split the BIOS and ME update into 2 seperate processes, if that matters. The ME file they supply is here: http://drivers.razersupport.com//index.p…loaditemid=3273 - using the same method of opening the .exe with 7zip, you can see all the files you need in there, however, now that I’ve gone and updated to the latest firmware in that thread I can’t flash back down to the one the provide at that link due to “Lower ARB SVN” error.

@Lost_N_BIOS My mind is officially blown - today I flashed a unlocked/HAP bit set dump to directly to my BIOS chip with a CH341A programmer and ME is still showing enabled. O.o

EDIT: I’ve witnessed some strange behaviour after flashing a new image with the programmer … I get multiple boot loops when I power back on, almost as if the machine is writing the old files back to chips - I’ve confirmed this by writing with the programmer, verifying, booting up, reading the flash chip again and comparing the files - they are different. O.o

This strange behaviour also explains the fact the “Reserved” bit isn’t sticking when I follow thru that guide and remake the ME FW image. Have you ever seen anything like this before and is there a way around it?

EDIT2: I also noticed my chip “GD25B127D” didn’t show up on flashrom, I had to use another option to read it.

EDIT3: Just reiterating that setting “Me FW Image Re-Flash” to Enabled causes a boot loop which unsets the setting - it seems like this machine has some sort of hard lock to prevent what I’m trying to do here?

@a.mihail91 - Sorry, I lost your thread until just now!

If you need to downgrade ME FW, you will need to unlock FD via pinmod, or get a flash programmer (sounds like you have)
Once you write to chip and power on system, the BIOS will never be the same again after dumped, this is normal.
Reserved bit not sticking, this is due to something you are doing incorrectly. Please reflash in stock BIOS with stock method, then dump BIOS with programmer and send to me, tell me what ME FW you want in there and if you want HAP bit set to disable ME or not.
Also, if you have, send me any original BIOS dump you created BEFORE you started messing with ANY of this. This can be made with software, or programmer.

ME FW reflash should not be set, it’s a one reboot item, always resets after reboot, you need to CTRL-ALT-Delete after changing and boot directly to windows to use FPT right then, otherwise it’s reset

What you are trying to do here, is kind of unclear to me right now, but since you have a programmer, it can ALL be done right then and there, directly in a BIOS edit and then programmed back in