RE:[Solved] Intel Ironlake vBios update for Medion Akoya E7214 notebook

It would be fine, if you would post the procedure how you modified the BIOS. This may help other users with a similar system and problem.
In this case I would split this thread and create a new one with the title "[Solved] Intel Ironlake vBios update for Medion Akoya E7214 notebook".

hello i opened akoya e7214 bios with mmtool 4.5 then i searched intelvgadriver clicked replace openened ironlake vbios 2120 first is wrong id searched id 8086.46 then click replace and saved new bios then i flashed with afuwin all is function at boot new ironlake picture

Screenshot (4).png

@ reno12:
Thanks for the report.
So you have just chosen the simpliest possible method and were lucky, that everything worked as it should after having flashed the modded BIOS.

Enyoy it!

hello all is working fine you gave me tip with wrong rom id ichoosed id from vga driver thank you

You got lucky, most systems would be bricked after doing such a procedure without adjusting settings first with Intel BMP.

hello since i updated i have more grafics performance do i have newest ironlake vbios by way all okay

hello for all who want updated bios medion akoya e7214 here added bios zip updated with latest classical ahci raid rom with latest intel microcode (only overwritten) with latest ironlake vbios 2120 may be flashing with older afuwin shows no mistake with me but newer afuwin flash can show wrong id then i choosed dont proof id and flashed with me all functioned take it at own risk

bios akoya (1.2 MB)


I’ve observed strange behaviour of this laptop (Medion Akoya E7214, MD98410 variant) while experimenting with repairing of the Windows 10 on it e.g.:
- after applying some tools (e.g. from Hiren’s Boot CD kit) when they finished like crashed, i.e. system stopped responding to keyboard and was shut down not by software command (event not by CTRL-ALT-DEL reset) but by pressing the power button;
- after next reboot from the USB/DVD-ROM it was not reacting to the arrow buttons;
- but after pressing F12 during boot time to initiate Multi-boot Menu it was reacting to the arrow buttons, was able to enter to the BIOS, navigating, etc, restart, but still not reacting to the arrow buttons when booted again to the Hiren’s UI;
- only after attempting some “shamanic” actions (like trying to boot something from another USB or CD-ROM - not really clear which one will help!) system may resume reacting to the arrow buttons.

I blame this to the BIOS and would like to replace it by the newer/different version.

Manufacturer’s Web-site…ls.php?did=9717 lists only one version of available BIOS named Version 00B, Release date: 22.03.2011 (and actual BIOS reports Version 0.0B, VGA BIOS Version 1930).

According to the information provided by the AIDA64 Extreme Edition v1.85.1600 tool it seems that current BIOS is AMI EFI BIOS, Version 4.6.3, Date 02/18/2011, Video BIOS Date 01/13/10.

Thus, I’m trying to update BIOS on this laptop to the version which was posted in this thread by reno12. AFUWIN tool (Current Label: 8.00.15_AFUWIN_4.48, Release Date: 2011/Feb/24) reports “Error: BIOS is write-protected” (when used under miniWindows 7) - for anything - not even reads current BIOS.

Current BIOS itself has no option for updating from inside or removing any protection. Instructions on Medion Website for the given BIOS Version 00B just say

1. Unzip the downloaded file into a created folder on your harddisk.
2. Run the file M10H100B.exe from Windows™ surface.
3. If a “WFlash Warning” appears, press OK to execute the update.
4. The system will be rebooted automatically for the changes to become effective.

Thus, any ideas how to proceed with update? Thanks in advance.