RE:Unlock Request H12DST-B (Supermicro) BIOS?

Could you please help me to unlock hidden menus in H12DST-B (Supermicro) BIOS?
The BIOS file could be downloaded from here:…areItemID=10677

@PetrB - Do you have flash programmer, like CH341A? If not, problem will be flashing in mod BIOS since this is AMD system. You need CH341A + SOIC8 test clip w/ cable if BIOS is soldered to board, or U Type Flat IC Extractor if BIOS is in a socket on the board.
In general, yes, I can probably unlock this menu for you. I would need images of your BIOS, one of each section you can see (showing all settings, so I can see what you can already see). But you need flash programmer to program in mod BIOS.
Unless this method would work for your system, I’m not sure. See last spoiler for method, mainly this is >> flash stock BIOS with attached AFU in that thread and then without reboot flash mod BIOS…r-motherboards/

I do advise against use of VERY OLD AFUDOS /GAN method, it can brick the device, or leave it with issues flashing BIOS Later, so above method suggested only, or flash programmer

For test of above method, here is simple mod BIOS with a two updated microcodes, flash using the method outlined in last spoiler at linustechtips link above (and use the AFU attached in that thread tools package)
Before you use that method, make sure to make an AFU backup so if we need to restore any serials or MAC ID etc later you will have a copy of the original BIOS >> afuwinx64.exe BIOSBackup.rom /O…306298431590047

BUT, to be 100% sure any of that is needed, please test using the original flash method first (Flash.nsh + afuefi.smc) + Mod BIOS, and see if you get error or not.
I do expect you will, but it’s possible sometimes you don’t and it’s OK

I’ve flashed your file (…306298431590047 ) using standard SMC utility.
No errors occurred. I did not noticed any changes in BIOS. Should I?
Thank you.

@PetrB - Great to hear! No, unless you can see CPU microcode in BIOS, and you are using CPU with CPUID 800F11 or 800F12 then you wouldn’t see any changes. I updated those to latest version, the version of microcode in use can be seen in HWINFO64, if you want to check current vs previous
But, all I needed to hear was success of flashing mod BIOS, so we can flash mod BIOS here and now I will look at editing menus for you. Please give me images of ALL of your BIOS, every page, every submenu, every setting.
Put them in 7zip or zip with max compression. If you can, before you take the images, set camera to small image size, I only need to see 100-300KB small image at a glance for a second, do not need 3-6MB images for each image

What is SMC Utility?? Do you mean the thing I mentioned, flash.nsh and afuefi.smc (this is standard flash batch file and AFU program included with the BIOS download you linked)

Please find all BIOS screen-shoots (together in one file). All sub-menus. For your convenience, each big section (highlighted) - of the left, all sub-menus - on the right.
SMC utility - from the standard package, which comes with ROM image (flash.nsh + afuefi.smc)

BIOS screen-shots.rar (1.2 MB)

Nothing attached? I need to see every setting you can see, on all menus, submenus, etc (ALL Setting, everywhere) I can’t tell, but sounds like you meant all this in one image? If yes, this is not possible.

Please check if it is OK.

BIOS screen-shots.rar (4.93 MB)

No, interesting idea, but sorry that is a mess and unusable for how I need to see these. Please send all images in one zip, not in one image.
Batch resize them if you need, 800-1000px wide is all I need to see, 100KB or so is plenty per image.

Please find new images (many small ones).

BIOS Screen-shots.rar (4.79 MB)

Before I get into editing here, let me know if you sort out flashing mod BIOS with what I sent you in PM or not, if not I will wait until you have flash programmer that way you’re not talking yourself into risking bricking the system over a mod BIOS flash itch
What is your main goals here, what menus are you most interested in? And, if CBS, do you really need to see them, or are you just interested in modifying some settings (That can be done easily, without a menu mod)

I experienced problems with only that mod which I’ve tried to do by myself.
I’ve flashed your test mod (on Saturday) without any problems.
Here is the list of most wanted options (I have pointed the sections, where I saw those options. Not sure that my findings are correct):
1. "BMC Support: Enabled/Disabled" option is inside ServerMgmtSetup section (1B08A1DB-F91A-4FA1-A911-255C417F1CF7).
2. "Relaxed EDC throttling" option is inside CbsSetupDxeZP section (A5E369C8-ABF9-4B43-B212-FF1BFD35666D)
3. "Custom Pstate" options are inside CbsSetupDxeZP section (A5E369C8-ABF9-4B43-B212-FF1BFD35666D)
4. "EDC Limit" option is inside CbsSetupDxeSSP section (8E38A88A-C267-4131-A8CD-C0BC80A24CB5)
5. "FCLK Frequency" option is inside CbsSetupDxeSSP section (8E38A88A-C267-4131-A8CD-C0BC80A24CB5)

Thank you.

Thanks for the list. CBS setup may be an issue to make visible, sometimes I can, sometimes I cannot, depends on BIOS and how they’ve done things internally
But, I can ALWAYS change any default value for any setting, hidden or not, to whatever you want. SO if it turns out I can’t make visible for you, at least we can still change them to what you want instead as last resort

Once again, to make everything clear if I have “flashing trouble” or not.

YOUR mod (with new micro codes) flashed with NO PROBLEMS.
Only my mods do not want to flash.
I can’t tell you very exactly, what changes I’ve tried to do myself (as I am at home now, without access to the system.
But, as I remember:
1. I’ve tried to modify the rom menu using AMIBCP 5.02.0023. It was hard, as I was need to change all “04 39 00 00 00 39” sequences by ”00 39 00 00 00 39” sequences before AMIBCP utility could read the rom file. But after I’ve changed that sequences, I was able to open rom in AMIBCM. I wondered that the menu that I’ve saw in AMIBCM utility looked completely different from the real menu that I’ve so in BIOS. I’ve decided not to care about this, and I’ve changed all “default” by “user”. After that I WAS ABLE to flash this mod rom. Unfortunately, this changes did not result in ANY changes in real BIOS menu.
2. Then I’ve started from the beginning. I’ve found 5.02.0031 AMIBCP utility. I’ve tried to modify the rom menu again, using this newer version of AMIBCP. This time I was able to open rom file without any problems (without changing of “04 39 00 00 00 39” sequences. I’ve changed some “default” by “user”. After that I‘ve tried to flash this mod. This time I was UNABLE to do it because of “18” error.
3. Then I’ve started from the beginning. I’ve changed “46 02” to “47 02” in the beginning of setup section (ref: Chipset). It was the only one change. I am not sure that I’ve used same version of Efitool as before. I’ve tried to flash the results - but received “18” error.
It was my very last attempt. I believe I am doing some mistakes.

Let’s do like that:
Please enable any option from the list which I gave you.
I will try to flash this new mod.
Then we will know if I need to get a programmer or not (I believe that it is not ease to get such a programmer from stock in Russia).

If you get problems with CBS menus, then please at least:
- make BMC enable/disable option visible (it’s IMPI, not CBS), as I need to try the system without BMC;
- make “relaxed EDC throttling” - enable by default (it’s CBS);
- make “EDC limit” and “TDC limit” double of its current values;

Best regards,

Thanks. For CBS Menu items, I may not be able to make visible to you in BIOS, we shall try though. BUT, no matter what I can change them to whatever you want (ie enable or disable, change default value to whatever you want etc).
So yes, I can set the ones you mentioned what you wanted them set to, but you need to tell me current value (ie I can’t “Double” what I can’t see current value of, unless that is already visible value you see in AMIBCP or Setup)
BMC is no problem to make visible, since you can already se BMC menu. I will use your images and make all hidden settings visible, in all the menus you can already see

Good news!

1. I was able to flash your 2nd mod BIOS. “Chipset” - not shows, and shouldn’t. Please see #4 for my explanation.

2. I was able to make the mod BIOS myself and succesfully flashed it (same changes as you did, “46 02” -> “47 02” in “Setup” section). “Chipset” - not shows, and should’t. Please see #4 for my explanation.
The “keys” for succesfull flashing are:
- AMIBCP 5.02.0031 should NOT be used.
- AMIBCP 5.02.0023 could be used if needed (with “04 39 00 00 00 39” sequences replacements by “00 39 00 00 00 39” sequences) in order to open the file in AMIBCP.
- UEFITool 0.21.5 should be used.

3. I was able to make the another mod BIOS myself and successfully flashed it (I’ve tried to make visible “BMC support” option in IPMI by editing “Server Mgmt Setup” section).
The flashing was successful. Unfortunately, “BMC support” option is still invisible. Please see #4 for my explanation.

4. I’ve made ROM backup (using “/O” key with auefix64.efi command). I’ve attached the file in this thread. I was surprised, it was only 16MB, not 32MB as original BIOS file from SMC.
I’ve opened it with AMIBCP 5.02.0031 to see what’s inside. I’ve found that it looks completely different from 32MB version (here I’m talking only about AMIBCP 5.02.0031 “views”).
Then I’ve opened it with UEFITool 0.25. I’ve found, that there are much less sections then in original one (32MB)!

After more close look I’ve found that most sections of 32MB BIOS version are present 2 times (with same names, but with different GUID).
So, the possible reason why my efforts had no effect is because of that (may be I was editing the wrong sections).

5. I’ve tried to flash backup ROM image (16MB). No success:(

6. I believe that we need to use backup ROM image (16MB) only in order to find, which sections are useful, and which sections were omitted during flashing.
So, I believe that we should modify original 32MB image, but we should change only that sections, which are present in both versions (32MB and 16MB).

7. I will try to edit different sections right now, but I am very awaiting for your changes too.
Please do something ASAP, I want to make sure that our efforts could have at least some effect.
(Based on my own experience I am afraid that any efforts are useless. I want to make sure that I’m wrong).

H12DSTB0.110.rar (4.64 MB)

@PetrB - Replied to above in PM

Here, please test and let me know, chipset visible yet or not (maybe not, but this test need done before further edit in regards to chipset is done) Additionally, this will have the changes you mentioned at #13
Wait, first please test these two BIOS, let me know which, if either, shows chipset - then I do rest and further chipset test if needed
All edits here done ONLY with Hex editor, and UEFITool v25 (FYI) -…265029319265257
If chipset is visible, grab me images of all contents when you have time, that way in a later edit I can add anything still missing

* Edit - @PetrB - OK, here is next round, please test in order as follows, once chipset appears stop, no further test needed (if it appears)
If it does not appear, another round of three similar to this will follow
1. Default
2. User
3. Super

Also, on one of these tests, please rename the BIOS file, not extension, so we can see if other than default name is OK
It makes life easier on everyone if BIOS can be named other than default during testing like this.
I usually use names to let me know which edit is what vs using folders, it’s much easier that way.…255813219058000

* Edit 2 next round -

I’ve noticed something strange with all archives received from you.
The total size of the archive equals to single file compressed size.
(Total archive size is 8 877 585 bytes - just 235 bytes greater then single file compressed size).
The size is shown only for the 1st file, the other 2 files have “???” size.
But no decompression problem occurs.
Please take a look to the attached picture.


All normal when looking at 7zip file in winrar, explained in PM, nothing to worry about

Please find the dump of last mod.

Chip4UAMIT1.rar (4.64 MB)

I’ve tried to go deep into “18 - error”. I’ve made some findings. I am not sure that they are useful (may be findings are wrong, may be everybody knows about it, but no solution possible).

Anyway, I want to share those findings with you:
- I was using UEFITool v0.25 to replace “Setup” (899407D7-99FE-43D8-9A21-79EC328CAC21) section (“47 02” -> “46 02” changes only), (the 2nd one in SMC BIOS)
- after replacement and saving (rebuilding), the “Setup” section (899407D7-99FE-43D8-9A21-79EC328CAC21) looks same as before (same size, etc),
- also, the parent section (8C8CE578-8A3D-4F1C-9935-896185C32DD3) have same size as before,
- but “grand-parent” section (EE4E5898-3914-4259-9D6E-DC7BD79403CF) looks different!!! It’s size have changed by 30KB!!!
- also, the “pad-file” sections (not-empty in the beginning) are changed too.
I think, that all “18 - error” troubles are happening because of the way how UEFITool rebuilds the volumes after any changes.
The “grand-parent” section (EE4E5898-3914-4259-9D6E-DC7BD79403CF) is compressed. So, when we update any sections inside, UEFITool updates the compressed “grand-parent” section.
I do believe that there is some difference in compression methods (between UEFITool and AMI or SMC compressors) as we are getting 30KB difference even in case if we changed only singe byte (“46 02” -> “47 02”).
Also, it looks like the previose volume size (or some other values connected to volume size) are stored somewhere (may be in “pad-files”) and any differencee between old and new value - leads to “18-error problem”.

Is there any way to keep the all volume sizes unchanged after rebuilding? May be different tool? Or some manually added “zeros”?
If such solutions are possible, then we will overcome “18 - error” (not only in my platform - but in other platforms too).

I’ve attached a picture where size differences are shown in thread.
(black lines for same sizes, red lines for changed sizes).

Section Sizes.png