Recommended AHCI/RAID and NVMe Drivers

I integrate cab files as Updates, not as Drivers:
NTLite: Integrate->Updates->Add->Package files, then select cab files from (KB2990941, b3087873)

WIN10 Device Manager:
Storage controllers:
Intel Chipset SATA RAID Controller → Hardware Ids:
Microsoft Storage Spaces Controller → Hardware Ids:


  1. Is the NVMe SSD connected to the mainboard while running Win10/11?
  2. Off which disk are you currently booting and onto which disk do you want to get Win7 installed?
  3. Have you already tried to disable the “RAID” mode within the BIOS before starting the Win7 installation?
  1. Yes disk now install, with OS WIN10
  2. Now booting from this disk with WIN10
  3. I have not this option in BIOS

I was able to install WIN7 on this drive. If I change the WIN7 installer to WIN10 (I used boot.wim from WIN10 and from WIN7) it works, the installer from WIN10 can detect that NVME disk, but after installation when WIN7 tries to load disk.sys it reboots computer. As far as I understand, need correct NVME driver for WIN7, and HotFix from MS does not help.

You can only boot in UEFI mode off an NVMe SSD and the NVMe SSD has to use the GUIMode Partition Table (GPT). This is valid for all Windows Operating Systems.

This means, that no NVMe Controller is in-use by the OS. I wonder how you are able to boot off the NVMe SSD while running Win10.
Please check the driver version, which the listed “Intel Chipset SATA RAID Controller” is using.

Which Options do you see within the “Advanced” BIOS options regarding the on-board Intel SATA Controller(s)?

It worked for all other Win7 users, who tried to get Win7 installed onto an NVMe SSD.
Use the Win7 ISO file, where you had integrated the MS Hotfixes into both WIM files, but follow my advices given within the chapter “B. Best/safest procedure to get Win10/11 properly installed onto an NVMe SSD”, which you can find within the start post of >this< thread. The method should work with Win7 as well.
By the way - besides the MS NVMe Hotfixes only the generic Phison NVMe driver v1.5.0.0 supports Win7 from scratch.

Yes, I boot in UEFI mode, with GPT, becouse if I set Legacy mode, then NVMe does’not work even in WIN10.

“iaStorAVC.sys” File version: Provider: Intel Corporation

In the “Advanced” BIOS parameters, there is not a word about Intel SATA controllers, only a checkbox to enable or disable M.2 SSD
2.89 MB

HP ProDesk 400 35W G4 Desktop Mini PC - BIOS Simulator

Thank you for this tips, I all do the same way, but as I say before this NVme Disk not work.

Thanks for your quick and clear reply.

Before I will try to help you to get Win7 x64 installed onto the NVMe SSD, you should update your current Win10 x64 configuration:

a) If not already done, I recommend to download and flash the latest BIOS, which is offered by HP for your specific device. Maybe this will already solve some problems.

b) The NVMe Controller of your NVMe SSD uses currently a very old Intel RST SATA RAID driver dated 02/08/2018, which is in-the-box of all modern Windows Operating Systems.
HP recommends for your system the much newer (and fully NVMe supporting) Intel RST driver v17.3.11.1010 WHQL dated 11/25/2022 and I agree with HP in this case.
For Win10/11 x64 I recommend to download the “pure” 64bit Intel RST driver v17.3.11.1010 from >here< and to replace the currently in-use Intel RST driver by the much newer and probably much better driver.

  1. Run the Device Manager and expand the section “Storage Controllers”.
  2. Right-click onto the listed “Intel Chipset SATA RAID Controller”
  3. Choose the options “Update Driver” > Browse my Computer" > “Search”
  4. Navigate to the folder, where the unzipped Intel RST driver files are stored…Let me pick…"
  5. Press the “OK” button

The correct and 100% matching driver will be installed automaticly.
After having rebooted don’t forget to run the Device Manager again, to expand the “Storage Controllers” section and to look for the updated name of the NVMe Controller. It should now be “Intel(R) NVMe Controller”.

Don’t you see a BIOS entry named “Intel(R) Rapid Storage Technology”? If yes, which options does it show?

a) Yes, BIOS is the latest version. The first thing I did was update the BIOS, but it didn’t help.
b) Thanks for information, I will definitely do this if I fail to install WIN7 and have to stay on win10.

No, these parameters are not in the BIOS, earlier in the post I attached a link to a PDF file simulating my BIOS from the HP website, you can see the full contents of my BIOS, there are no such settings there.

Thanks for the hint to the “Interactive BIOS Simulator” PDF file about your mainboard BIOS.
According to your previous posts I assume, that
a) the in-use NVMe SSD is your system drive and connected to the on-board M.2 port and
b) no SATA drives are connected to the mainboarrd.

As far as I understood the listed details, you should enter the BIOS, load the default settings and then check and customize (if useful) the following settings:

  1. “Main” section:
    The current date and time should be up-to-date.
  2. “Advanced” section:
    a) “System Options”: Check all settings! The M.2 connected drive has to be visible for the OS.
    b) “Port Options”: Check the SATA0 settings!
    c) “Power Management Options”: Check the PCI Express Power Management setting.
    d) “Option ROM Launch Policy”: Check the setting. The UEFI “Driver” should be loaded.

a) yes
b) yes
Thanks, I’ll try to follow your advice.

Does anyone have Intel drivers for the B360 chipset under Windows 7, (possibly modified drivers if there are no original ones.)?

What type of Intel drivers (AHCI/RAID/NVMe) are you looking for?

mostly NVMe Intel drivers for the B360 chipset

Which NVMe SSD are you using? I need the model, the name of the manufacturer and - if possible - the HardwareIDs of the NVMe Controller.

Disk: Western Digital “WDC PC SN520” NVMe M.2 SDAPNUW-128G-1006
On board NVMe controller: SanDisk 20-82-00703-A1
NVMe Chip Memory: SanDisk 05561 128G
property “Hardware Ids” under win10 show: SCSI\DISKNVMe___WDC_PC_SN520-SDA0006

The safest way to get Win7 installed onto your WD NVMe SSD is to integrate Microsoft’s NVMe Hotfixes for Win7/W2k8 R2 into the boot.wim and install.wim of the Win7 ISO file. For details please read the related section of this thread’s first post.
Once the OS is installed and running, you can try to replace the generic MS NVMe driver by another one (e.g by the Phison NVMe driver v1.5.0.0 WHQL for Win7 x86/x64). It has to be done from within the “Storage Controllers” section of the Device Manager.

@Fernando definitely love what you do here at this forum was wondering if you could help out.

I have an Asus UX8402VV somewhat recently purchased and I opted to turn off my VMD on UEFI which resulted in unnecessarily high DPCs from storport / afd / stornvme and other various drivers related to m.2

I was wondering if you have any custom Standard NVM Express Controller drivers for VEN_8086&DEV_A77F that can take care of this dumb issue I’m having or if you suggest going back to RST and setting my VMD back on I can do that as well with custom drivers you might have as well.

I read somewhere on the interwebs that using AHCI instead of RST would resolve this problem in my case but I do not see anyway this model machine can use AHCI properly when attempting to get that working.

So if possible VEN_8086&DEV_A77F custom RST or Standard NVM Express Controller
drivers would be greatly appreciated!


Welcome to th Win-Raid Forum!
You forgot to mention the OS you are running, but I suspect, that it is Win10 or Win11 x64.

These are the HardwareIDs of an Intel VMD Controller and I don’t know whether it can simply replaced by any NVMe Controller.
You can find it out yourself by doing the following (Tip: Set a “Restore Point” just in case of a not bootable system thereafter):

  1. Run the Device Manage and expand the “Storage Controllers” section.
  2. Right-click onto the listed “Intel RST VMD Controller A77F” and choose “Update driver”.
  3. Choose the options “Browse my Computer…” and then “Let me pick…”.
  4. Check whether the device named “Standard NVM Express Controller” is shown as being compatible.
  5. Choose the offered option (if available)
  6. Reboot and look for the in-use “Storage Controllers”.

Good luck!

1 Like

Thank you very much Fernando, I was wondering if you have anything custom for that VMD Intel RST Controller with that VEN & DEV I scoured throughout the forums but no dice.

And my mistake on the HWID earlier this is the correct one -
VEN_144D&DEV_A80A if you have custom drivers for that one I’d really appreciate it!

Thank you very much for any help!

Which was the result of your test? (see my previous post)?
If you were able to get the generic MS in-box NVMe driver installed instead of Intel’s NVMe driver, you can replace it by any other compatible NVMe driver.

1 Like

I think I got it! I grabbed your custom controller driver right off this file - Mod+signed Samsung NVMe drivers for HP+Dell systems - #37 by Fernando

My NVME is Samsung so it was perfect.

Thank you so much for your quick reply!