Recommended AHCI/RAID and NVMe Drivers

hello. pls help me… for 3 day i`m tryng to install windows 8.1 with raid 0 on my 990fxa gd80…

what driver do u recomand?

i try diferent drivers, i put them on the stick, brows for them, AMD AHCI COMPATIBLE RAID CONTROLER and … no new devices drivers were found…

excuse my bad english, pls assist me :frowning:

@ gopo2004:
Welcome at Win-RAID Forum!

I recommend to take the newest 32/64bit AMD RAID driver v3.8.1540.11 WHQL. You will find them within the start post of this thread.

Good luck!

tried allredey… put the on the stick, brows from the instalation … and then… no new devices drivers were found… :frowning:

This message indicates, that you tried to update an already in-use driver. I thought, that want to install Windows XP onto an already existing AMD RAID system.
Please give me exact informations, what you have done and what you want to do.
Another question: Do you have access to another Operating System, which is installed onto the same RAID0 array?
If yes, please open the "Storage Controllers" section of the Device Manager, do a right click onto the AMD RAID Controller and choose the following options: "Properties" > "Details" > "Property" > "HardwareIDs". Which DeviceID do you see (looks like DEV_XXXX)?

Great forum Fernando! :slight_smile:

In first post those links and their mirrors are not working:

But links (I assume for exactly the same drivers) from post Modded Intel AHCI and RAID Drivers are OK.

@ triodak:

Welcome at Win-RAID Forum and thanks for the info regarding the broken download links within the start post of this thread!
All broken links have been repaired and are working now (just tested).

Enjoy the Forum!

Hi Fernando. First, big thanks to you for sharing your knowledge. I think this is very valuable.

I’m in the process of installing Windows 8.1 Pro x64 and tried the latest AMD AHCI posted in this thread. The driver is not accepted during setup. When I load the driver the hard drive is removed from the list of possible install locations and setup reports the following error code: 0x80300001. My motherboard is Gigabyte GA-MA78GM-S2H v1.1, which includes the AMD 780G chipset. This is my second attempt to use this driver. Previously, I already had Windows 8.1 installed and decided to update the SATA driver, because I was occasionally seeing the blue screen error INTERNAL_POWER_ERROR. At that time, Windows would not boot after installing the driver.

When I learn more, I’ll post here. I realize this post is not helpful without a resolution to the problem. Meanwhile I’m hoping someone may have some suggestions.


UPDATE: FWIW, I just tried the ACHI driver that’s available on AMD’s website without success.

@ TotallyHosed:
Welcome at Win-RAID Forum!

Since I doubt, that AMD is already offering AHCI drivers, which have been optimized for being used with Windows 8.1, I generally recommend to avoid the installation of an AMD AHCI driver with this actual OS. The use of the generic Win8.1 own MS AHCI driver will be the best option.

I doubt, that the BSOD has been caused by the generic MS AHCI driver.


Since I doubt, that AMD is already offering AHCI drivers, which have been optimized for being used with Windows 8.1, I generally recommend to avoid the installation of an AMD AHCI driver with this actual OS. The use of the generic Win8.1 own MS AHCI driver will be the best option.

I agree.

I doubt, that the BSOD has been caused by the generic MS AHCI driver.

I’m starting to agree with you here. Thanks for your insight.


Update of the start post


  • new: 32/64bit ASMedia 106x SATA3 AHCI drivers v2.0.3.1 WHQL dated 11/19/2013 for Win8/8.1, Win7, Vista and XP (32/64bit) with customized 32/64bit TXTSETUP.OEM files

Note: The 64bit ASMedia AHCI driver v2.0.3.1 has been successfully installed onto my Z77 chipset system running Win 8.1 x64. Nevertheless I am not sure, if it work with other systems as well.

I’m experiencing massive performance leaks of using AMD RAID 3.3.1540.40 driver. Strange, I used the 3.3 driver version on XP 32bit and it worked fine for me. One day things changed and the performance leaks started. So I was forced to change back to 3.1 driver…without S.M.A.R.T. monitoring :frowning: I don’t know what happened. One thing I did was opening my pc case to reset the CMOS through jumper switching.
Now I’m using Windows 7 64bit but the problem is still existing with 3.3.1540.40 driver version.
Is there any other solution to get S.M.A.R.T. monitoring activating ?

P.S.: the performance leaks are shown in a disk reading “bit by bit”. All applications (especially games) needed so much more time to load associating with game freezes for seconds. It seems the disk stops responding and continue reading after a while.

EDIT: I forgot…I’m using RAID0 :slight_smile: already with an updated RAID ROM Module :slight_smile:

@ Bugger Vance:
Thanks for your interesting report.

Maybe the installation of the 64bit Win7Vista AMD RAID driver v3.3.1540.29 WHQL or v3.3.1540.35 will solve your problem.
Here are the links:

64bit Win7Vista AMD SB7xx & SB8xx RAID driver v3.3.1540.29 WHQL.rar (157 KB)

64bit Win7Vista AMD SB7xx & SB8xx RAID driver v3.3.1540.35.rar (158 KB)

I tried both drivers, but the problem still exist.
I checked the Event Monitor of Windows 7 and found some interesting. Maybe we could find a solution :slight_smile:
There is a warning of AMD RAID API, if I’m using v3.3 drivers. No warnings, if I’m using v3.1.

@ Bugger Vance:

Advice: If you don’t get S.M.A.R.T. reports by using the AMD RAID driver, you may get them by running the CrystalDiskInfo tool.
1. Which AMD RAID ROM and MISC.BIN version is within your BIOS?
2. The Event Monitor message “Task 20 timeout on port 1 target 1 at LBA 0x0b9c537 (Length 0x10)” indicates a problem with the HDD, which is connected with your SATA port 1. Have you already checked the drive and the port?

thanks for your reply fernando :slight_smile:
to change the SATA port worked ! Didn’t expect that, because I had no event warnings by using driver version 3.1
I have connected 3 SATA devices to the mainboard. I switched the BD-ROM to Port 1 and one of the RAID-HDD on Port 1 to Port 3. I’m anxious how the BD-ROM will react to this :smiley: but that’ll another (secondary) story :smiley:

thanks a lot :slight_smile:

P.S.: I’m using RAID ROM 3.2.1540.15. I don’t know which MISC.BIN I used a year ago for updating. btw: the described performance leaks are gone now :slight_smile:

It is fine, that you solved the problem. Thanks for your feedback!

If the OS should have mixed the drive letters, you can easily correct it from within the Disk Management.

It would be a good idea to update the AMD RAID ROM and the related MISC.BIN to v3.3.

I remembering there was a problem to update to 3.3, because the vendor ID of my module is shown different of that what it really is. The vendor ID shown is “4393” and for real it is “4392” and as far as i know there is only v3.2 available for vendor ID “4392”. Here is the thread of the past :wink:

error to load misc bin file [solved]

Hi Fernando,

in the latest AMD Driver-Pack (13.351.1001) is a new AHCI-Driver (Win 8) included:

There seems to be also a new Driver for Win 7:

I can send you the files per mail, if you wish.


Hello huelfi,

welcome at Win-RAID Forum!
As far as I remember I have already seen you at nForcersHQ Forum.

Thanks for the info about the new AMD AHCI drivers. I will get them very soon and update the start post of this thread.


Hi Fernando,

yes, that’s me. Good memory, it’s been a long time.