Reinstalling windows on Lenovo ideapad 710s is not possibile (ssd not recognized)

Hello everybody,

I’ve just bought from the Lenovo store the ideapad 710s (i5-6200U version). After realizing the Ubuntu cannot be installed because the BIOS do not allow to switch the SATA/drive mode from RAID to AHCI, I’ve decided to reinstall Windows 10 from scratches. The problem is that during the installation Windows 10 does not recognize the hard-drive ( a NVMe SAmsung MZVLV256). I thought that it was because the Intel SATA drive was missing but it is not. I’ve tried almost every driver present in this forum and most of the intel drivers are not recognized during the installation process ( win says the they are not compatible with the hardware). The only driver that the windows 10 installation seems to like is the Intel RSTe AHCI & RAID drivers v14.8.10.1055 but the hard drive is not recognized even with this driver. I’ve already contacted the support but they were not able to do anything.
Do you have any suggestions? Many thanks

here is a full test of your pc…167294.0.html#

it has a lot of infos

this page has a link to an asus pc having same chipset :…e-platform.html…pDesk_Download/
that has a lot of sata drivers

@faksimile :
Welcome at Win-RAID Forum!

Win10 should detect your NVMe SSD without the need to load a special driver, because it has an in-box NVMe driver. But the question is, whether the BIOS of your Lenovo Ideapad is able to detect the NVMe drive. To be able to boot off the NVMe SSD, the BIOS needs a special NVMe module. Furthermore you have to install the OS in UEFI mode. You should ask the Lenovo Support for a BIOS with NVMe support.

Good luck!
Dieter (alias Fernando)

A SATA driver doesn’t help, when the SSD runs in NVMe mode.

Thanks for your help. I’ve tried to reinstall windows with UEFI and it worked. By the way, during the installation process, the ssd was not recognized so I had to load the RTS Intel drivers v14.8.10.1055. I’ve deleted all the UEFI related partition to prevent any future problems with UEFI/Legacy boot.
I’ve not yet tried to install Ubuntu with UEFI mode enabled but I think that ubuntu is not able to recognize the ssd.
I’ll keep you updated

UPDATE: Ubuntu doesn’t recognize the ssd nor in legacy nor in UEFI mode. Any help would be appreciated

Thanks for your feedback. It is fine, that you succeeded the way I recommended to do it.

I am sorry, but I cannot help you regarding Ubuntu (by the way: This is a Windows Forum).