[Release] Resizable BAR BIOS EFI Module

it does have, check it on coffeetime

1 Like

I’m trying to keep up, but I don’t understand how to run this step

Could you help me a little? Should I execute this for CMD?

I got the bar working on old dell 7810

16gb bar was really easy to do tried to turn csm off but system won’t boot after that but rebar works like a charm

Save the raw section body to DSDT.aml using UEFITool and run that command in cmd yes


I managed to use the shared bios. It wasn’t a microcode problem.
The problem was the ME version
The modified bios with only that detail is the following.

Then do what is indicated, use the grub method, but nothing worked.
“setup_var 0x3 0x1” = no change, 4g decode off
“setup_var 0x387 0x1” = does not start windows
“setup_var_cv pci_common 0x3 0x1 0x1” = no change, 4g decode off
Z17MOCF7.60MOD2.zip (8.0 MB)

Just one detail, without applying any of this, I can activate the resizable bar at 1gb (with the bios shared by you). Likewise, when I try to go up to any higher value, it doesn’t start the pc. :confused:

which ME ver should i use? i tought based on this any me below 11.7 should be fine? (it seems you use my modded bios but replaced the ME ver on your own, so it worked?)

I wonder, if, it’s something to do with the bios since the above 4g decode wont made it past boot… or maybe, just maybe, try to disconnect from internet, completely uninstall the driver with ddu (clean and do not restart) and all nvidia options ticked, set rebarstate to 0, then reboot to bios, and try to enable above 4g using the grub method (0x0, reboot, then 0x1, and reboot), see if it booted right up to windows…

1 Like

@kingdzv Did you try the DSDT edit ? It’s almost certainly the cause of no Windows boot or Device Manager showing error on device because that’s what others report with DSDT issue too.


hi all im trying to make a dell poweredge r730 to enable rebar support, but im not getting it to work and cant understand if it’s a 64bit problem or just something else.

ive attached some picture.

without the mmio lower m,emory in bios pc was crashing when i was installing drivers.

i post also large memory screenshot “grande quantità di memoria” difference with mmio enabled and disabled.

i cant find the dsdt extraction as my pc is not with amibios , but it’s a dell server rack.
hope to get it working. if i need to try other things let me know.

did you insert the dxe after 7F7292E8-B594-45FA-92CD-78534D8B7EEC guid?

i inserted it at the end of volume like shown in the wiki.

it should be inserted to the bottom most dxe driver. it is shown here

Also you could enable above 4g right?

yes 4g was enabled but rebar was always off in gpu-z. if i use till 512mb pc will boot. over 512mb pc will freeze at startup and need to reset bios.
liker in the picture both large memory have 2 different address if mmio enabled or disabled, but that range looks like it’s ok even with mmio disabled.
mmio say it can be enabled to lower memory support to 512gb.

edit: i flashed stock bios back and load -nc rebarstate.efi give me the same output even with no rebardxe loaded in bios.

so, you did insert the rebar dxe after 7F7292E8-B594-45FA-92CD-78534D8B7EEC or you didnt? since there is 3 DXE parts, the buttom most (with only 2 DXE, which should be inserted after 7F7292E8-B594-45FA-92CD-78534D8B7EEC guid) is the one should be entered, might work or might not work tho.

this is the same case on amd am4 uefi bios, it is being split onto 2-3 parts, so i find the buttom most DXE driver, and verify the volume after it is PEI, not DXE, then it would be the bottom most DXE driver.

this is the bios i extract for your board (added rebardxe on the bottom most dxe driver):
R730-021600C.rar (5.3 MB)

i inserted it here.

orioginal bios
can u add that rebar to my original dumped bios ? it’s original.bin inside rar :slight_smile:

edit: i see u insert dxe in toital different area, but on tutorial they show to search for pcibus and insert at the bottom.

try put it on the buttom most dxe. compare the sent bios and your original bios, i get those from dell own web.

@Scruffy Why are you using ReBarTest ? It’s something that was used during early development/testing and does nothing but print the supported BAR sizes by GPU.

You’re supposed to enable Resizable BAR using ReBarState

If you’re unable to POST then the issue doesn’t relate to DSDT. It’s probably related to 4G decode being off or CSM being on. It could also be that the Dell BIOS is allocating GPUs in 32-bit region (often done for CSM with work with 4G decoding) and needs to be patched.

You can check in Device Manager if your GPU is allocated at a 64-bit address or not (longer than 8 characters)

1 Like

Yes, use your bios and replace the ME with version 11.7

I will try the alternative that you indicate and I will let you know. Thank you very much for all the help given

Yes, now I will try and I will be notifying news by this means. Thank you very much for the help


I made progress a bit, but got stuck again :frowning:
I can’t find “M1LEN” in DSDTMod.dsl

DSDTMod.zip (73.8 KB)

Hello @Kuri0

@Orion still has a problem with setting a bar larger than 1GB

Large Memory seems to be a thing, so Above 4g decode is ok?

If a value above 1GB is set, then the board fails to POST.

Here are some screen grabs of Device Manager.


Your thoughts?

Best regards,


flashed bios by desoldering and flashed with external programmer and did put dxe after your guid, but gpu-z show always disabled in bios.