[Release] Resizable BAR BIOS EFI Module

Also check Chipset, System Agent (SA) Configuration:


I have a PC with Asus z97-ws paired with a 4790k and 16GB of DDR3 ram.
for GPU i’m using Intel Arc 770 and would really like to enable Resizable bar for that extra performance.

I have tried to follow the guides here and on github to modidy the bios file myself but without success… i tried alot of different ways but i just can’t get it to work.
Now after downloading half of Github and 20 reboots later i give up doing it myself…

Would very much appreciate help from someone with knowledge about this!!

Hello @JonatanC,

What part of the process isn’t working for you?

Things of note with this system:-

  1. The latest BIOS file seems to have Above 4G decode, which is great.

  2. Doing the rebar mod should be straight forward.

  3. The flashing might require some force, because the utilities will complain about the modified file.

I can help via PM if you would like. A long series of support messages here might not be helpful for everyone. Maybe a follow up post with a report will be best.

Best regards


1 Like

Hi please help me out from PM. The bios i managed to flash with USB Bios flashback, the option with Ezflash is not working for me. This gives “Selected file is not proper BIOS”.

I think i’m doing the rebar mod wrong, when flashing with my modded bios PC will not boot. Q-code of mobo reads 00D7 - No Console Input Devices are found
and 0098 - Console input devices connect.

thanks alot for your time :slightly_smiling_face:

Mod files should be only be flashed with Asus USB BFB feature when the model has it. The same applies now for recovery of your system bios.
Never EZ Flash due to security issues blocked by AMI/Asus on modern Aptio V Core bios and most of Aptio IV, because a mod bios is a tampered file.

Please help me modify my bios i cant do it in my lenovo ideapad gaming 3 with gtx 1650

Hello! i have tried to apply the ReBar UEFI method by xCuri0 on a I7 3770 Ivy Bridge with the ASUS H61M-K motherboard and RX 480 Sapphire NITRO+
i followed all the steps but when trying to flash bios i get the error “Selected BIOS is not UEFI BIOS”
ive tried formatting the Flash to FAT32, tried renaming the file, tried Disabling Secure boot, but it wont work.
any solution to this???

Hello @nkzbda ,

What method are you using to flash the file to the board?

Sounds like an EZ Flash error

Look at the ASUS section at the top of this page [Guide] How to flash a modded AMI UEFI BIOS

Best regards,


1 Like

yeah it was EZ Flash, but now i will try these methods and get back to you as soon as i get a result! thank you for the response.

Hi @nkzbda,

Make a save of the chip first before force flashing it. Asus boards tend to have Serial Numbers, MAC addresses and UUID stored in the flash chip.

Using AFUWINx64.exe with the /GAN switch should work for your board.

If you need help, please PM and I’ll see what I can do.

Good luck,


1 Like

please help me still my rebar is disable

what mobo?

hey man, replying back to you after i tried flashing the bios
i think i bricked the motherboard, i did everything correctly like it seemed but after flashing, the pc turns on fine but there is a black screen, and it doesnt post. there is only power
i tried the mb vga, tried changine ram sticks, tried clearing cmos, i think its done
how i flashed it:
i prepared the bios file with mmtool and uefi tool using a guide from youtube, then removed the .cap and flashed it, i also applied DSDT Patch, UEFI Patch, REBAR DXE.
wish u could help on this one mate

you might did the step by step correctly, but maybe, just maybe, it is something around pad-file issues…

im not saying about it getting deleted or not, but on the p8z77m i’ve tested with my friend, dsdt and runtime patches gives black screen. making the padfiles that were gone re appear (means the pad-file hex alligned correctly), well actually it is anything above the pad files meaning its either the amiboardinfo or runtime or else. Cant figure out how…, but since that board dsdt have configured the m2ln at 36bit, runtime and dsdt wont be needed and it worked, as long as im not touching that dsdt and runtime patch, but since dsdt patch were needed, i am out of clue

1 Like

idk im not sure if they were needed but i was pretty careful and i still verfied that the pad file was correct. pad, raw, pad, raw. still, its a pretty risky operation and i was there to risk it all.

It’s not a desktop mobo, Lenovo IdeaPad 3 15IHU6.
I helped Jesthon with bios flashing. Now GPU HW Support: Yes, and that’s the only improvement.

1 Like

Hi @nkzbda,

  • Download the latest official bios file for the board.

  • Rename the file H61M-K.CAP

  • Put it on a USB stick that is formatted as FAT32 and has no folders.

  • Connect the USB stick and power the board on.

After some time (unsure how long) it should boot. When it does, enter the BIOS setup and set default values.

Good luck,


1 Like

The correct name is H61MK.CAP but…
These boards have no USB BFB or dual spi feature and their only official Asus option is “Kicking” the CrashFree recover …witch doesn’t help no one on “bad” mods flashed or doesnt work at all in general rule.
You’ll have to get a ch341a, take the soic8 ic off and reprogramme it.
File to use is the image out of the CAPSULE, original data from backup can be transferred with FD44 editor.

1 Like

Hello everyone,

I tried to implement NvStrapsRebar in my X99 Deluxe II BIOS but failed miserably. I was able to place the modules with UEFITool but the further process with UEFIPatcher has me lost and I wasn’t able to save the bios with MMTool.

Therefore, I am looking someone knowledgeable who can make it work.

Special Request: If possible, update/patch the miscellanous UEFI modules as well but downgrade microcode to 1C for 406F1.

BIOS Download: https://dlcdnets.asus.com/pub/ASUS/mb/LGA2011/X99-DLX_II/X99-DELUXE-II-ASUS-2101.zip?model=X99-DELUXE%20II

Thanks a lot!