Renesas uPD720200 USB 3.0 slow transfer (29MB/s) on Windows 10

Hi guys,

I have a problem with 2 of the 4 rear USB 3.0 ports from my ASrock X58 Extreme6 motherboard (latest bios 1.60c).
The upwards ports works perfect and have a transfer rate around 150MB/s.
With the two other (underneath) I get stuck slow at around 29MB/s.
The chips are Renesas/NEC uPD720200 revision 3 and are flashed with latest firmware.

I tried both Windows 10 native drivers and (from 2012) Renesas drivers.
Is there something I can do to fix this ?

@Nightsax :
Welcome at Win-RAID Forum!

I don’t know any, but maybe a user with a similar Renesas USB 3.0 Controller can help you.

Happy New Year!
Dieter (alias Fernando)

Thanks Fernando. Many views on this thread, but still no reply…
Anyone using Renesas uPD720200 USB 3.0 controllers under Windows 10 here ?
If anyone can get it to work well under Windows 10, please let me know which drivers/firmware you are using !

I would recommend as first step, just to be sure that there is no problem with your hardware, to test your USB 3.0 ports with the USB3CV Tool.

You need to plug a USB 3.0 device in your port for this to work and repeat it for both port. If you can’t, a USB 2.0 can do but it will only test for USB 2.0 speed and specifications. But because USB 2.0 speed is still faster than what you get, the test would still be valid and relevant.

Maybe this won’t solve your problem but, at least, it can eliminate this possible cause if your ports pass the test.

ASrock X58 Extreme6 uses a PLX PEX8608 bridge witch connects 6 usb3 and sata 6 controllers.
When u use some of theese devices the bandwith is lower.
If u want to test ur hard drive remove another devices from above and test it there.

Problem is worse now, maybe due to Windows 10 updates. Before at least 2 ports gave me USB3 transfer rates (150MB/s)
Now, none of my 6 USB (4 rear 2 front) give me more than around 29MB/s = USB2 speed.
I googled a lot but there doesn’t seem any drivers or support for x58 USB3, unfortunately
If i manually try to set a Renesas/NEC driver port fail to start at reboot.

Did you try Disable “USB selective suspend”?…ing-usb-devices

uPD720200 is a s*** chip. I have it on my W701, 8740w, W520, Thinkstation D30. Same symptoms happen on all of my devices. :confused:

First of all, install the drivers from here: USB 3.0/3.1 Drivers (original and modded) Having this driver is a huge help in terms of stability.
You need to dust clean the ports and sockets frequently and insert the USB 3.0 as fast and hard as possible, as if you are f***ing microsoft for pushing winbugs 10.

Also my HD Tune testing on those uPD720200, while it’s working, is capped at ~100MB/s. So yours 150MB/s is probably a bit unrealistic