[Reports] No NVMe Booting despite BIOS Mod

@gloobox :

Nobody sees the "Windows Boot Manager" within the BIOS right after the flash of an NVMe modded BIOS, but the BIOS boot option "Windows Boot Manager" will be visible after having installed Win10 in UEFI mode onto the NVMe SSD.

But BIOS boot option “Windows Boot Manager” will NOT be visible after having installed Win10 in UEFI mode onto the NVMe SSD in some MOBOs which I memtioned in the first post.

I agree with his opinion @lfb6 that these mobos’s bioses were not completely UEFI compliant.

@gloobox :
It may be possible, that some of the first mainboards with an UEFI BIOS don’t fully support booting in UEFI mode, but in this case it is a mistake done by the mainboard manufacturer while compiling the BIOS.

Ok, but then your following statement was absolutely misleading:

By the way: I have never written, that a BIOS module named "CSMCORE" is absolutely required for being able to get full NVMe support. Within my guide I have given the advice to search for that module, because
1. nearly all AMI UEFI BIOSes contain a module named "CSMCORE" and
2. some AMI UEFI BIOSes contain more than 1 "DXE Driver Volume", but the BIOS module named "CSMCORE is always within the one, where the NVMe module has to be inserted.

Thanks,I will post precisely henceforth.
Yes,I don’t konw whether this post could help others,but I really don’t want to mislead someone.

Hallo gloobox!

I noticed your comment regarding injecting NVMe boot support to intel DP45SG mobo. Well, thats exactly where I am heading to! Currently, my mobo is on the latest BIOS (0125) with the Xeon patch, running E5430. Now, since the mobo has two PCI-E slots, I would like run one for graphics and the other one with an Apple SSD-to-PCIE adapter, where my 512GB Samsung S4LN058A01-8030 will be placed (https://www.storagereview.com/images/YlR…KTdEq_huge.jpeg). It Sees the SSD in Win10, that is on a SATA HDD drive. I can even install Windows on that SSD as it is visible in Win10 install procedure, but it would not boot from it, obviously because of the lack of NVMe boot support in BIOS. Can you help me, please, how to make it?

I know I shall somehow inject the intel NVMe driver into the bios file and the flash it into the chip. But my last attempt ended up by non-posting mobo. So I desoldered the MX chip from the mobo and flashed it with the previously backuped .BIN file…

I obviously need some guidence to inject the NVMe driver correctly. Please, help.

Regards, George


On pre 2.0 UEFI the "windows boot manager" NVAR entry will be only shown as boot entry within the bios boot menu (F10).
The user could not select the entry from the bios setup as UEFI dual boot is unimplemented.

could you dump the bios file from your mobo ?I think you’d better dump it by SPI programmer.

Hi I found this post through google and cip67m. I was able to insert the NVME module under csmcore into a rom provided by Lenovo. I haven’t flashed it, because after reading this thread it seems that flashing a Non-UEFI compliant legacy BIOS with NVME mod inserted through MMtool will cause it to not post?

Hi ryambo1987!

Well, to be honest, I never thought of that point of view! And you might be very true that injecting EFI NVME module into the “legacy only” bios structure might definately lead to a boot failure. On the other hand, according to this document https://www.intel.com/content/dam/suppor…ductGuide01.pdf this board already contains Framwork for EFI and according to this document https://www.intel.com/content/dam/suppor…echProdSpec.pdf it also support EFI boot sequence. Even though it’s still disabled by default in the bios menu, it is there which means this board is sort of “UEFI ready” and shall be able to boot from EFI boot device. I believe this is how the Compatibility Support Mode alias CSM was born and started to appear in the bioses of all the manufacturers. It became a common part of every biso menu now.

But anyway, if you enable the UEFI boot in the bios menu, then boot from USB flash drive, lets say Windows installer, that was created on a modern Pc with UEFI BIOS and EFI boot as primary option form a GPT initiated drive, then this USB flash drive will no longer boot on any old Legacy bios based PC. But right because you enabled the EFI boot in the bios menu of the DP45SG board, it will boot from that USB drive on the DP45SG with no problem. And if proceeding with the intallation of Windows on a “new” non-initiated HDD or SSD, it will by default initate it in GPT not in MBR! You would later see that in Windows once you have finished the installation successfully. So maybe flashing the file modded by you shall not do any harm to any DP45SG board.

Would you share your modded file, please? I am very curious and interested in seeing that file!

Regards, George


I recently got my hands on an Intel Server S3420GP. I opened the .cap file downloaded from the Intel support page with MMTool 5.00.0007 but there is no CSM module. When I try to insert the NVMe module “NvmExpressDxe_4.ffs” into what I think is the correct volume index it throws “Invalid Volume Index”. I tried two other volumes but neither worked.

Extracting the ROM with AFUWINx64 and opening in MMTool throws “Error Loading Firmware Image (80000001h)”.

https ://www .intel .com.au/content/www/au/en/support/products/50528/server-products/legacy-server-products/intel-server-board-s3420gp-family .html#drivers-software
Intel Server S3420GP Software Support

The most recent BIOS is under the “Intel® Server Board S3420GP BIOS Only Update” download and the file is R0054.cap

I have so far successfully modded 3 UEFI BIOS’s with the NVMe driver but they all had the CSMCORE entry.

Regards, Kyle

Possibly not AMI bios. 6CE3993F-CF65-4348-8288-D99F06830944 has DXE entries and a CSM16 module, that’s where one could try with UEFITool.

Hi @ky56

Intel bioses can be modded with the NVME module, but it needs to be done with a bios dump (ideally from a hardware programmer), rather than the .bio / .cap file.

Thanks @lfb6 ,

I was avoiding using UEFITool and even forgot about it after reading that it causes problems with pad files. Once I found a source for MMTool i’ve just been using that.

That said UEFITool worked great patching the .cap file on this board. Thanks for the GUID pointer. No need for a hardware programmer this time. I used the IFlash32.efi tool that comes with the BIOS updater to flash the .cap file on the built-in EFI Shell.

What i was surprised by was how much free space there is on the BIOS flash. In contrast to the other boards i’ve done i had to use the NvmExpressDxe_small.ffs. This one could fit the full NvmExpressDxe_4.ffs with heaps left over.

It’s definitely an AMI BIOS but it may only be EFI and not UEFI as it’s quite old. Neither MMTool or UBU will recognize the file.

İ did modify the uefi just by just adding a working nvme module to the same volume of CSMCORE as suggested here https://winraid.level1techs.com/t/h…t-for-all-systems-with-an-ami-uefi-bios/30901

And i did it. Now i guess i coud boot from any nvme drive regardless of vendor/device id (to be confirmed). I think this method should work with all motherboards with Uefi.

As stated before because of uncomplete or early stage of dev of uefis some boards with experimental uefis like mine (Msi P45 platinum) do not have the option to swich secure boot off or on and boot from medias in uefi only mode. But i’have managed to boot from my nvme drive attached via pcie express adapter. İ followed the guide and failed at first. The problem wasn’t related to the modified uefi. The problem was i couldn’t start a uefi windows setup usb because there are no boot options for uefi (Uefi only mode). So here is what i did:
1- I’ve created a bootable windows setup usb with rufus by selecting Large fat32 and uefi mode. Ntfs files are not recognized with this uefi so it is important to format in fat32.
2- Restarted pc entered uefi setup with F2 or Del and selected uefi shell for boot override and started in the uefi shell.
3- I then mapped devices by typing map and found my usb drive (blk1 or blk0 depending on configuration).
4- then typed Blk0: to switch to the usb drive
5- Typed cd efi\boot\bootx64.efi to start windows install. This was the only way to boot a uefi windows installation

For the next part i did :

6- Press “Shift+F10”;
c-sel disk 0
(the NVMe SSD drive listed should usually be “0”)
d-clean disk
e-convert gpt
7- Continue Windows installation on NVMe SSD .
The pc restarted a couple of times then it booted from the nvme drive. And i was able to boot to windows.

I did try to mod the UEFİ myself before but i thought i’have failed because i couldn’t boot from the usb with a bootable uefi windows install disk. Since the nvme drive wasn’t found anywhere in the boot menu i couldn’t select it for a mbr installation either. İt seems that with a uefi installation of Windows via the uefi shell creates a windows boot manager which than appears as a bootable option in the uefi setup menu (and not before).

E7512IMS.rar (3.1 MB)

1 Like

This one is actually booting from nvme why is this even here?. İt’s an uefi bios with bootable gpt partitioned nvme drive.

1 Like

According to the latest reports it seems, that the amount of mainboards, which are definitively affected by the issue “no NVMe booting despite BIOS modification” is much lower than you thought while starting this thread.
If you should have the required time, please update the start post.
Thanks and Happy New Year!

I have almost the same mobo your friend has (Msi p45 platinum). These motherboards have a different some how incomplete early stage uefi bios. I managed to boot from nvme in ahci mode.
My mobo didn’t detect the nvme as a drive although i modded the uefi and installed the nvme efi driver. İ couldn’t even boot from uefi windows bootable usb disk. Then i had the idea of booting from the uefi shell and start windows installation from there. On select disk menu of windows setup i hit shift 10 to start diskpart and created a gpt partition on the nvme. Than i was able to install windows on it . İt succesfully finished and i could see a bootable windows boot manager from the boot menu of the uefi bios.

It’s a bit awkward since i thought i would be able to see the drive and install windows in mbr mode but wasn’t able to do so. I guess this uefi is only able to see the drive when it has a succesfull uefi windows on it.

Maybe this could also work with yours?

@Koekieezz i saw you were interested about MSI P45 UEFI BIOS might want to ask him for more info about it.

I have a lenovo is6xm mainboard ,it have this problem,the nvme hdd cannot bootable.i have another lenovo is7xm mainborad ,maybe it can bootable,I am ready to test it after a few days.

lenovo is7xm test ok.the pci to nvme hdd can bootable.